










<!DOCTYPE html>


	
	
		
	
		
	
	
	
	

<html lang="en">
	












<head>
	<link rel="alternate" hreflang="en" href="https://www.techhive.com/article/3447398/pani-smart-home-water-monitor.html" />	
	<meta charset="utf-8" />
	<title>Pani Smart Home Water Monitor promises an easier way to keep tabs on your water usage | TechHive</title>
	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
	
	
	<script>
	function getQueryVariable(variable) {
		var query = window.location.search.substring(1);
		var vars = query.split("&");
		for (var i=0;i<vars.length;i++) {
			var pair = vars[i].split("=");
			if(pair[0] == variable){return pair[1];}
		}
		return(false);
	}
	</script>
	
	<!-- ad-related js -->
	
	<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
	
	<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
	
	
	<script type="text/javascript" src="/www/js/apollo-locales.js"></script>
	
	











<script src="//d2zv5rkii46miq.cloudfront.net/0/latest/cmp_shim.js"></script>

<script>
var consent = consent || {};
consent.isEU = consent.isEU || null;
consent.personalization = consent.personalization || null;
consent.ads = consent.ads || {};
consent.ads.queue = consent.ads.queue || [];

consent.infostorage = consent.infostorage || {};
consent.infostorage.queue = consent.infostorage.queue || [];

consent.adsel = consent.adsel || {};
consent.adsel.queue = consent.adsel.queue || [];

consent.contentsel = consent.contentsel || {};
consent.contentsel.queue = consent.contentsel.queue || [];

consent.socmedia = consent.socmedia || {};
consent.socmedia.queue = consent.socmedia.queue || [];

consent.tealium = consent.tealium || {};
consent.tealium.queue = consent.tealium.queue || [];

consent.digitalelement = consent.digitalelement || {};
consent.digitalelement.queue = consent.digitalelement.queue || [];

consent.purposes = consent.purposes || {};
consent.purposes.standard = consent.purposes.standard || [];
consent.purposes.custom = consent.purposes.custom || [];
consent.vendors = consent.vendors || {};
consent.vendors.standard = consent.vendors.standard || [];
consent.vendors.custom = consent.vendors.custom || [];

var dataLayer = window.dataLayer = window.dataLayer || [];
</script>



<style type="text/css">
#sp_privacy_manager_container {
	z-index: 10000000 !important;
}
</style>

<script> 											
window._sp_ = window._sp_ || {};
window._sp_.config = window._sp_.config || {};

//Replace YOUR_ACCOUNT_ID with the account ID provided
//by Sourcepoint
window._sp_.config.account_id = 146;

// replace 'mms.sp-prod.net' with your CNAME'd messaging subdomain		
window._sp_.config.mms_domain = 'cmp.techhive.com' ; 
//window._sp_.config.mms_domain = 'mms.sp-prod.net' ; 

// messaging-specific configuration
window._sp_.mms = window._sp_.mms || {};
window._sp_.mms.cmd = window._sp_.mms.cmd || [];

//CMP Flags
window._sp_.config.cmp = _sp_.config.cmp || {};
window._sp_.config.cmp.enabled = true;
window._sp_.config.cmp.waitForConsentData = true;

//Code to call the server and display a message
window._sp_.mms.cmd.push( function () {
    window._sp_.mms.startMsg();
});						
</script>

<script src="/www/js/messaging.js"></script>

<script>
__cmp('getConsentData',null,function(e){
	
	consent.isEU = e.gdprApplies;
	if (!consent.isEU) {
		
		consent.personalization=true;
		$(window).trigger("runConsent", [consent.ads.queue]);
		$(window).trigger("runConsent", [consent.infostorage.queue]);
		$(window).trigger("runConsent", [consent.adsel.queue]);
		$(window).trigger("runConsent", [consent.contentsel.queue]);
		$(window).trigger("runConsent", [consent.socmedia.queue]);
		$(window).trigger("runConsent", [consent.digitalelement.queue]);
		$(window).trigger("runConsent", [consent.tealium.queue]);
		dataLayer.push({
			'event': 'consentKnown' 
		});
		bindReshowCmp();
	}
	else if (e.consentData !== null && e.consentData !== "") { // else if.. visitor is from EU and consent is known...
		getConsentInfo();
		bindReshowCmp();
	}
	else { //else consent is not known
	    bindReshowCmp();
	}
});

function getConsentInfo() {
	
	__cmp('getVendorConsents',[],function (e) {
		
		consent.purposes.standard = Object.keys(e.purposeConsents);
		consent.vendors.standard = Object.keys(e.vendorConsents);
		
		consent.personalization = consent.purposes.standard.includes("2");
		
		
		
		
		
		
		
		if (consent.purposes.standard.includes("1")) { // if information storage consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.infostorage.queue]);
		}
		if (consent.purposes.standard.includes("3")) { // if ad selection consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.adsel.queue]);
		}
		if (consent.purposes.standard.includes("4")) { // if content selection consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.contentsel.queue]);
		}
		//special case for Tealium
		if (consent.purposes.standard.includes("1") && consent.purposes.standard.includes("2") && consent.purposes.standard.includes("3") && consent.purposes.standard.includes("4") && consent.purposes.standard.includes("5") && consent.vendors.standard.includes(522)) {
			
			$(window).trigger("runConsent", [consent.tealium.queue]);
		}
		
		//special case for Digital Element
		if (consent.purposes.standard.includes("2") && consent.purposes.standard.includes("3") && consent.purposes.standard.includes("4") && consent.purposes.standard.includes("5")) {
			
			$(window).trigger("runConsent", [consent.digitalelement.queue]);
		}
	});

	__cmp('getCustomVendorConsents',[],function (e) { 
		
		consent.purposes.custom = [];
		e.consentedPurposes.forEach(function(item, index) {
			consent.purposes.custom.push(item.name);
		});
		
		consent.vendors.custom = [];
		e.consentedVendors.forEach(function(item, index) {
			consent.vendors.custom.push(item.name);
		});
		
		
		
		if (consent.purposes.custom.includes("Social Media Consents")) { // if social media consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.socmedia.queue]);
		}
		
		
		if (consent.vendors.custom.includes("Google Ad Manager")) {
			
			$(window).trigger("runConsent", [consent.ads.queue]);
		}
		
	});
	
	dataLayer.push({
		'event': 'consentKnown' 
	});
}

var idgCMPSourcepointCallback = function(){
	if (consent.isEU) {		
		getConsentInfo();
	}
}

$(window).on("runConsent", function(event, queueToRun) {
		watchConsentQueue(queueToRun)
});

function runQueue(queue){
	for (var x=0;x<queue.length;x++) {
		var nextFn = queue.shift();
		nextFn();
		
	}	
}

function watchConsentQueue(queue){
	setInterval(function() { runQueue(queue); },500);
}
function bindReshowCmp() {
	var url = document.location.pathname;
	if (url.indexOf("/about/member-preferences") > -1) {
		$(document).ready(function() {
			$(".cmpSettings").show();
			$(".reshowLink").on("click", function(e) {
				e.preventDefault();
				window._sp_.privacyManager.loadPrivacyManagerModal(3933, '5cd195e5f9f3332a80a0e25f');
			});
		});
	}
}
</script>




	
	
	
		










<script>
// this javascript is for retrieving locale-specific ad units for DFP - see mapping in apollo-locales.js
// getting locale and editions for the site the reader is viewing
let brandAbbrev = "th";
let brandConfigBrandId = "4";
//let myLocale = getLocale(); // getting locale on page load from URL, IP, geolocation - this will always be something. If 0, it's the global/default/core view.
let countryCode = "";
let getSlugFromId = getApolloLocaleIdMap();
let getIdFromSlug = getApolloLocaleSlugMap();

// if selectedLocale cookie exists, get locale
if (typeof getSelectedLocale() !== 'undefined'  && getSelectedLocale() === getLocale()) { // get locale from cookie if available otherwise, use another locale source (from geolocation, url slug, etc.)
 	countryCode = getSlugFromId[getSelectedLocale()];
} else {
	countryCode = getSlugFromId[getLocale()];
}
//console.log("+++ 1) in locales.editions.jsp - COUNTRY CODE IS DEFINED AS: "+countryCode+"+++");
// if countryCode is empty string at this point, it means localeId = 0 which is global (default/core)...
if (countryCode == "") {
	countryCode = "us"; // country code for default global is currently US
}
//console.log("====INSIDE locales-editions.jsp - getSelectedLocale() = " + getSelectedLocale() + " and getLocale() = " + getLocale() + " and countryCode = " + countryCode);
//US social media accounts are the default if locale cannot be determined
var twitterUrl = "https://twitter.com/TechHive";
var linkedInUrl = "";
var facebookUrl = "http://www.facebook.com/techhivemedia";
var youTubeUrl = "";
var twitterHandle = "TechHive";

if (countryCode === 'asean') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'middle-east') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'uk') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'in') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
	youTubeUrl = "";
}
if (countryCode === 'africa') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
	youTubeUrl = "";
}

//US business unit is the default if locale cannot be determined
var busUnit = "";
//cookie policy page
var localeEdition = "";
var busUnitAddress = "";
if (countryCode === 'asean') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'middle-east') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'uk') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'in') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'africa') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
</script>

	

	
    <script src="/www/js/init_device.js"></script>    
    
    	
    
    
   	
   	
		
			















	<script async="async" src="//cdn.adsafeprotected.com/iasPET.1.js"></script>




	<script async src="//js-sec.indexww.com/ht/p/183980-58723449634151.js"></script>

	
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20191022113641"></script>

<script type="text/javascript">
	if (adLayer==null || adLayer=='undefined') {
		var adLayer=[];
	}
	
		
			adLayer["itemType"]="article";
		
		
	
</script>
	
<script type="text/javascript">
	// Set up ad related variables
	try {
		IDG.GPT.unitName = "/8456/IDG.US_CSMB_TechHive.com";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}

	try {
		IDG.GPT.unitName = IDG.GPT.unitName + "/" + "home-tech_section";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	// global variables
	var global_ShowSuper = true;
	var global_ShowHero = false;
	
	//XFP global targeting, more targeting thm_pre
	var url = window.location.href;
	if(url.indexOf("?")>1){
		url=url.split('?')[0];
	}
	

	try {
		IDG.GPT.addTarget("URL", encodeURIComponent(url));
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	try {IDG.GPT.addTarget("zone", 'article/sensors');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("channel", 'connected-home');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("productId", '1442852');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("articleId", '3447398');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("type", 'news');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("typeId", '2');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("templateType", 'article-default');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	
	try {IDG.GPT.addTarget("categoryIds", ['3978','3932','3067']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("categorySlugs", ['sensors','connected-home','home-tech']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {IDG.GPT.addTarget("goldenIds", ['425','415','1027']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {
		if (null != IDG.GPT.getQsVal("env")) {		
			IDG.GPT.addTarget("env", IDG.GPT.getQsVal("env").replace(/\W/g, "") );
		}
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	
	
		try {
			IDG.GPT.addTarget("author", 'Ben Patterson');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
		

	try {
		IDG.GPT.addTarget("page_type", '');
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	

	
	
	
	
		try {
			IDG.GPT.addTarget("insiderContent", 'false');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
	
	
</script>



<script type="text/javascript">
	
	
	
	
		
		
		
		
		
		
		
		
	
	
	
	
</script>
  
<script src="/www.idgcsmb/js/thm_pre.js?v=20191022113641"></script>

	<script type="text/javascript">
        $thm.useBusinessData=true;
	</script>


	
	
		<script>
		// IDGMPM-16419 - moved out of adsel queue for IDGMPM-16933
		googletag.cmd.push(function() {
		  if (googletag.pubads().getTargeting('permutive').length == 0) {
		    var kvs = localStorage.getItem('_pdfps');
		    googletag.pubads().setTargeting('permutive', kvs ? JSON.parse(kvs) : []);
		    console.log('ad targeting permutive kvs: ', kvs);
		  }
		});
		</script>
	

<script type="text/javascript" src="/www/js/ads/gpt_starter.js?1234"></script>
	<script>
		loadGPT();
	</script>

	
		<script type="text/javascript" src="/www/js/ads/ias_gpt_launcher.js?v=20191022113641"></script>
	

	



		
		
	

	

    <link rel="canonical" href="https://www.techhive.com/article/3447398/pani-smart-home-water-monitor.html" />
	
	
	
	
	
	<meta name="description" content="Compatible with most common water fixtures, the $70 wireless sensor detects leaks and doles out water conservation tips via an iOS or Android app." />
	<meta itemprop="image" content="https://images.idgesg.net/images/article/2019/10/pani_smart_water_monitor_main-100815178-medium.jpg">
	
	
		
			<meta name="DC.date.issued" content="2019-10-23" />
			<meta name="date" content="2019-10-23" />
			
		
		
		
		 
	
	
	<link rel="amphtml" href="https://www.techhive.com/article/3447398/pani-smart-home-water-monitor.amp.html" />

	
		<link rel="stylesheet" href="https://use.typekit.net/azu1qsr.css" />
	
	
	<meta property="twitter:account_id" content="499275959" />
	<meta property="fb:app_id" content="1566936830273000" />
	
		
		
		
			
			
				
			
			
			
		
		
	<meta property="og:type" content="article">	
	<meta property="og:url" content="https://www.techhive.com/article/3447398/pani-smart-home-water-monitor.html">
    <meta property="og:site_name" content="TechHive">   
    
    
    	<meta property="og:image" content="https://images.idgesg.net/images/article/2019/10/pani_smart_water_monitor_main-100815178-large.3x2.jpg">
    	<meta property="og:image:width" content="1200">
    	<meta property="og:image:height" content="800">
    
    
    
    
    
    
    	<meta property="og:title" content="Pani Smart Home Water Monitor promises an easier way to keep tabs on your water usage"> 
    
    
    <meta property="og:description" content="Compatible with most common water fixtures, the $70 wireless sensor detects leaks and doles out water conservation tips via an iOS or Android app.">
    
    

	
	<meta name="displaytype" content="article" />
	
	<meta name="associatedproducts" content="phyn plus" />
	
	<meta name="source" content="techhive" />
	
	<meta name="category" content="sensors,connected home,home tech" />
	
	<meta name="storytype" content="news" />
	
	
	
		<meta name="google-site-verification" content="GHmsZtoU3FlVFNZp6NaQob2y1ZBU9WoIhanodiETb2o" />
	
	
	
		<meta name="msvalidate.01" content="05F49F041AAA61528A0A3329A6C0C02D" />
	
	
	
	
	
		<link id="mobile-size" rel="stylesheet" href="/www.idgcsmb/css/inline-header-mobile.css?v=20191022113641" />
		<script>
			if (window.matchMedia("(min-width: 768px)").matches) {
				document.getElementById('mobile-size').insertAdjacentHTML('afterend', '<link id="desktop-size" rel="stylesheet" href="/www.idgcsmb/css/inline-header.css?v=20191022113641" />');
			}
		</script>
		<link rel="stylesheet" href="/www.idgcsmb.th/css/inline-header.css?v=20191022113641" />
	 
	
	
	    
	
	<link rel="stylesheet" href="/www.idgcsmb/css/print.css" media="print" />
	
	<!-- this must be first -->
	<link href="/www.idgcsmb/css/colorbox.css" rel="stylesheet" />
	<!-- <link href="/www.idgcsmb/css/equalizer.css" rel="stylesheet" /> -->
	<link href="/www.idgcsmb/css/global-layout.css?v=20191022113641" rel="stylesheet" />
	<link href="/www.idgcsmb.th/css/global-layout.css?v=20191022113641" rel="stylesheet" />
	<link href="/www.idgcsmb/css/global-colors.css?v=20191022113641" rel="stylesheet" />
	<link href="/www.idgcsmb.th/css/global-colors.css?v=20191022113641" rel="stylesheet" />
	<link href="/www.idgcsmb/css/global-typography.css?v=20191022113641" rel="stylesheet" />
	<link href="/www.idgcsmb.th/css/global-typography.css?v=20191022113641" rel="stylesheet" />
	
	
	
	
		
		
			
			
				<link rel="stylesheet" href="/www/css/article.css?v=20191022113641" />	
			
			
		<link href="/www.idgcsmb.th/css/article.css?v=20191022113641" rel="stylesheet" />
	
	
	<link href="/www.idgcsmb/css/video.player.css?v=20191022113641" rel="stylesheet" media="all" />
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	  
	<!-- this must be last -->
	<link href="/www.idgcsmb/css/helpers.css" rel="stylesheet" />
	
	
		<script>
		try {
			performance.mark("mark_head_css_done_blocking");
		}
		catch(e) {
			console.log("Error saving performance mark -- this function may not be supported in this browser");
		}
		</script>
	
	<!--  fav and touch icons -->
	<link rel="shortcut icon" href="/www.idgcsmb.th/favicon.ico"/>
	<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://csmb.staticworld.net/images/furniture/techhive/th-apple-touch-icon-precomposed-144.png" />
	<link rel="apple-touch-icon-precomposed" sizes="129x129" href="https://csmb.staticworld.net/images/furniture/techhive/th-apple-touch-icon-precomposed-129.png" />
	<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://csmb.staticworld.net/images/furniture/techhive/th-apple-touch-icon-precomposed-114.png" />
	<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://csmb.staticworld.net/images/furniture/techhive/th-apple-touch-icon-precomposed-72.png" />
	<link rel="apple-touch-icon" href="https://csmb.staticworld.net/images/furniture/techhive/th-apple-touch-icon-precomposed.png" />
	
	

	
		
	
	
	
	
	<script type="text/javascript">
	var _sf_async_config={};
	_sf_async_config.uid = 29363;
	
	
	
		_sf_async_config.useCanonical = true;
	
	
	
		
						
	_sf_async_config.authors="Ben Patterson";
			
		
			
			
	_sf_async_config.sections="sensors";	
		
		
		
		
	_sf_async_config.domain = "techhive.com";
	</script>
	
	
	
	
	
	<!-- <link href="/www.idgcsmb/webfonts/ss-social.css" rel="stylesheet" />
	<link href="/www.idgcsmb/webfonts/ss-standard.css" rel="stylesheet" />  -->
	<!--[if lte IE 8]>  
		<link href="/www.idgcsmb/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->


	
	<!-- Use Twitter Summary Card with Large Image for articles and videos; summary otherwise -->
	
		
				<meta name="twitter:card" content="summary_large_image">
		
		
	
	<meta property="twitter:description" content="Compatible with most common water fixtures, the $70 wireless sensor detects leaks and doles out water conservation tips via an iOS or Android app.">
	
	
		
			<meta name="twitter:site" content="@TechHive">
			
			
				
					<meta name="twitter:image" content="https://images.idgesg.net/images/article/2019/10/pani_smart_water_monitor_main-100815178-orig.jpg" />
				
				
						
			
				
				
					<meta name="twitter:title" content="Pani Smart Home Water Monitor promises an easier way to keep tabs on your water usage">
				
				
			
			
				
				
					<meta name="twitter:url" content="www.techhive.com">
				
			
		
		
		
		
		
	
	












<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "WebSite",
		"url": "https://www.techhive.com/",
		"potentialAction": {
		"@type": "SearchAction",
		"target": "https://www.techhive.com/search?query={search_term}",
		"query-input": "required name=search_term"
		}
	}
</script>
	
	
	
	
	<script src="/www/js/ads/ads.js"></script>
	
	<script>var oneRegPlacementID = "";</script>
	
	
	
	
	
		
			
				
			
			
			
			
			
			
		
		
		
	
	
	
		
		
		
		
		  
		
	
	
	
	
	
	
	
	  	 
	    
	    
	 
	 
	
	
	
	
	
	
	
	
	
	
	<script>
	var supMontMods = false;
	</script>
	


	
	
			
			
			
				
					
					
				











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2806 blox4.simple  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
					
						
					
				
				
			
		















	
		
		
	
		
		
	
		
		
	


	


			
	
	
	
	
	




	
		
	
		
	
	



	
	
	
	
	
	
		
			
				
				
				
					
				
			
			
			
			
		
		
		
	
	
	
	
	
	
	
	 
	 
		<script>
		window.ntvConfig = window.ntvConfig || {} ;
		window.ntvConfig.keyValues = window.ntvConfig.keyValues || {};
		var segs = localStorage.getItem('_pnativo');
		if (segs) {
		  window.ntvConfig.keyValues.permutive = JSON.parse(segs).join(",");
		}
		</script>
	
	 
	 
	
		<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
	
	
	
	<script type="text/javascript">
		var prodNames = '';
		var prodManufacturers = '';
		var prodCategories = '';
		var prodVendors = '';
	</script>
		
	
	
	<script>
	var idg_uuid = $.cookie('idg_uuid') || "";
	
	//get edition from countryCode
	var edition = '';
	if (typeof countryCode !== 'undefined') {//should be defined in locales-editions.jsp if brand has editions
		edition = countryCode;
	}

	var dlJobFunction = '';
	var dlJobPosition = '';
	var dlIndustry = '';
	
	dataLayer.push({
		'articleId': '3447398',
		'articleDisplayId':'1',
		'articleHasVideo':'false',
		'articleLocale': '',
		'articleTitle': 'Pani Smart Home Water Monitor promises an easier way to keep tabs on your water usage',
		'articleType': 'News',
		'audience':'consumer',
		'author':'Ben Patterson',
		'blogName':'',
		'brandpost': 'false',
		'categoryIdList':'3978,3932,3067',
		'categoryIdPrimary': '3978',
		'contentStrategy': '',
		'contentType':'news',
		'datePublished':'2019-10-23',
		'dateUpdated':'2019-10-23',
		'daysSincePublished':'0',
		'daysSinceUpdated':'0',
		'displayType':'article',
		'edition':edition,
		'environment':'production',
		'ga_enabled':'true',
		'gaTrackingId':'UA-30870572-1',
		'geolocEnabled':'true',
		'goldenTaxonomyIdPrimary': '425',
		'goldenTaxonomyIdList': '415,1027',
		'isBlog':'false',
		'isInsiderContent':'',
		'isICN': 'false',
		'oneRegPlacementID':oneRegPlacementID,
		'pageNumber':'1',
		'platform':'Web',
		'podcastSponsored': 'false',
		'primaryCategory': 'sensors',
		'prodCategories':prodCategories.slice('|', -1),
		'prodManufacturers':prodManufacturers.slice('|', -1),
		'prodNames':prodNames.slice('|', -1),
		'prodVendors':prodVendors.slice('|', -1),
		'ancestorGoldenCategories': '',
		'primaryCategoryList': 'connected homes,home tech',
		'primaryAncestorCategoryList': '',
		'property': 'techhive',
		'propertyCountry':'US',
		'purchaseIntent':'',
		'skimlinksId':'111346X1569484',
		'source':'techhive',
		'sponsorName':'',
		'suppressMonetization': supMontMods.toString(),
		'tags': '',
		'userId':idg_uuid,
		'videoAutoplay':'false',
		'youtubeId':''
	});
	</script>
	 
	
	
	










<script>
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var adBlockStatus = 'false';
	
	function AdBlockEnabled() {
		var ad = document.createElement('ins');
		ad.className = 'AdSense';
		ad.style.display = 'block';
		ad.style.position = 'absolute';
		ad.style.top = '-1px';
		ad.style.height = '1px';

		if (document.body != null) {
			document.body.appendChild(ad);
			var isAdBlockEnabled = !ad.clientHeight;
			document.body.removeChild(ad);
		}

		return isAdBlockEnabled; 
	}
	// AdBlockEnabled() was successful document.body not null
	if (AdBlockEnabled() != undefined) {
		adBlockStatus = AdBlockEnabled().toString();
	}
	// not successful - look for ads.js
	if (document.body == null) {
		if (window.canRunAds === undefined) {
			adBlockStatus = 'true';
		} else {
			adBlockStatus = 'false';
		}
	}
	
	dataLayer.push({
		'adBlockStatus': adBlockStatus
	});
</script>





	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-WR6LD2P"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-WR6LD2P');</script>
	<!-- End Google Tag Manager -->

	
		<script>
			try {
				performance.mark("mark_head_js_done_blocking");
			}
			catch(e) {
				console.log("Error saving performance mark -- this function may not be supported in this browser");

			}
		</script>
	
	
	
	
	
	<script src="https://www.google.com/recaptcha/api.js" async defer></script>
	
	
	
		<script>
			var numberFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "number") {
			    return dataLayer[0][property];
			  }
			  return null;
			};
			
			var stringFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "string") {
			    return dataLayer[0][property];
			  }
			  return "";
			};
		</script>
	
	
	
	

	
		










<script>
// IDGMPM-16419 - updated in IDGMPM-16933
	!function(n,e,o,r,i){if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}}(document,window.permutive,"f5b3be27-f789-4ef1-8867-37c67da5b361","84c7e805-5ce9-41f4-b988-3529488bab1c",{});
	  permutive.addon('web', {
	    page: {
	      type: stringFromDataLayer('displayType'),
	      language: 'en',
	      tags: stringFromDataLayer('tags').split(","),
	      audience: stringFromDataLayer('audience'),
	      description: 'Compatible with most common water fixtures, the $70 wireless sensor detects leaks and doles out water conservation tips via an iOS or Android app.',
	      
	      article: {
	        authors: stringFromDataLayer('author').split(","),
	        description: 'Compatible with most common water fixtures, the $70 wireless sensor detects leaks and doles out water conservation tips via an iOS or Android app.',
	        id: stringFromDataLayer('articleId'),
	        isInsiderContent: (stringFromDataLayer('isInsiderContent') == "true"),
	        modifiedAt: "2019-10-23T07:01:27Z",
	        publishedAt: "2019-10-23T07:01:27Z",
	        source: stringFromDataLayer('source'),
	        title: stringFromDataLayer('articleTitle'),
	        type: stringFromDataLayer('articleType'),
	        purchaseIntent: stringFromDataLayer('purchaseIntent')
	      },
	      
	      ads: {
	        adblocker: (adBlockStatus == "true"), //detected further up the page
	        enabled: true
	      },
	      gTax: {
	        primaryIds: [425,],
	        secondaryIds: [415,1027,]
	      },
	      tax: {
	    	  primaryCategories: stringFromDataLayer('ancestorGoldenCategories').length > 0 ? stringFromDataLayer('ancestorGoldenCategories').split(",").concat(stringFromDataLayer('primaryCategory')) : [stringFromDataLayer('primaryCategory')] ,
	          secondaryCategories: stringFromDataLayer('primaryAncestorCategoryList').length > 0 ? stringFromDataLayer('primaryCategoryList').split(",").concat(stringFromDataLayer('primaryAncestorCategoryList').split(",")) : stringFromDataLayer('primaryCategoryList').split(",")
	      }
	    }
	  });

	  dlJobPosition = dlJobPosition || null;
	  dlIndustry = dlIndustry || null;

	  if (dlJobPosition !== '' || dlIndustry !== '' || stringFromDataLayer('userId') !== '') {
		  if (stringFromDataLayer('userId') !== '') {
				var userData = {};

				var hermesAttrs = {
					"companySize" : "543ea0bd-604a-4011-99e7-806fc8979b5e",
					"country" : "ea76d652-29bd-4a6c-ae50-a5d08ea28c5e",
				};
				var userKeys = Object.keys(hermesAttrs);

				$.ajax({
					type: "get",
				    crossDomain: true,
					url: "https://lqxgcyk808.execute-api.us-east-1.amazonaws.com/prod_h2/api/v1/profiles/" + idg_uuid,
					dataType: "json",
					data: {}, 
					headers : {
						"Content-Type": "application/x-www-form-urlencoded",
						"x-api-key":"HLyMXLISSW7HAYGgbx2Vb1Gf1OLcGmMG5BcwZ4Vb"
					}
				}).done(function(responseData){ 
					userKeys.forEach(function(key) {
						if (typeof(responseData.attrs[hermesAttrs[key]].option_label) !== "undefined") { 
							userData[key] = responseData.attrs[hermesAttrs[key]].option_label;
						}
						else { 
							userData[key] = responseData.attrs[hermesAttrs[key]].value;
						}
					});

					window.permutive.track('User', {
					  companySize: userData['companySize'],
					  country: userData['country'],
					  id: (stringFromDataLayer('userId') !== "" ? stringFromDataLayer('userId') : null),
					  jobIndustry: (dlIndustry !== "" ? dlIndustry : null),
					  jobPosition: (dlJobPosition !== "" ? dlJobPosition : null),
					  loggedIn: (stringFromDataLayer('insiderSignedIn') == 'true')
					})
					
					
				}).fail(function(data){
					//console.log("Error retrieving data: " + data.responseJSON.error);
				});  

			}
			else {
				window.permutive.track('User', {
				  companySize: null,
				  country: null,
				  id: (stringFromDataLayer('userId') !== "" ? stringFromDataLayer('userId') : null),
				  jobIndustry: (dlIndustry !== "" ? dlIndustry : null),
				  jobPosition: (dlJobPosition !== "" ? dlJobPosition : null),
				  loggedIn: (stringFromDataLayer('insiderSignedIn') == 'true')
				});
			}
	  }
	
	  //product js vars defined in document-head	  
	  if (prodNames !== '' || prodManufacturers !== '' || prodCategories !== '' || prodVendors !== '') {
		  window.permutive.track('Product', {
			  names: stringFromDataLayer('prodNames').split("|"),
			  categories: stringFromDataLayer('prodCategories').split("|"),
			  manufacturers: stringFromDataLayer('prodManufacturers').split("|"),
			  vendors: stringFromDataLayer('prodVendors').split("|")
		});

	  }
		 

</script>

<script>
	$.ajax({
		url: "https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js",
	  	dataType: "script",
	  	cache: true, // default is false
	  	async: true // default is true
	});
</script>
	
	
	
	
	
</head>

	<body id="article3447398" class="article techhive">
		 
		
			<div id="skinAdTarget"></div>
		

		
			<div id="superadunit" class="hidden">
			    <div class="ad">
			    	<div class="ad-header">
						<div class="brand-logo"></div>
						<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
					</div>
					
						
						
						
					




















	
		
		
		
		
			<div id="gpt-superstitial" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-superstitial", "true");
	    			$('#gpt-superstitial').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-superstitial [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
			    </div><!-- / ad -->
			</div><!-- / super -->		
		

		











	
	
		
		
		
		
		
			
		
				
					
				











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	


		
		
		
		
		
		
		
		
		
		<div id="page-top">
				<div class="page-top-inner" itemscope itemtype="http://schema.org/Organization">
				<link itemprop="url" href="http://www.techhive.com"> 
			    
		
						<header id="banner">
						<a id="mobile-offscreen-toggle" class="ss-standard ss-rows" href="javascript://"></a>
						<div id="logo">
						<a href="/" class="ir banner-logo" id="logoImage">Home</a>
						</div>
						<div id="mobile-search-toggle" class="ss-standard ss-search"></div>
						
						</header>
						
		
		
						














		<ul id="th-nav">
			<li class="newsNav"><a href="/news/" id="newsNav">News</a></li>
			<li class="reviewsNav"><a href="/reviews/" id="reviewsNav">Reviews</a></li>
			
				
				
					<li class="th-category-nav"><a href="/category/connected-home/">Connected Home<span class="ss-navigatedown right"></span></a>
					
						<ul class="th-sub-nav">
			            	
							

		            		
							
								<li><a href="/category/smart-appliance/">Appliances</a></li>
								<li><a href="/tag/gardengarage/">Garden &amp; Garage</a></li>
								<li><a href="/category/home-control/">Home Control</a></li>
								<li><a href="/category/home-networking/">Home Networking</a></li>				
								<li><a href="/category/home-security/">Home Security</a></li>
								<li><a href="/category/hubs-controllers/">Hubs &amp; Controllers</a></li>
								<li><a href="/category/internet-of-things/">Internet of Things</a></li>
								<li><a href="/tag/kitchen/">Kitchen</a></li>	            		
								<li><a href="/category/lighting/">Lighting</a></li>
								<li><a href="/category/security-cameras/">Security Cameras</a></li>
								<li><a href="/category/thermostats/">Thermostats</a></li>
			            			            		
		            		
		            		
		            		
						</ul><!-- /.th-sub-nav -->
					
					</li><!-- /.th-category-nav -->
				
			
				
				
					<li class="th-category-nav"><a href="/category/entertainment/">Entertainment<span class="ss-navigatedown right"></span></a>
					
						<ul class="th-sub-nav">
			            	
							

		            		
									            		
		            		
		            		
		            		
								<li><a href="/tag/cordcutting/">Cord Cutting</a></li>						
								<li><a href="/category/home-audio/">Home audio</a></li>
								<li><a href="/category/tv/">TVs</a></li>
								<li><a href="/category/streaming-hardware/">Streaming Hardware</a></li>
								<li><a href="/category/streaming-media/">Streaming Media</a></li>
								<li><a href="/category/streaming-services/">Streaming services</a></li>		            		
							
						</ul><!-- /.th-sub-nav -->
					
					</li><!-- /.th-category-nav -->
				
			
				
				
			
				
				
			
			<li class="th-category-nav"><a href="/deals">Deals</a></li>
			<li class="th-category-nav"><a href="/resources/" id="resourcesNav">Resources</a></li>
		</ul><!-- /.th-nav -->





						
		
		
						<div id="th-social">					                  
							<a href="http://www.facebook.com/techhivemedia" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
								&#xF610;
							</a>
							<a href="https://twitter.com/TechHive" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
								&#xF611;
							</a>
							
						</div><!-- /#th-social -->
		
						
						<div id="th-search">
						<form id="search-form" action="/search">
							<input type="search" name="query" id="banner-search-term" class="inactive searchbox-input-class" value="">
							<input type="submit" name="submit" id="banner-search-submit" value="search" />
							<a id="magGlassClick" class="ss-icon ss-standard" type="submit">&#x1F50E;</a>
						</form>
						</div>
						
						
						<div id="saved-comparisons"></div>							
						
		
			</div> 
		</div> 
		
		
		
		
		
		
		
		
		
		
		
		
					<!-- Events Header -->
				
					
						
						 
							
								
								
								
								
								
											    			
								
							
							
							
							
							
						
						 
						 
						 
						 
						  
						  
						 
						 
					











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	


				
		
		
		<script>
		$(document).ready(function(){
			$('.searchbox-input-class').each(function(){
			    $(this).change(function(){
			    	var qStr=$(this).val();
			    	if($(this).val().indexOf('@')!=-1){
			    		qStr=qStr.replace(/@/g,' ');
			    		$(this).val(qStr);
			    	}
			    });
			});
		});
		</script>
	


		
		













<div id="page-wrapper" class="page-wrapper">
	
	










	
	<section role="main">
	
		
		
		

		<article itemscope itemtype="http://schema.org/NewsArticle"  >

		











	
	






































<script src="/www/js/date-time-moments.js"></script>


	
	
		<script>
		// non-edition sites
		$(document).ready(function() {
			var fullDate = "2019-10-23T07:00-0700";
			var dateFormat = "MMM D, YYYY h:mm a z";
			timeDate = moment(fullDate).tz('America/Los_Angeles').format(dateFormat); // 12 hour format
			document.querySelector(".format-date").textContent = timeDate;
		});
		</script>
	



















	
			















<header class='cat'>

	
	
	
	
	
	
	
	
	<nav class="breadcrumbs horiz">
		<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
			<li><a class="edition-link-url" href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
			
				
				
				
					<li><a class="edition-link-url" href="/category/sensors/" itemprop="url"><span class="article-primary-cat" itemprop="title">Sensors</span></a></li>
				
			
		</ul>
	</nav>
	
	
	
	
	
	
	
	
	
	
		
		
			<div class="category"><a class="edition-link-url" href="/news" itemprop="genre">News</a></div>
		
	
	

	<h1 itemprop="headline">Pani Smart Home Water Monitor promises an easier way to keep tabs on your water usage</h1>
	
		<script>
		try {
			performance.mark("mark_headline_rendered");
		}
		catch(e) {
			console.log("Error saving performance mark -- this function may not be supported in this browser");
		}
		</script>
	
	
	
	
		<section class="deck viewability">
			<h3 itemprop="description">Compatible with most common water fixtures, the $70 wireless sensor detects leaks and doles out water conservation tips via an iOS or Android app.</h3>
		</section>
	
	
	
	
	
	
	
	
			<div class="cat-social">
				
					
				
















 



	

				

	
	
		
		
	



	
	


	


<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">



	<li class="sosh">
		<a data-socialsite="Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3447398%2Fpani-smart-home-water-monitor.html" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg" />
		</a>
	</li>
	<li class="sosh">
		<a data-socialsite="Twitter" class="twit-hand" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3447398%2Fpani-smart-home-water-monitor.html&via=TechHive&text=Pani+Smart+Home+Water+Monitor+promises+an+easier+way+to+keep+tabs+on+your" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg" />
		</a>	
	</li>
	<li class="sosh">
		<a data-socialsite="Pinterest" class="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?url=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3447398%2Fpani-smart-home-water-monitor.html&description=Pani+Smart+Home+Water+Monitor+promises+an+easier+way+to+keep+tabs+on+your" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/pinterest.svg" />
		</a>
	</li>
	<li class="sosh">
		<a data-socialsite="Reddit" href="http://reddit.com/submit?url=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3447398%2Fpani-smart-home-water-monitor.html&title=Pani+Smart+Home+Water+Monitor+promises+an+easier+way+to+keep+tabs+on+your" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg" />
		</a>
	</li>
	<li class="sosh cat">
		<a href="mailto:?Subject=Pani Smart Home Water Monitor promises an easier way to keep tabs on your water usage&Body=Check%20out%20this%20article%20from%20TechHive%3A%20https%3A%2F%2Fwww.techhive.com%2Farticle%2F3447398%2Fpani-smart-home-water-monitor.html" target="_blank" rel="nofollow" id="email-icon">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg" />
		</a>
	</li>
	<li class="sosh hide cat print">
		<a href="javascript:window.print();">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg" />
		</a>
	</li>



</ul>
</div>

<script type="text/javascript">
$(document).ready(function() {
	if (twitterHandle != "") {
		$("a[href*=via]").attr("href", function(_, href) {
			  return href.replace(/via=TechHive/, "via="+twitterHandle);
		});
	}
	
	//Add Social Share Event Tag in GTM - IDGMPM-17271
	$("a[data-socialsite]").click(function() {
		var dataLayer = window.dataLayer = window.dataLayer || [];
		dataLayer.push({
			'event': 'socialShare', 
		  	'eventCategory': 'Social Share',
		  	'eventAction': $(this).attr("data-socialsite"), 
		  	'eventLabel': window.document.title
		});
		
	});
});
</script>

<script type="text/javascript">
var isValidEmailAddress = isValidEmailAddress || function(emailAddress) {
    var pattern = new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);
    return pattern.test(emailAddress);
};
function encodeQueryData(params) {
	var ret = [];
	for (var paramKey in params) {
		ret.push(encodeURIComponent(paramKey) + "=" + encodeURIComponent(params[paramKey]));
	}
	return ret.join("&");
}
</script>

			</div>
	
	
	

	
		
			
				
				<div class="cat byline vcard author with-image">		
					<div class="byline-wrapper">
						<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
							
						
							
							
							
							
						
















<a href="/author/Ben-Patterson/" rel="author" title="Ben Patterson"><img  class="bylineImage  imgId100808710 " src="https://images.idgesg.net/images/article/2019/08/ben_patterson-100808710-byline.jpg" width="34" width="34" alt="Ben Patterson" itemprop="image" /></a>

						
							
								
							
















<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Ben-Patterson/"><span itemprop="name">Ben Patterson</span></a></span>
						</p>
						<p class="dateline">
						
							Senior Writer, 
								
									
								












<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">TechHive</span><meta itemprop="logo" content=""/></span> <span class="divider break">|</span>
							
	
							<span class="pub-date" class='break-date' itemprop="datePublished" 
							    content="2019-10-23T07:00-0700"><span class="format-date"></span>
								
							</span>
						</p>
					</div>
				</div>
			
		
	
	
		
	
	
	
	
		
			<div id="articleLeaderboardWrapper">
				<div id="articleLeaderboardInner">
						
						
								
									
								




















	
		
		
		
		
			<div id="gpt-leaderboard" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-leaderboard", "true");
	    			$('#gpt-leaderboard').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-leaderboard [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
						
				</div>
			</div>
			
				
			




















	
		
		
		
		
			<div id="gpt-leaderboardmobile" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-leaderboardmobile", "true");
	    			$('#gpt-leaderboardmobile').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-leaderboardmobile [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	 
		
	
	
	
</header>




	<div class="constrain-970">
		
		
		
		
			
				<div class="lede-container">
					
					
					
						
						
							
				                
				                	
				                	
				                
				                
								
								
								
							
							
							
							
							<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
								<meta itemprop="representativeOfPage" content="1" />
								<meta itemprop="height" content="800" />
								<meta itemprop="width" content="1200" />
					    		
					    		<img data-original="https://images.idgesg.net/images/article/2019/10/pani_smart_water_monitor_main-100815178-large.jpg" class="lazy" loading="lazy" alt="pani smart water monitor main" itemprop="contentUrl" itemprop="url" onload="try {performance.clearMarks('mark_primary_img_rendered'); performance.mark('mark_primary_img_rendered');}catch(e) {console.log('Error saving performance mark -- this function may not be supported in this browser');}"/>
					    		
						    		<script>
						    			try {
						    				performance.clearMarks("mark_primary_img_rendered");
											performance.mark("mark_primary_img_rendered");
						    			}
						    			catch(e) {
						    				console.log("Error saving performance mark -- this function may not be supported in this browser");
						    			}
									</script>
								
					    		<figcaption>
					    			
					    			
					    				<span class="credit" itemprop="copyrightHolder">
					    					
							    				
							    				Pani
						    				
				
							    			
							    				
							    				
							    				
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
							    				
							    				
												
											
									
										</span>
					    			
									
					    		</figcaption>
							</figure>
							
				
						
						
					
				</div>
			
			
		
	



<section class="epo cat-narrow" id="drr-top-ad">

	
	
	
		<div class="techDeals">
			<div class="hed">
				<p>Today's Best Tech Deals</p>
				<p>Picked by TechHive's Editors</p>
			</div>
			<div class="techDealsModule"></div>
		  	
			<div class="moreDeals"><a href="/deals/">Find More Hand-Picked Tech Deals</a></div>
		</div>
	
	
	
	
		<div class="ad top-ad">
	
		
		
			
				
					
						
					
					
				
				
				
			





















	

		
			
			
			
			
			
			
				<div id="gpt-showcase" class="adunit ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				if($(window).width() >= 930) {
					IDG.GPT.addDisplayedAd("gpt-showcase", "true");
					$('#gpt-showcase').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: gpt-showcase - [971 1115]");
                    
				}
				});
				</script>
			
		
	
 	
 
 
		
	
</div>
	
	
	
	
		<div class="topDeals topper">
					<div class="hed">
						<p>Top Deals On Great Products</p>
						<p>Picked by Techconnect's Editors</p>
					</div>
					<div class="topDealsModule"></div>
				  	
					<div class="moreDeals"><a href="http://www.techconnect.com/deals/">See More Hand-Picked Deals</a></div>
		</div>
	
	
	
	
	
	
</section>

</div>







<div class="constrain-970">
	
</div>




<script src="/www/js/deal-modules.js"></script>



		<section class="bodee">

			
				
				
					





















<style>
	#drr-container figure.large.video {
		border-bottom: 0 none;
	}
	figure#page-lede.thm-gallery.rr-gallery-vid #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 300px !important;
		height: 169px !important;
		transition: all 0.5s ease;
	}
	figure#page-lede.thm-gallery #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 100%;
		height: 100%;
		transition: all 0.5s ease;
	}
</style>
<style>
.jwplayer.jw-state-paused .jw-display {
	display: table !important;
	padding: 0;
}
.jwplayer .jw-display-icon-container {
    float: none;
    padding: 0;
    margin: 0;
}
.jw-flag-small-player .jw-display {
	padding-top: 0px;
}
.jwplayer .jw-display-icon-container .jw-icon-rewind {
	visibility: hidden;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play path,
.jw-state-idle .jw-svg-icon-play path,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay path,
.jw-state-complete .jw-svg-icon-replay path {    
    display: none;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    background-size: contain;
    background-repeat: no-repeat;
    background-color: transparent;
    background-image: url(//idge.staticworld.net/idgtv/btn-play-default.svg);
    background-position: center center;
    bottom: 0;
    border-radius: 0;
    box-shadow: none;
    left: 0;
    margin: auto;
    right: 0;
    top: 0;
}
.jwplayer .jw-display-icon-container .jw-icon,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    height: 81px;
    width: 78px;
}
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container .jw-icon,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jw-state-idle .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.thm-gallery.rr-gallery-vid .jw-state-complete .jw-svg-icon-replay  {
	height: 65px;
    width: 62px;
}
</style>


	



	
	
	
	
		<div class="ad placement">
			
				
			





















	

		
			
			
			
				<script>
					var supLocaleEd = false;
					if (typeof countryCode !== 'undefined' && countryCode !== "" && countryCode === 'in') {
						supLocaleEd = true;
					}
				</script>
				<!--  Begin inread -->
				<div id="inread" class=" ad-container">					
				</div>
				
				<script>
					if (supLocaleEd === true) {
						$("div#inread").remove();
					} else {
						consent.ads.queue.push(function(){
							IDG.GPT.addDisplayedAd("inread", "true");
							IDG.GPT.displayGoogleTagSlot('inread');
						});
					}
				</script>
				
				<!--  End inread -->	
			
			
			
			
		
	
 	
 
 
		</div>
	
	
	
	
	
	
	
	
		
		
			
			
			<script>
				var dataLayer = window.dataLayer = window.dataLayer || [];
				dataLayer.push({
					'event': 'loadTopCollectionModule'
					});
			</script>
			
		
	
	
	
	
	













<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>
			
	
		
	
			
			













<style>
@media only screen and (min-width: 60.625em) {
	article .apart.ad.not-lazy {
		margin-left: 0;
		float: right;
	}
}
/* this spaces the ads in the right rail */
@media only screen and ( min-width: 48em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 390px; /*originally 354px*/
	}
	.topDeals.topper {
		margin-top: 390px;
	}
}
@media only screen and ( min-width: 48em ) and ( max-width: 58.063em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 0;
	}
}
@media only screen and ( min-width: 60.625em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 390px; /*originally 354px*/
	}
	.topDeals.topper {
		margin-top: 390px;
	}
}
@media only screen and ( min-width: 48em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 390px;
	}
}
@media only screen and ( min-width: 48em ) and ( max-width: 58.063em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 0;
	}
}
@media only screen and ( min-width: 60.625em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 390px;
	}
}
</style>


<script type="text/javascript">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</script>
			
			
	
	
	
	
	
		
		
			
		
	
	
	
	
	
		
			
				
				
				
					
				
				
			
		
		
	
	
		
		
			<div id="drr-container" class='cat ' itemprop="articleBody">
		
		
		
		
	
		
			
			
				<p dir="ltr">We’ve seen plenty of smart water sensors that will monitor how much household water you’re using while checking for leaks, but they’re often wallet-busters that require help from a plumber to install.</p><aside class="emo emo-sb">
<h6 class="nav-title">Mentioned in this article</h6>
<div class="product-details">
<figure class="productFigure"><a href="https://www.techhive.com/article/3397102/phyn-plus-review.html" rel="noopener" target="_blank"><img border="0" data-productid="1442852" data-original="https://images.idgesg.net/images/article/2018/01/phyn-plus-with-pex-100746262-small.jpg" class="lazy" loading="lazy"/></a><a class="product-name" href="https://www.techhive.com/article/3397102/phyn-plus-review.html" data-productid="1442852">Phyn Plus</a></figure>

 <div class="product-lines"><div class="product-line1"><div class="rating"> <a href="https://www.techhive.com/article/3397102/phyn-plus-review.html"><span class="rating-star four-star"/></a></div><span class="product-brand"><a href="https://www.techhive.com/article/3397102/phyn-plus-review.html">Read TechHive's review</a></span></div><div class="product-line2"><div class="price-msrp"><a class="product-list-price" href="https://go.redirectingat.com/?id=111346X1569484&amp;url=https%3A%2F%2Fwww.phyn.com%2Fget-phyn%2F&amp;sref=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3447398%2Fpani-smart-home-water-monitor.html&amp;xcust=US_003_3447398_005_1442852_web" target="_blank" data-product-name="Phyn Plus" data-vars-product-name="Phyn Plus" data-vars-link-position-id="005" data-vars-link-position="Product Sidebar" data-po="vendor" data-product-id="1442852" data-vars-product-id="1442852" data-bkc="HomeTech" data-bkmfr="PhynLLC" data-vars-bkmfr="PhynLLC" data-bkvndr="Phyn" data-vars-bkvndr="Phyn" data-vars-outbound-link="https://www.phyn.com/get-phyn/">$699.00</a><span class="msrp">MSRP $699.00</span></div><a class="btn-amazon" href="https://go.redirectingat.com/?id=111346X1569484&amp;url=https%3A%2F%2Fwww.phyn.com%2Fget-phyn%2F&amp;sref=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3447398%2Fpani-smart-home-water-monitor.html&amp;xcust=US_003_3447398_005_1442852_web" target="_blank" data-product-name="Phyn Plus" data-vars-product-name="Phyn Plus" data-vars-link-position-id="005" data-vars-link-position="Product Sidebar" data-po="vendor" data-product-id="1442852" data-vars-product-id="1442852" data-bkc="HomeTech" data-bkmfr="PhynLLC" data-vars-bkmfr="PhynLLC" data-bkvndr="Phyn" data-vars-bkvndr="Phyn" data-vars-outbound-link="https://www.phyn.com/get-phyn/">See it</a></div><div class="product-line3 vendor"><a href="https://go.redirectingat.com/?id=111346X1569484&amp;url=https%3A%2F%2Fwww.phyn.com%2Fget-phyn%2F&amp;sref=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3447398%2Fpani-smart-home-water-monitor.html&amp;xcust=US_003_3447398_005_1442852_web">on <span class="vendor-name">Phyn</span></a></div></div></div>
</aside><p dir="ltr">Not so with the <a class="addLink" href="https://go.redirectingat.com/?id=111346X1569484&amp;url=https%3A%2F%2Fgetpani.com%2Fshop&amp;sref=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3447398%2Fpani-smart-home-water-monitor.html&amp;xcust=US_003_3447398_000_000000_web" rel="noopener" target="_blank" data-product-name="Smart Home Water Monitor" data-vars-product-name="Smart Home Water Monitor" data-vars-outbound-link="https://getpani.com/shop" data-product-id="000000" data-vars-product-id="000000" data-bkmfr="Pani" data-vars-bkmfr="Pani" data-bkvndr="Pani" data-vars-bkvndr="Pani">Smart Home Water Monitor</a><a class="removelink" href="#" rel="nofollow"><span class="removelink-tooltip" style="display: none;" data-removeparamvalues="Smart Home Water Monitor|Pani|https://getpani.com/shop|Pani|Smart Home Water Monitor|4|Add Link">Remove non-product link</span></a> from Pani, a do-it-yourself wireless sensor that attaches to a shower head or the water line connector of a toilet or sink.</p><p dir="ltr">Available starting today for $70 or as a $120 two-pack, the Smart Home Water Monitor is a wireless flow meter that connects to most water fixtures that have 1/2- or 3/8-inch fittings.</p><aside class="fakesidebar"><a href="http://www.techhive.com/article/3138905/sensors/best-water-leak-detectors-for-smart-homes.html">[ Further reading: The best home water leak detectors ]</a></aside><p dir="ltr">The battery-powered monitor sends data about your water usage to the Pani mobile app for iOS and Android. After about 7 to 10 days of keeping an eye on your water usage, the Pani app will begin giving you tips and recommendations for conserving water. It will also alert you if it detects any leaks.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2019/10/pani_smart_water_monitor_mobile_app-100815177-orig.jpg" rel="nofollow"><img border="0" alt="pani smart water monitor mobile app" width="1200" height="801" data-imageid="100815177" data-license="Supplied Art" data-original="https://images.idgesg.net/images/article/2019/10/pani_smart_water_monitor_mobile_app-100815177-large.jpg" class="lazy" loading="lazy"/></a> <small class="credit">Pani</small>
<figcaption>
<p>The Pani Smart Home Water Detector can keep tabs on your water usage and send you tips via the free Pani app for iOS and Android.</p>
</figcaption>
</figure><p dir="ltr"><a href="https://getpani.com/estimator" rel="nofollow">Pani offers an online tool</a> that will help you estimate how many Smart Home Water Monitors you’ll need in your home for the best “high-level” picture of your water usage, with Pani noting that showers, toilets, and faucets generally account for about 70 percent of household water consumption.</p><p dir="ltr">I gave Pani’s estimator tool a spin and it told me that based on the size of my apartment, the number of bathrooms (one and a half) and the number of family members (three), we’d probably need about three Smart Home Water Monitors to properly track our water usage.</p><p dir="ltr">While the individual Pani water monitors are relatively inexpensive at $70 each, they do add up if you need more. The three recommended Smart Home Water Monitors for my apartment, for example, would cost a total of about $190.</p><p dir="ltr">That’s still not bad compared to the <a href="https://www.techhive.com/article/3433197/phyn-smart-water-assistant.html">Phyn Smart Water Assistant</a>, a $299 DIY system that connects to your hot and cold water lines to monitor your household water use and detect leaks. Of course, the Alexa- and Google Assistant-compatible Phyn Smart Water Assistant could end up being a bargain depending on how many of Pani’s Smart Home Water Monitors you need.</p><aside class="nativo-promo nativo-promo-1 smartphone tablet desktop" id=""> </aside><p dir="ltr">It’s also worth considering that neither Pani’s Smart Home Water Monitors nor the Phyn Smart Water Assistant can shut off your water lines in the event of a leak. For that, you’ll need to upgrade to a somewhat more substantial system like the $699 <a href="https://www.techhive.com/article/3397102/phyn-plus-review.html">Phyn Plus</a> or the <a href="https://www.techhive.com/article/3321177/flo-review.html">Flo by Moen</a>, water monitors that need to be installed on your main water line.</p><p dir="ltr">We’ll have a review of the Pani Smart Home Water Monitor once we spend quality time with a few of them.</p><div> </div>
			
		
		
	
		
		
			
		
		
		
		
			
			
			
			










<div class="end-note">
	
		
	











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2010 blox4.html  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
					
						
					
				
				
			
		
















	
		
		
			<div id="" class="blx blxParticleendnote blxM2010  blox4_html  blxC24070">Note: When you purchase something after clicking links in our articles, we may earn a small commission. Read our <a href="https://www.techhive.com/about/affiliates.html">affiliate link policy</a> for more details. </div>
		
	

	


</div>
		
		
	</div>
	
		<script>
			try {
				performance.mark("mark_article_body_rendered");
			}
			catch(e) {
				console.log("Error saving performance mark -- this function may not be supported in this browser");
			}
		</script>
	
	
	
		
			
		
		
		
	
	
		
		  
		





























	


	
	
	<script>
$("a[data-product-id]").on('click',function(e){
	var e = e || window.event;
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var prodName = $(this).attr("data-product-name");
	prodName = prodName.replace("\\'","'"); // to counter the effects of over-escaping
	
	if ( $(this).parents('.slideshow').length > 0 ) {
		var productLinkPosition = "Slideshow";
	} else if ( $(this).parents('.emo-sb').length > 0 ) {
		var productLinkPosition = "Product Sidebar";
	} else if ( $(this).parents('.at-a-glance.top').length > 0 ) {
		var productLinkPosition = "AAG Top";
	} else if ( $(this).parents('.at-a-glance').length > 0 ) {
		var productLinkPosition = "AAG Bottom";
	} else if ( $(this).parents('.quick-hits.medium').length > 0 ) {
		var productLinkPosition = "Quick Hit Medium";
	} else if ( $(this).parents('.quick-hits').length > 0 ) {
		var productLinkPosition = "Quick Hit Full";
	} else if ( $(this).parents('.product-chart').length > 0 ) {
		var productLinkPosition = "Product Chart";
	} else if ( $(this).parents('.emo-list').length > 0 ) {
		var productLinkPosition = "Product List";
	} else {
		var productLinkPosition = "Body Text";
	}
	
	dataLayer.push({
		'event': 'affiliateLink', 
	  	'eventCategory': 'Affiliate Link', // Hardcoded, not dynamic
	  	'eventAction': 'Click', // Hardcoded, not dynamic
	  	'eventLabel': ''+e.target+'', // The URL the affiliate link leads to
	  	'productVendor': $(this).attr("data-bkvndr"), // The vendor of the product
	  	'productManufacturer': $(this).attr("data-bkmfr"), // The manufacturer of the product
	  	'productName': prodName, // The name of the product
	  	'productId': $(this).attr("data-product-id"), // The ID of the product
	  	'productLinkPosition': productLinkPosition // location of product link (Product Sidebar, Product Chart, etc.)
	});
	
});
</script>
	
	
		<script>
$("#drr-container a:not('[data-product-id]')").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickParentsUntilDrr = $clickEl.parentsUntil("#drr-container");
	var clickText = $clickEl.text().trim();
	var linkLocation;
	var linkType;
	var regex = new RegExp("cio.com|csoonline.com|computerworld.com|itnews.com|itworld.com|infoworld.com|networkworld.com|javaworld.com|techconnect.com|techhive.com|macworld.com|pcworld.com|greenbot.com|gamestar.com", "i");
	
	if (clickParentsUntilDrr.hasClass("fakesidebar")) {
		linkLocation = "FSB";
	}
	else if (clickParentsUntilDrr.hasClass("end-note")) {
     	 linkLocation = "End Note";
   }
	else {
		linkLocation = "Body";
	}
	
	if (regex.test(clickUrl)) {
	      linkType = "Internal";
	    }
	else {
		linkType = "External";
	}
		
	
	dataLayer.push({
		'event': 'editBodyLink', 
	  	'eventCategory': 'Editorial Body Links',
	  	'eventAction': linkType,
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>
	
	
	<script>
$("#drr-top-ad .related-promo-wrapper .title > a").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickText = $clickEl.text().trim();
	var linkLocation = "Promo";		
	
	dataLayer.push({
		'event': 'promoModuleLink', 
	  	'eventCategory': 'Promotion module',
	  	'eventAction': 'Click',
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>
	
	
	
	
	
	
	    <div class="apart-alt tags">
	    <span class="related">Related: </span>
	    <ul>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/sensors"><span class="primary-cat-name2">Sensors</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/connected-home"><span class="primary-cat-name2">Connected Home</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/home-tech"><span class="primary-cat-name2">Home Tech</span></a></li>
			 
			
				
				
					 
						 
				    				
					
				
					
			
	    </ul>
	   
		</div>
	
	
	
	
	
	
	
	
	
			
	   		
			












		
	
	
	
	<div class="byline vcard author end-byline">	
		<div class="author-info" id="benpatterson">		
			
			
				<p>Ben has been writing about technology and consumer electronics for more than 20 years. A PCWorld contributor since 2014, Ben joined TechHive in 2019, where he covers smart home and home entertainment products.</p>
					
		</div><!-- end .author-info -->	
		
		<div class="brand-social">
				<div class="follow-text">Follow</div>
				<ul class="social-links">
					<li>
						<a href="/author/Ben-Patterson/">
							<i class="ss-icon ss-user"></i>
						</a>
					</li>
					
					<li>
						<a href="https://twitter.com/benpatt" class="twitter-follow" target="_blank">
							<i class="ss-icon ss-social ss-twitter"></i>
						</a>
					</li>
					
					
					<li>
						<a href="https://www.facebook.com/benpatt" class="facebook-follow" target="_blank">
							<i class="ss-icon ss-social ss-facebook"></i>
						</a>
					</li>
					
					
				</ul>
			</div>
			
	</div>
	
	
		
			
			
	
	
	
	
		 
	
	
	
	
	
		
		
	

















	 
	



	
	
	
	
	
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	





<script src="/www/js/video/embedder-jwp.js?v=20191022113641"></script>


					










				
			
		
		</section><!-- /.bodee -->

		














		
			
				











<script>var suppressEd = false;</script>







<div id="content-recommender">
	<div class="OUTBRAIN" data-widget-id="AR_1" data-ob-template="TechHive_1"></div>  
</div>
<script>
	var obEdition = edition ||  countryCode || '';
	var widgetId="";
	
	if (obEdition === "asean") {
		widgetId="AR_3";
		if ($("body").hasClass("slideshow")) {
			widgetId="AR_4";
		}
	}
	if (widgetId !== "") {
		$(".OUTBRAIN").attr("data-widget-id", widgetId);
	}
	// suppressed for certain editions
	if (!suppressEd) {
		$.getScript("//widgets.outbrain.com/outbrain.js");
	}
</script>


			
				
		
	
		<div id="amazon-bottom-widget">
			<div class="amzn-custom-header">Shop Tech Products at Amazon</div>
			<div id="amazon-links" class="rr sector" original="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&storeId=httpwwwidgcsm-20&adInstanceId=78b1d44a-51eb-41a3-8f7b-1c26d7650c44">
				<code type="text/javascript"><!--
				           console.log('lazyloaded amazon widget links in footer');
				           //-->
				</code>
			</div>
		</div>
		<script>
		$(window).load(function() {
			consent.adsel.queue.push(function(){
				try {
					$("div#amazon-links").lazyLoadAd({
				          threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
				          forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
				          onLoad       : false,       // Callback function on call ad loading
				          onComplete   : false,       // Callback function when load is loaded
				          timeout      : 2000,        // Timeout ad load
				          debug        : false,       // For debug use : draw colors border depends on load status
				          xray         : false      // For debug use : display a complete page view with ad placements
				    });
				} catch (exception){
					console.log("ERROR loading amazon widget links " + exception);
				}
			});
		});
		</script>
	



	<div class="lazyload_ad">
		<code type="text/javascript">
						<!--
						var slotName = 'bottomleaderboard';
						var slotSize = [];
						if ($thm.deviceClass == 'mobile') {
							slotSize = [[300,50],[320,50],[300,250]];
						}
						else if ($thm.deviceClass == 'tablet') {
							slotSize = [[728,90],[468,60]];
						}
						else {
							slotSize = [[728,90],[970,90],[970,250]];
						}
						IDG.GPT.addDisplayedAd(slotName, "true");
						document.write('<div id="' + slotName + '" class="ad-container">');
						consent.ads.queue.push(function(){
							IDG.GPT.defineGoogleTagSlot(slotName, slotSize, false, true);});
						document.write('</div>');
						consent.ads.queue.push(function(){
							$('#' + slotName).responsiveAd({screenSize:'971 1115', scriptTags: []}, true);});
						//-->
		</code>
	</div>



		</article>

	</section><!-- /role=main -->

	
	
	

</div><!-- /#page-wrapper -->
		
		













<div id="panel-loader"></div>
<!-- IDGMPM-11812, category.getCategoryType() returns an integer, and 9 stands for tentpole-->
 



	
		










<link rel="stylesheet" href="/www.idgcsmb/css/tso-links.css?v=20191022113641" />

	<div id="tso-wrapper"><div id="tso" style="display:none"></div></div>
	<script type="text/javascript">
	function renderTSO(ads, requireHttps) {
		$thm.debug("renderTSO:"+ads.length);
		if (ads && ads.length > 0) {
			var selectedAds = selectTSOAds(ads,10);
			if (null != selectedAds && selectedAds.length > 0) {
				var html = "<h3>Sponsored Links</h3>";
				html += "<ul>";
				for (var i=0; i<selectedAds.length;i++) {
					html += "<li>";
					html += "<a href='"+selectedAds[i].url+"'> "+selectedAds[i].title+"</a>";
					if (null != selectedAds[i].pixel && selectedAds[i].pixel.length > 0 && selectedAds[i].pixel.indexOf('http') == 0) {
						if(!requireHttps || selectedAds[i].pixel.indexOf('https://') == 0){
							html += "<img src='"+selectedAds[i].pixel+"' style='height:0;width:0;'/>";
						}
					}
					html += "</li>";
				}
				html += "</ul>";
				$("#tso").html(html).show();
			}
		}
	}
	function selectTSOAds(ads,max) {
		if (ads.length <= max) {
			return ads;
		} else {
			var uniq = {};
			var found = 0;
			var selectedAds = [];
			while (found < max) {
				var ad = ads[Math.floor(Math.random()*ads.length)];
				if (uniq[ad.id] != null) {
					continue;
				} else {
					uniq[ad.id] = true;
					found++;
					selectedAds.push(ad);
				}
			}
			return selectedAds;
		}
		return null;
	}
	</script>
	

	




		










<link rel="stylesheet" href="/www.idgcsmb/css/footer.css?v=20191022113641" />
<link rel="stylesheet" href="/www.idgcsmb.th/css/footer.css?v=20191022113641" />
<div id="network"></div>

	












<footer id="footer" class="clearfix">
    <div class="container clearfix">
    	<div class="footer-col">
    		<a href="#" id="footer-logo" class="ir">TechHive</a>
    		<p>TechHive helps you find your tech sweet spot. We steer you to products you'll love and show you how to get the most out of them.</p>
    		<ul>
    			<li><a href="/about/about.html">About Us</a></li>
				<li><a href="/about/contact.html">Contact Us</a></li>
				<li><a href="/newsletters/signup.html">Newsletters</a></li>
				<li><a href="/about/member-preferences.html">Member Preferences</a></li>
				<li><a href="/about/cookie-policy.html">Cookie Policy</a></li>
				<li><a href="/index.rss">RSS</a></li>
				<li><a href="https://www.idg.com/about-adchoices-techhive/" rel="nofollow">Ad Choices</a></li>
				<li><a href="/about/privacy.html" rel="nofollow">Privacy Policy</a></li>
				<li><a href="https://www.idg.com/terms-of-service-agreement/" rel="nofollow">Terms of Service Agreement</a></li>				
			</ul>
			<ul class="right">
				
				<li><a href="https://shop.techhive.com">Shop</a></li>
				
				<li><a href="https://www.pcworld.com/couponcodes">Coupon Codes</a>
					<ul>
						<li><a href="https://www.pcworld.com/couponcodes/aliexpress">Aliexpress</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/ebay">Ebay</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/home-depot">Home Depot</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/hp">HP</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/jcpenney">jcpenney</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/oneplus">OnePlus</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/walmart">Walmart</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/target">Target</a></li>
						<li><a href="https://www.pcworld.com/couponcodes/6pm-com">6PM</a></li>
					</ul>
				</li>
				<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a></li>
				
				
			</ul>
    	</div>
    	<div class="footer-col">
    		<h2>TechHive Categories</h2>
    		<ul>
    			
				<li><a href="/category/connected-home/">Connected Home</a></li>
				<li><a href="/tag/cordcutting/">Cord Cutting</a></li>
				<li><a href="/category/home-audio/">Home Audio</a></li>
				<li><a href="/category/home-networking/">Home Networking</a></li>
				<li><a href="/category/home-security/">Home Security</a></li>
				<li><a href="/category/hubs-controllers/">Hubs &amp; Controllers</a></li>
			</ul>
			<ul class="right">
				
				<li><a href="/category/internet-of-things/">Internet of Things</a></li>
				<li><a href="/category/lighting/">Lighting</a></li>
				<li><a href="/category/smart-appliance/">Smart Appliances</a></li>
				<li><a href="/category/streaming-media/">Streaming Media</a></li>
				<li><a href="/category/thermostats/">Thermostats</a></li>
				<li><a href="/deals">Deals</a></li>
			</ul>



			<h3>IDG Network Sites</h3>
			<ul>
				<li><a href="https://www.idg.com/advertise-with-us/macworld/" rel="nofollow">Advertise</a></li>
				<li><a href="https://www.idg.com/technetwork/technetwork-permissions-guildelines/" rel="nofollow">Permissions</a></li>
				<li><a href="http://www.macworld.com/" rel="nofollow">Macworld</a></li>
				<li><a href="http://www.pcworld.com/" rel="nofollow">PCWorld</a></li>
				<li><a href="http://www.techadvisor.co.uk/">Tech Advisor</a></li>
			</ul>
			<ul class="right">
				<li><a href="https://www.idg.com/technetwork/" rel="nofollow">IDG TechNetwork</a></li>
				<li><a href="https://www.idg.com/" rel="nofollow">IDG</a></li>
				<li><a href="http://blog.idg.com/" rel="nofollow">IDG Blog</a></li>
				<li><a href="https://www.idg.com/work-here/" rel="nofollow">Careers at IDG</a></li>
			</ul>
    	</div>
    	<div class="footer-col">
    		<div id="footer-social">
    			<span>Follow us</span> 
    			<a href="http://www.facebook.com/techhivemedia" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
					&#xF610;
				</a>
				<a href="https://twitter.com/TechHive" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
					&#xF611;
				</a>
				
    		</div>
    		
    		
		    <p>Visit other IDG sites:</p>
    		
    		<div id="idgInfo" class="styled-select">		
		            <select onchange="location = this.options[this.selectedIndex].value;" id="jumpMenu" name="jumpMenu" d30tagged="1" style="visibility: visible;">
		                <option value="">Select One</option>
						
							
						













	
		<option value="https://www.greenbot.com">Greenbot</option>
	
		<option value="https://www.macworld.com">Macworld</option>
	
		<option value="https://www.pcworld.com">PCWorld</option>
	
		<option value="https://www.techhive.com">TechHive</option>
	

		            </select>
		    </div>
		    
		        <p><small><a href="http://idgcsmb.com/terms-of-service-agreement/">Copyright</a> &copy; 2019 IDG Communications, Inc.</small></p>
    	</div>
    </div>
</footer>

	
	<script src="/www/js/ads/stickyLb.js"></script>
	<script>
		(function(){
			var parallaxArgs = {
				topNavEl: 'page-top',
				topNavIsSticky: false,
				leaderboadrdId: 'gpt-leaderboard', 
				adContainer: 'articleLeaderboardWrapper',
				adUnit: 'articleLeaderboardInner',
				viewabilityTime: 10000
			}
			parallaxLb(parallaxArgs) ;
		})();
		
	</script>



		
				
		
			
				
			




















	
		
		
		
		
			<div id="gpt-infunnel" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-infunnel", "true");
	    			$('#gpt-infunnel').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-infunnel [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
		
		
			
		
















<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script> 

<script src="/www.idgcsmb/js/jquery/jquery-ui-tools.js"></script>


<script src="/www.idgcsmb/js/thm_post.js?v=20191022113641"></script>

<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.md5.js"></script>

	<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.colorbox-min.js"></script>


<script src="/www.idgcsmb/js/autocomplete.js"></script>







<script>
$(function() {
	if (typeof $.fn.lazyload === 'undefined' ) {
		$.getScript('/www/js/jquery/jquery.lazyload.min.js',function(){
			 $("img.lazy").lazyload({ 
			    	effect : "fadeIn", 
			    	threshold: 200,
			    	failure_limit:25
			 });
		});	
	}
});
</script>

<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>















<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>

<script type="text/javascript">
// -- Load Lazy Advertisement placement as deferred
try {
	$("div.lazyload_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
	}) ;
}
catch (exception) {
	console.log("Error with lazyLoadAd: "+exception);
}
</script>

<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
<script>
$(document).ready(function() {
	$("table.tablesorter").tablesorter({
		widgets: ['zebra']
	});
	
	$("table.tablesorter tbody tr").hover(function() {
		$(this).toggleClass("selected");
	});
	
	$("table.tablesorter thead tr th").each(function(){			
		if ($(this).find('.ss-icon').length < 1) {
			$(this).append('<i class="ss-icon"></i>');
		}
	});
	
});
</script>

<script>
	//click event for BrandPost "Learn More" buttons
	$(".learn-more").click(function(event) {
		 var brandpost_txt = "<div class=\"about-brandposts\"><p>BrandPosts are written and edited by members of our sponsor community. BrandPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of BrandPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 if ($(".blog-byline.sponsored-post").length > 0) { //for Nativo sponsoredPosts
			 brandpost_txt = "<div class=\"about-brandposts\"><p>SponsoredPosts are written and edited by members of our sponsor community. SponsoredPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of SponsoredPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 }
		 $("body").append(brandpost_txt);
		 $(".about-brandposts").css("top",event.pageY);
		 if ($("body").width() >= 955) { // need different behavior at desktop breakpoint and above
			 //find difference between X position clicked and body width and set as right attr 
			 //this is so tooltip doesn't overflow window
			 var xpos = $("body").width() - event.pageX;
			 $(".about-brandposts").css({"right":xpos,"margin-right":"0"});
		 }
		 $(".about-brandposts .close-bar").click(function() {
			 $(".about-brandposts").remove();
			 return false;
		 });
		 return false;
	});
</script>

<script>
//click event for Sponsorship "Learn More" buttons
	 $(".learn-more-sponsorship").click(function(event) {
		 var sponsorship_txt = "<div class=\"about-sponsorships\"><p>This content is written and edited by members of our sponsor community. Such sponsor content creates an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of sponsor content.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 if ($(".blog-byline.sponsored-post").length > 0) { //for Nativo sponsoredPosts
			 sponsorship_txt = "<div class=\"about-sponsorships\"><p>SponsoredPosts are written and edited by members of our sponsor community. SponsoredPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of SponsoredPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 }
		 $("body").append(sponsorship_txt);
		 $(".about-sponsorships").css("top",event.pageY);
		 if ($("body").width() >= 955) { // need different behavior at desktop breakpoint and above
			 //find difference between X position clicked and body width and set as right attr 
			 //this is so tooltip doesn't overflow window
			 var xpos = $("body").width() - event.pageX;
			 $(".about-sponsorships").css({"right":xpos,"margin-right":"0"});
		 }
		 $(".about-sponsorships .close-bar").click(function() {
			 $(".about-sponsorships").remove();
			 return false;
		 });
		 return false;
	 });
</script>




	<!-- LiveRamp Sources -->
	<script src="/www/js/utils/liveRamp.js"></script>
	<!-- End of LiveRamp -->


<script type='text/javascript'>

	g_bRequireHttps = true;
	 	var localeId = getLocale();
		$.ajax('/ads/tso?localeId=' + localeId,{
			dataType: 'json',
			success: function(data){
				renderTSO(data.tsoLinks, g_bRequireHttps);
			},
			error: function(jqXHR,error,thrown){
				$thm.debug("TSO AJAX Status: "+error+": "+thrown,true);
			}
		});
	
</script>

		
		<script type="text/javascript">
			a=top;f=self;
			var acceptedDomains = ["lookbookhq.com"];
			var cleanedHost = a.location.hostname.split(".").slice(-2).join(".");
			if(a!=f && acceptedDomains.indexOf(cleanedHost) < 0) {
				a.location=f.location;
			}
		</script>	

 		














	
	
	    
	    
		   	
		   	
		   	
	    
    	
    	
	    
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	




 		
		










<script type="text/javascript">
consent.digitalelement.queue.push(function(){
	$thm.logPlEvent({"b":"th","e":"view","t":"article","id":"3447398"});
});
</script>
	
	
		<div id="loginModal"></div>
		<div id="logoffModal"></div>
		<div id="abuseModal"></div>

		
			<!-- rev: 20191022113641  -->
		
		
		
		
			
				
			




















	
		
			<div id="gpt-skin" class=" ad-container"></div>
    			<script type="text/javascript">
    			consent.ads.queue.push(function(){
    				try {
	    				IDG.GPT.addDisplayedAd("gpt-skin", "true");
	    				IDG.GPT.displayGoogleTagSlot('gpt-skin');
	    			}
	    			catch (exception) {
	    				console.log("Error with IDG.GPT: " + exception);
	    			}
    			});
    			</script>
		
		
		
		
	
 
 
			
		
		
		
			
		




















	
		
		
		
		
			<div id="gpt_custom_promo_2" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt_custom_promo_2", "true");
	    			$('#gpt_custom_promo_2').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt_custom_promo_2 [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
			
	</body>
</html>
