










<!DOCTYPE html>


	
	
	
		
		
	
	
	
	

<html lang="en">
	












<head>
	
	<meta charset="utf-8" />
	<title>Amazon Fire TV Recast review: This over-the-air DVR is frustratingly close to great | TechHive</title>
	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
	
	
	<script>
	function getQueryVariable(variable) {
		var query = window.location.search.substring(1);
		var vars = query.split("&");
		for (var i=0;i<vars.length;i++) {
			var pair = vars[i].split("=");
			if(pair[0] == variable){return pair[1];}
		}
		return(false);
	}
	</script>
	
	<!-- ad-related js -->
	
	<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
	
	<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
	
	
	












<script>
!function(t,o,e){e=t.createElement(o),t=t.getElementsByTagName(o)[0],e.async=1,e.src="https://spiffymachine.com/v2/0/xsouDc-hlLIlrDskvEwLo4NqErNxhsQhZEvJMkeR-V-Adls6lbE9ThjXDi5dQCQjkWxUA",t.parentNode.insertBefore(e,t)}(document,"script"),function(t,o){t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)}}(document,window,"script","admiral");!function(t,e,a,n){function o(t){try{return t=localStorage.getItem("v4ac1eiZr0"),t&&t.split(",")[4]>0}catch(e){}return!1}function r(){var n=o();if(n){var r=t[e].pubads();typeof r.setTargeting===a&&r.setTargeting("admiral-engaged","true")}}n=t[e]=t[e]||{},n.cmd=n.cmd||[],typeof n.pubads===a?r():typeof n.cmd.unshift===a?n.cmd.unshift(r):n.cmd.push(r)}(window,"googletag","function");;;;!function(t,e,a,n){function o(){if(!window.frames[n]){var e=t.body;if(e){var a=t.createElement("iframe");a.style="display:none",a.name=n,e.appendChild(a)}else setTimeout(o,5)}}function r(){for(var t=[],a=0;a<arguments.length;a++)t.push(arguments[a]);i.q=i.q||[],"ping"===t[0]?t[2]({gdprAppliesGlobally:e.__cmpGdprAppliesGlobally||!1,cmpLoaded:!1},!0):t.length&&i.q.push(t)}function c(t){try{return JSON.parse(t)}catch(e){}}function s(t){if(t){var e,a="__cmpCall",n="string"==typeof t.data&&t.data.indexOf(a)>=0;e=n?(c(t.data)||{})[a]:(t.data||{})[a],e&&i(e.command,e.parameter,function(a,o){var r={__cmpReturn:{returnValue:a,success:o,callId:e.callId}};t.source.postMessage(n?JSON.stringify(r):r,"*")})}}var i=e[a];o(),"function"!=typeof i&&(i=e[a]=r,e.addEventListener?e.addEventListener("message",s,!1):e.attachEvent&&e.attachEvent("onmessage",s))}(document,window,"__cmp","__cmpLocator");;
</script>

<script>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</script>




	
    <script src="/www/js/init_device.js"></script>    
    
    
    
		














<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20181113114309"></script>

<script type="text/javascript">
	if (adLayer==null || adLayer=='undefined') {
		var adLayer=[];
	}
	
		
			adLayer["itemType"]="article";
		
		
	
</script>
	
<script type="text/javascript">
	// Set up ad related variables
	try {
		IDG.GPT.unitName = "/8456/IDG.US_CSMB_TechHive.com";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}

	try {
		IDG.GPT.unitName = IDG.GPT.unitName + "/" + "consumer-electronics_section";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	// global variables
	var global_ShowSuper = true;
	var global_ShowHero = false;
	
	//XFP global targeting, more targeting thm_pre
	var url = window.location.href;
	if(url.indexOf("?")>1){
		url=url.split('?')[0];
	}
	

	try {
		IDG.GPT.addTarget("URL", encodeURIComponent(url));
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	try {IDG.GPT.addTarget("zone", 'article/streaming-hardware');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("channel", 'streaming-media');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("productId", '1441707');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("productId", '1440552');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("productId", '1441686');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("productId", '1440737');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("productId", '1441704');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("productId", '1441705');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("articleId", '3321002');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("type", 'reviews');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("typeId", '3');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("manufacturer", 'amazon');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("templateType", 'article-review');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	
	try {IDG.GPT.addTarget("categoryIds", [3941,3059,3799,4723]);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("categorySlugs", ['streaming-hardware','home-theater','consumer-electronics','plex-systems']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {IDG.GPT.addTarget("goldenIds", [416,398,1025,833]);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {
		if (null != IDG.GPT.getQsVal("env")) {		
			IDG.GPT.addTarget("env", IDG.GPT.getQsVal("env").replace(/\W/g, "") );
		}
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	
	
		try {
			IDG.GPT.addTarget("author", 'Jared Newman');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
		

	try {
		IDG.GPT.addTarget("page_type", '');
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	

	
	
		try {
			IDG.GPT.addTarget("tagNames", 'DVR,Movies');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
		try {
			IDG.GPT.addTarget("insiderContent", 'false');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
	
	
</script>



<script type="text/javascript">
	
	
	
	
		
		
		
		
		
		
		
		
	
</script>
  
<script src="/www.idgcsmb/js/thm_pre.js?v=20181113114309"></script>

	<script type="text/javascript">
        $thm.useBusinessData=true;
	</script>















	
		
	
	
	



	
	
		
		<script type="text/javascript" src="/www/js/ads/proximic.js"></script>
		<script type="text/javascript">
            console.log("PROXIMIC RESPONSE: SITE-LEVEL");
            var currentUrl = 'https://www.techhive.com/article/3321002/streaming-hardware/amazon-fire-tv-recast-review.html';
            (function (u) {
                var f = "scr";
                var e = (u ? ("url=" + u) : "");
                document.write("<"+f+"ipt type='text/javascript' src='//t.zqtk.net/c.js?m=1&s=idg_js&"+e.replace(/\'/g, "")+"'></"+f+"ipt>");
            })((typeof (currentUrl) === "undefined") ? "" : currentUrl);
		</script>
		
	



	
	

<script type="text/javascript" src="/www/js/ads/gpt_starter.js?1234"></script>
	<script>
		loadGPT();
	</script>
<script type="text/javascript" src="/www/js/ads/gpt_launcher.js"></script>

	

	

    <link rel="canonical" href="https://www.techhive.com/article/3321002/streaming-hardware/amazon-fire-tv-recast-review.html" />
	
	
	
	
	
	<meta name="description" content="Amazon&#039;s over-the-air DVR nails the little details, but it has some major limitations." />
	
	<meta itemprop="image" content="https://images.idgesg.net/images/article/2018/11/firetvrecast1-100780083-medium.jpg">
	
	
		
			<meta name="DC.date.issued" content="2018-11-14" />
			<meta name="date" content="2018-11-14" />
			
		
		
		
		 
	
	
	<link rel="amphtml" href="https://www.techhive.com/article/3321002/streaming-hardware/amazon-fire-tv-recast-review.amp.html" />

	
		<script type="text/javascript" src="//fonts.staticworld.net/azu1qsr.js"></script>
		<script type="text/javascript">try{Typekit.load();}catch(e){}</script>
	
	
	<meta property="twitter:account_id" content="499275959" />
	<meta property="fb:app_id" content="1566936830273000" />
	
		
		
		
			
			
				
			
			
			
		
		
	<meta property="og:type" content="article">	
	<meta property="og:url" content="https://www.techhive.com/article/3321002/streaming-hardware/amazon-fire-tv-recast-review.html">
    <meta property="og:site_name" content="TechHive">   
    
    
    	<meta property="og:image" content="https://images.idgesg.net/images/article/2018/11/firetvrecast1-100780083-large.3x2.jpg">
    	<meta property="og:image:width" content="700">
    	<meta property="og:image:height" content="467">
    
    
    
    
    
    
    	<meta property="og:title" content="Amazon Fire TV Recast review: This over-the-air DVR is frustratingly close to great"> 
    
    
    <meta property="og:description" content="Amazon&#039;s over-the-air DVR nails the little details, but it has some major limitations.">
    
    
    
    













	<!-- Sailthru -->
	
		<meta name="sailthru.tags" content="streaming-hardware,home-theater,consumer-electronics,plex-systems,dvr,movies,jared-newman,reviews,long"/>
	
		<meta name="sailthru.image.thumb" content="https://images.idgesg.net/images/article/2018/11/firetvrecast1-100780083-small.jpg"/>
	
		<meta name="sailthru.image.full" content="https://images.idgesg.net/images/article/2018/11/firetvrecast1-100780083-large.3x2.jpg"/>
	

    
    	<meta name="sailthru.title" content="Amazon Fire TV Recast review: This over-the-air DVR is frustratingly close to great" />
    
    
    	<meta name="sailthru.description" content="Amazon&#039;s over-the-air DVR nails the little details, but it has some major limitations." />
    

	
	<meta name="displaytype" content="article" />
	
	<meta name="associatedproducts" content="echo show (2nd generation),fire tv recast (75-hour model),tablo dual lite dvr,plex dvr,fire tv recast (150-hour model),bolt ota" />
	
	<meta name="source" content="techhive" />
	
	<meta name="category" content="streaming hardware,home theater,consumer electronics,plex systems" />
	
	<meta name="storytype" content="reviews" />
	
	<meta name="tags" content="dvr,movies" />
	
	
	
		<meta name="google-site-verification" content="GHmsZtoU3FlVFNZp6NaQob2y1ZBU9WoIhanodiETb2o" />
	
	
	
		<meta name="msvalidate.01" content="05F49F041AAA61528A0A3329A6C0C02D" />
	
	
	
	
	
		<link id="mobile-size" rel="stylesheet" href="/www.idgcsmb/css/inline-header-mobile.css?v=20181113114309" />
		<script>
			if (window.matchMedia("(min-width: 768px)").matches) {
				document.getElementById('mobile-size').insertAdjacentHTML('afterend', '<link id="desktop-size" rel="stylesheet" href="/www.idgcsmb/css/inline-header.css?v=20181113114309" />');
			}
		</script>
		<link rel="stylesheet" href="/www.idgcsmb.th/css/inline-header.css?v=20181113114309" />
	 
	
	
	    
	
	<link rel="stylesheet" href="/www.idgcsmb/css/print.css" media="print" />
	
	<!-- this must be first -->
	<link href="/www.idgcsmb/css/colorbox.css" rel="stylesheet" />
	<!-- <link href="/www.idgcsmb/css/equalizer.css" rel="stylesheet" /> -->
	<link href="/www.idgcsmb/css/global-layout.css?v=20181113114309" rel="stylesheet" />
	<link href="/www.idgcsmb.th/css/global-layout.css?v=20181113114309" rel="stylesheet" />
	<link href="/www.idgcsmb/css/global-colors.css?v=20181113114309" rel="stylesheet" />
	<link href="/www.idgcsmb.th/css/global-colors.css?v=20181113114309" rel="stylesheet" />
	<link href="/www.idgcsmb/css/global-typography.css?v=20181113114309" rel="stylesheet" />
	<link href="/www.idgcsmb.th/css/global-typography.css?v=20181113114309" rel="stylesheet" />
	
	
	
	
		
		
			
			
			
				<link rel="stylesheet" href="/www/css/article.css?v=20181113114309" />	
			
			
		<link href="/www.idgcsmb.th/css/article.css?v=20181113114309" rel="stylesheet" />
	
	
	<link href="/www.idgcsmb/css/video.player.css?v=20181113114309" rel="stylesheet" media="all" />
	
	
	
	
	
	
	
	
	
	
	
	  
	<!-- this must be last -->
	<link href="/www.idgcsmb/css/helpers.css" rel="stylesheet" />
	
	
		<script>
		try {
			performance.mark("mark_head_css_done_blocking");
		}
		catch(e) {
			console.log("Error saving performance mark -- this function may not be supported in this browser");
		}
		</script>
	
	<!--  fav and touch icons -->
	<link rel="shortcut icon" href="/www.idgcsmb.th/favicon.ico"/>
	<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://csmb.staticworld.net/images/furniture/techhive/th-apple-touch-icon-precomposed-144.png" />
	<link rel="apple-touch-icon-precomposed" sizes="129x129" href="https://csmb.staticworld.net/images/furniture/techhive/th-apple-touch-icon-precomposed-129.png" />
	<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://csmb.staticworld.net/images/furniture/techhive/th-apple-touch-icon-precomposed-114.png" />
	<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://csmb.staticworld.net/images/furniture/techhive/th-apple-touch-icon-precomposed-72.png" />
	<link rel="apple-touch-icon" href="https://csmb.staticworld.net/images/furniture/techhive/th-apple-touch-icon-precomposed.png" />
	
	

	
		
	
	
	
	
	<script type="text/javascript">
	var _sf_async_config={};
	_sf_async_config.uid = 29363;
	
	
	
		_sf_async_config.useCanonical = true;
	
	
	
		
						
	_sf_async_config.authors="Jared Newman";
			
		
			
			
	_sf_async_config.sections="streaming-hardware";	
		
		
		
		
	_sf_async_config.domain = "techhive.com";
	</script>
	
	
	
	
	
	<!-- <link href="/www.idgcsmb/webfonts/ss-social.css" rel="stylesheet" />
	<link href="/www.idgcsmb/webfonts/ss-standard.css" rel="stylesheet" />  -->
	<!--[if lte IE 8]>  
		<link href="/www.idgcsmb/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->


	
	<!-- Use Twitter Summary Card with Large Image for articles and videos; summary otherwise -->
	
		
				<meta name="twitter:card" content="summary_large_image">
		
		
	
	<meta property="twitter:description" content="Amazon&#039;s over-the-air DVR nails the little details, but it has some major limitations.">
	
	
		
			<meta name="twitter:site" content="@TechHive">
			
			
				
					<meta name="twitter:image" content="https://images.idgesg.net/images/article/2018/11/firetvrecast1-100780083-orig.jpg" />
				
				
						
			
				
				
					<meta name="twitter:title" content="Amazon Fire TV Recast review: This over-the-air DVR is frustratingly close to great">
				
				
			
			
				
				
					<meta name="twitter:url" content="www.techhive.com">
				
			
		
		
		
		
		
	
	
	
	
	












<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "WebSite",
		"url": "https://www.techhive.com/",
		"potentialAction": {
		"@type": "SearchAction",
		"target": "https://www.techhive.com/search?query={search_term}",
		"query-input": "required name=search_term"
		}
	}
</script>
	
	
	<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
	
	
	<script src="/www/js/ads/ads.js"></script>
	
	<script>var oneRegPlacementID = "";</script>
	
	
	
	
	
		
			
				
			
			
			
			
			
		
		
		
	
	
	
		
		
		
		
		  
		
	
	
	
	
	
	  	 
	    
	    
	 
	 
	
	
	
	
	
	
	
	
	
	




	
		
	
		
	
	



	
	
	
	
	
		
			
				
				
				
					
				
			
			
			
			
		
		
		
	
	
	
	
	
	
	
	
	
	<script>
	var sincePublished = '0 days';
	sincePublished = sincePublished.split(" ")[0];
	var idg_uuid = $.cookie('idg_uuid') || "";
	
	dataLayer=[{
		'articleId': '3321002',
		'articleDisplayId':'1',
		'articleTitle': 'Amazon Fire TV Recast review: This over-the-air DVR is frustratingly close to great',
		'articleType': 'Reviews',
		'audience':'consumer',
		'author':'Jared Newman',
		'blogName':'',
		'brandpost': '',
		'categoryIdList':'3941,3059,3799,4723',
		'categoryIdPrimary': '3941',
		'contentStrategy': '',
		'contentType':'reviews',
		'datePublished':'2018-11-14',
		'dateUpdated':'',
		'daysSincePublished':sincePublished,
		'daysSinceUpdated':'',
		'displayType':'article',
		'environment':'production',
		'ga_enabled':'true',
		'gaTrackingId':'UA-30870572-1',
		'geolocEnabled':'true',
		'goldenTaxonomyIdPrimary': '416',
		'goldenTaxonomyIdList': '416,398,1025,833',
		'isBlog':'false',
		'isInsiderContent':'',
		'isICN': 'false',
		'oneRegPlacementID':oneRegPlacementID,
		'pageNumber':'1',
		'platform':'Web',
		'podcastSponsored': 'false',
		'primaryCategory': 'streaming hardware',
		'primaryCategoryList': 'streaming hardware,home theater,consumer electronics,plex systems',
		'property': 'techhive',
		'propertyCountry':'US',
		'purchaseIntent':'',
		'sailthruCustomerId':'14e51635b425ee81f25f84e57f95fbff',
		'skimlinksId':'111346X1569484',
		'source':'techhive',
		'sponsorName':'',
		'tags': 'dvr,movies',
		'userId':idg_uuid,
		'videoAutoplay':'false',
		'articleHasVideo':'false'	
	}];
	</script>
	 
	
	
	
	
	










<script>
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var adBlockStatus = 'false';
	
	function AdBlockEnabled() {
		var ad = document.createElement('ins');
		ad.className = 'AdSense';
		ad.style.display = 'block';
		ad.style.position = 'absolute';
		ad.style.top = '-1px';
		ad.style.height = '1px';

		if (document.body != null) {
			document.body.appendChild(ad);
			var isAdBlockEnabled = !ad.clientHeight;
			document.body.removeChild(ad);
		}

		return isAdBlockEnabled; 
	}
	// AdBlockEnabled() was successful document.body not null
	if (AdBlockEnabled() != undefined) {
		adBlockStatus = AdBlockEnabled().toString();
	}
	// not successful - look for ads.js
	if (document.body == null) {
		if (window.canRunAds === undefined) {
			adBlockStatus = 'true';
		} else {
			adBlockStatus = 'false';
		}
	}
	
	dataLayer.push({
		'adBlockStatus': adBlockStatus
	});
</script>




	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-NZGV5J"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-NZGV5J');</script>
	<!-- End Google Tag Manager -->

	
		<script>
			try {
				performance.mark("mark_head_js_done_blocking");
			}
			catch(e) {
				console.log("Error saving performance mark -- this function may not be supported in this browser");

			}
		</script>
	
	
	
	
	
	<script src="https://www.google.com/recaptcha/api.js" async defer></script>
	
	
	
		<script async src="//js-sec.indexww.com/ht/p/187051-135663723608637.js"></script>
	
	
	
	
	
</head>

	<body id="article3321002" class="article review techhive">
		 
		
			<div id="skinAdTarget"></div>
		

		
			<div id="superadunit" class="hidden">
			    <div class="ad">
			    	<div class="ad-header">
						<div class="brand-logo"></div>
						<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
					</div>
					
						
						
						
					




















	
		
		
		
		
			<div id="gpt-superstitial" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-superstitial", "true");
	    			$('#gpt-superstitial').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-superstitial [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
			    </div><!-- / ad -->
			</div><!-- / super -->		
		

		















	

		
			
		











	
	
	
	
	
	
	
	
	
	
	
	
	
	











<div id="page-top">
		<div class="page-top-inner" itemscope itemtype="http://schema.org/Organization">
		<link itemprop="url" href="http://www.techhive.com"> 
	    

				<header id="banner">
				<a id="mobile-offscreen-toggle" class="ss-standard ss-rows" href="javascript://"></a>
				<div id="logo">
				<a href="/" class="ir banner-logo" id="logoImage">Home</a>
				</div>
				<div id="mobile-search-toggle" class="ss-standard ss-search"></div>
				
				</header>
				


				














		<ul id="th-nav">
			<li class="newsNav"><a href="/news/" id="newsNav">News</a></li>
			<li class="reviewsNav"><a href="/reviews/" id="reviewsNav">Reviews</a></li>
			<li class="videoNav"><a href="/video/" id="videoNav">Video</a></li>
			
				
				
					<li class="th-category-nav"><a href="/category/connected-home/">Connected Home<span class="ss-navigatedown right"></span></a>
					
						<ul class="th-sub-nav">
			            	
							

		            		
							
								<li><a href="/category/smart-appliance/">Appliances</a></li>
								<li><a href="/tag/gardengarage/">Garden &amp; Garage</a></li>
								<li><a href="/category/health-fitness/">Health</a></li>		            		
								<li><a href="/category/home-control/">Home Control</a></li>
								<li><a href="/category/home-networking/">Home Networking</a></li>				
								<li><a href="/category/home-security/">Home Security</a></li>
								<li><a href="/category/hubs-controllers/">Hubs &amp; Controllers</a></li>
								<li><a href="/category/internet-of-things/">Internet of Things</a></li>
								<li><a href="/tag/kitchen/">Kitchen</a></li>	            		
								<li><a href="/category/lighting/">Lighting</a></li>
								<li><a href="/category/security-cameras/">Security Cameras</a></li>
								<li><a href="/category/thermostats/">Thermostats</a></li>
			            			            		
		            		
		            		
		            		
						</ul><!-- /.th-sub-nav -->
					
					</li><!-- /.th-category-nav -->
				
			
				
				
					<li class="th-category-nav"><a href="/category/entertainment/">Entertainment<span class="ss-navigatedown right"></span></a>
					
						<ul class="th-sub-nav">
			            	
							

		            		
									            		
		            		
		            		
		            		
								<li><a href="/tag/cordcutting/">Cord Cutting</a></li>						
								<li><a href="/category/home-audio/">Home audio</a></li>
								<li><a href="/category/smart-tv/">Smart TVs</a></li>
								<li><a href="/category/streaming-hardware/">Streaming Hardware</a></li>
								<li><a href="/category/streaming-media/">Streaming Media</a></li>
								<li><a href="/category/streaming-services/">Streaming services</a></li>		            		
							
						</ul><!-- /.th-sub-nav -->
					
					</li><!-- /.th-category-nav -->
				
			
				
				
			
				
				
			
			<li class="th-category-nav"><a href="/resources/" id="resourcesNav">Resources</a>
		</ul><!-- /.th-nav -->





				


				<div id="th-social">					                  
					<a href="http://www.facebook.com/techhivemedia" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
						&#xF610;
					</a>
					<a href="https://twitter.com/TechHive" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
						&#xF611;
					</a>
					<a href="https://plus.google.com/+TechHiveUS/posts" class="network-google ss-icon ss-social-circle banner-social banner-google" alt="Google+" itemprop="sameAs" rel="publisher">
						&#xF613;
					</a>
					
				</div><!-- /#th-social -->

				
				<div id="th-search">
				<form id="search-form" action="/search">
					<input type="search" name="query" id="banner-search-term" class="inactive searchbox-input-class" value="">
					<input type="submit" name="submit" id="banner-search-submit" value="search" />
					<a id="magGlassClick" class="ss-icon ss-standard" type="submit">&#x1F50E;</a>
				</form>
				</div>
				
				
				<div id="saved-comparisons"></div>							
				

	</div> 
</div> 




<div id="section-nav">
		<div class="container clearfix">
			<ul class="fmenu">
				
					<li >
						
							
							
								<a href="/category/software-music/">Home Audio</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/streaming-media/" class="active">Streaming Media</a>
							
						
					</li>

				
			</ul>
		</div>
</div><!--/#section-nav-->









			<!-- Events Header -->
		
			
				
				 
					
						
						
						
						
						
							
								
				   				
				   				
				   			
								
				   				
				   				
				   					    			
						
					
					
					
					
					
				
				 
				 
				 
				 
				  
				   
				  
				  
				 
				 
			











	
	
	
	
	
	
	
	
	
	
	
	
	
	


		


<script>
$(document).ready(function(){
	$('.searchbox-input-class').each(function(){
	    $(this).change(function(){
	    	var qStr=$(this).val();
	    	if($(this).val().indexOf('@')!=-1){
	    		qStr=qStr.replace(/@/g,' ');
	    		$(this).val(qStr);
	    	}
	    });
	});
});
</script>


		
		











<div id="page-wrapper" class="page-wrapper">
	
	










	
	<section role="main">

		<article itemscope itemtype="http://schema.org/Review"  >

		











	
	
























	
			















<header  class='cat'>

	
	
	
	
	
	
	
	
	
	
	
	<nav class="breadcrumbs horiz">
		<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
			<li><a href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
			
				
				
				
					<li><a href="/category/streaming-hardware/" itemprop="url"><span itemprop="title">Streaming Hardware</span></a></li>
				
			
		</ul>
	</nav>
	
	
	
	
	
	
	
		
		
			<div class="category"><a href="/reviews" itemprop="genre">Review</a></div>
		
	
	

	<h1 itemprop="headline">Amazon Fire TV Recast review: This over-the-air DVR is frustratingly close to great</h1>
	
		<script>
		try {
			performance.mark("mark_headline_rendered");
		}
		catch(e) {
			console.log("Error saving performance mark -- this function may not be supported in this browser");
		}
		</script>
	
	
	
	
		<section class="deck viewability">
			<h3 itemprop="description">While it nailing the little details, this box whiffs on some important things.</h3>
		</section>
	
	
	
	
		<div class="cat-social">
			
				
			


















	

				

	
	
		
	



	
	


	


<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">



	<li class="sosh">
		<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3321002%2Fstreaming-hardware%2Famazon-fire-tv-recast-review.html" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg" />
		</a>
	</li>
	<li class="sosh">
		<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3321002%2Fstreaming-hardware%2Famazon-fire-tv-recast-review.html&via=TechHive&text=Amazon+Fire+TV+Recast+review%3A+This+over-the-air+DVR+is+frustratingly+close+to" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg" />
		</a>	
	</li>
	<li class="sosh">
		<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3321002%2Fstreaming-hardware%2Famazon-fire-tv-recast-review.html" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/gplus.svg" />
		</a>	
	</li>
	<li class="sosh">
		<a class="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?url=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3321002%2Fstreaming-hardware%2Famazon-fire-tv-recast-review.html&description=Amazon+Fire+TV+Recast+review%3A+This+over-the-air+DVR+is+frustratingly+close+to" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/pinterest.svg" />
		</a>
	</li>
	<li class="sosh">
		<a href="http://reddit.com/submit?url=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3321002%2Fstreaming-hardware%2Famazon-fire-tv-recast-review.html&title=Amazon+Fire+TV+Recast+review%3A+This+over-the-air+DVR+is+frustratingly+close+to" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg" />
		</a>
	</li>
	<li class="sosh cat">
		<a href="#email" id="email-icon">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg" />
		</a>
	</li>
	<li class="sosh hide cat print">
		<a href="javascript:window.print();">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg" />
		</a>
	</li>



</ul>
</div>
<script type="text/javascript">
var isValidEmailAddress = isValidEmailAddress || function(emailAddress) {
    var pattern = new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);
    return pattern.test(emailAddress);
};
function encodeQueryData(params) {
	var ret = [];
	for (var paramKey in params) {
		ret.push(encodeURIComponent(paramKey) + "=" + encodeURIComponent(params[paramKey]));
	}
	return ret.join("&");
}	
function bindEmailModal() {
	$('#emailModal').on("click",".close-btn",function(event) {
		event.preventDefault();
        $('#emailModal').hide();
        $("#emailModal .eml-friend").show();
        $(".eml-friend-success").hide();
        $(".eml-friend-error").hide();
		$('#emailModal').fadeOut(200);
		$('#email-to').val('');
		$('#email-from').val('');
		$('#name').val('');
		$('#personalization').val('');
		$('#eml-from-address-message').html("");
		$('#eml-to-address-message').html("");
		$('#eml-friend-captcha-message').html("");
	});

	$('#emailModal').on("submit","form",function(event) {
		event.preventDefault();
		var $form = $(this);
		var action = $form.attr('action');
		var formData = $form.serialize();
		var emailFrom = $('#email-from').val();
		var emailTo = $('#email-to').val();
		var uresponse=$('#g-recaptcha-response').val();
		$('#eml-from-address-message').html("");
		$('#eml-to-address-message').html("");
		$('#eml-friend-captcha-message').html("");
		if (isValidEmailAddress(emailFrom) && isValidEmailAddress(emailTo) && uresponse !="") {
			// eloqua
			
			// email
			$.ajax(action, {
				type: 'POST',
				data: formData,
				success: function(data, textStatus, xhr) {
					$("#emailModal .eml-friend").hide();
					$(".eml-friend-success").fadeIn(800);	
				},
				error: function(xhr, textStatus, errorThrown) {
					$("#emailModal .eml-friend").hide();
					$(".eml-friend-error").fadeIn(800);						
				}
			});
		}
		else {	
			if(uresponse==""){
				$('#eml-friend-captcha-message').html("Please verify you're not a robot!");	
			}
			if(!isValidEmailAddress(emailTo)){
			  $('#eml-to-address-message').html("Please enter a valid email address.");		
			}
			if(!isValidEmailAddress(emailFrom)){
			  $('#eml-from-address-message').html("Please enter a valid email address.");		
			}
		}
	});
} //bindEmailModal() end

$(document).ready(function() {
	$(document).on("click","#email-icon",function(event) {
		event.preventDefault();
		bindEmailModal();
		$('#emailModal').fadeIn(800);
	});
});
</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">	
	<form class="eml-friend" action="/eloquaemail/article?eloqua=false&id=3321002">
		<input type="hidden" name="title" value="Amazon Fire TV Recast review: This over-the-air DVR is frustratingly close to great" />
		<input type="hidden" name="url" value="https://www.techhive.com/article/3321002/streaming-hardware/amazon-fire-tv-recast-review.html" />
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Email a friend</h3>

		<div class="input-row">
			<div id="eml-to-address-message" class="error-msg"></div>
			<h4 class="input-label">To</h4>
			<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
			<p class="addl-text">Use commas to separate multiple email addresses</p>
		</div>
		<hr />
		<div class="input-row">
			<div id="eml-from-address-message" class="error-msg"></div>
			<h4 class="input-label">From</h4>
			<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
		</div>
		<div class="input-row">
			<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
		</div>
		<div class="input-row">
			<textarea name="message" placeholder="Check out this article I found on TechHive." id="personalization" tabindex="4"></textarea>
		</div>
		<hr />
		<div class="input-row">
			<div id="eml-friend-captcha-message" class="error-msg"></div>
		
		
 			











<script src="https://www.google.com/recaptcha/api.js" async defer></script>

<div class="g-recaptcha" data-sitekey="6LczmkcUAAAAANEO7J277KwH6Kzp6BEQjPTWP4S4"></div>
 		</div>
		<hr />
		<div class="submit">
			<input type="submit" value="Send" class="input-submit" tabindex="5">
			<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
		</div>
	</form>

	<div class="eml-ty eml-friend-success" style="display:none;">
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Thank you</h3>
		<p class="msg-sent">Your message has been sent.</p>
	</div>
	<div class="eml-friend-error" style="display:none;">
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Sorry</h3>
		<p class="msg-sent">There was an error emailing this page.</p>
	</div>
</div>

		</div>
	
	
	

	
		
			
				
				<div class="cat byline vcard author with-image">		
					<div class="byline-wrapper">
						<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
							
						
							
							
							
							
						
















<a href="/author/Jared-Newman/" rel="author" title="Jared Newman"><img  class="bylineImage  imgId100004509 " src="https://images.techhive.com/images/article/2012/09/jnprofil-100004509-byline.jpg" width="34" width="34" alt="Jared Newman" itemprop="image" /></a>

						
							
								
							
















<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Jared-Newman/"><span itemprop="name">Jared Newman</span></a></span>
						</p>
						<p class="dateline">
						
							
								
									
								












<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">TechHive</span><meta itemprop="logo" content=""/></span> <span class="divider">|</span>
							
										
							<span class="pub-date"  itemprop="datePublished" content="2018-11-14T06:00-0800">Nov 14, 2018 6:00 AM
								 PT
							</span>
						</p>
					</div>
				</div>
			
		
	
	
		
	
	
	
	
		
			<div id="articleLeaderboardWrapper">
				<div id="articleLeaderboardInner">
						
						
								
									
								




















	
		
		
		
		
			<div id="gpt-leaderboard" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-leaderboard", "true");
	    			$('#gpt-leaderboard').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-leaderboard [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
						
				</div>
			</div>
			
				
			




















	
		
		
		
		
			<div id="gpt-leaderboardmobile" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-leaderboardmobile", "true");
	    			$('#gpt-leaderboardmobile').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-leaderboardmobile [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	 
		
	
	
	
</header>




	
	
	
	
		<div class="lede-container">
			
			
			
				
				
					
		                
		                	
		                	
		                
		                
						
						
						
					
					
					
					
					<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
						<meta itemprop="representativeOfPage" content="1" />
						<meta itemprop="height" content="467" />
						<meta itemprop="width" content="700" />
			    		
			    		<img src="https://images.idgesg.net/images/article/2018/11/firetvrecast1-100780083-large.jpg" alt="firetvrecast1" itemprop="contentUrl" itemprop="url" onload="try {performance.clearMarks('mark_primary_img_rendered'); performance.mark('mark_primary_img_rendered');}catch(e) {console.log('Error saving performance mark -- this function may not be supported in this browser');}"/>
			    		
				    		<script>
				    			try {
				    				performance.clearMarks("mark_primary_img_rendered");
									performance.mark("mark_primary_img_rendered");
				    			}
				    			catch(e) {
				    				console.log("Error saving performance mark -- this function may not be supported in this browser");
				    			}
							</script>
						
			    		<figcaption>
			    			
			    			
			    				<span class="credit" itemprop="copyrightHolder">
			    					
					    				
					    				Jared Newman / IDG
				    				
		
					    			
					    				
					    				
					    				
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
					    				
					    				
										
									
							
								</span>
			    			
							
			    		</figcaption>
					</figure>
					
		
				
				
			
		</div>
	











	
	
	
	
		
	



<section class="epo cat-narrow" id="drr-top-ad">
	
		
		
				
   	
   	
   	
   		
   			
   		











<!-- Related -->










	<div class="related-promo-wrapper">
		<div class="sector apart">
			<div class="hed">More like this</div>
	    	<ul class="">
		    	
		    		
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3173175/streaming-hardware/best-dvr-for-cord-cutters.html"><img  class="small.3x2Image  imgId100719630 " src="https://images.techhive.com/images/article/2017/04/ota-dvr-product-hub-art-100719630-small.3x2.jpg" alt="ota dvr product hub art" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3173175/streaming-hardware/best-dvr-for-cord-cutters.html">Best DVR for cord cutters</a></div>
	</div>
</li>
		    	
		    		
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3316657/home-theater/tivo-bolt-ota-dvr-review.html"><img  class="small.3x2Image  imgId100778387 " src="https://images.idgesg.net/images/article/2018/10/tivo_ota_02_22_29_17-100778387-small.3x2.jpg" alt="tivo ota 02 22 29 17" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3316657/home-theater/tivo-bolt-ota-dvr-review.html">TiVo Bolt OTA DVR review: More features, but many familiar drawbacks as well</a></div>
	</div>
</li>
		    	
		    		
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3319517/data-center-cloud/fire-tv-how-to.html"><img  class="small.3x2Image  imgId100778679 " src="https://images.idgesg.net/images/article/2018/10/firetvstick4kalt-100778679-small.3x2.jpg" alt="firetvstick4kalt" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3319517/data-center-cloud/fire-tv-how-to.html">Fire TV how-to tips: Make the most of Amazon&#039;s media streamers</a></div>
	</div>
</li>
		    	
		    	
					
					
						
						
						
							
							
							
							
							
							
							
							
							
							
						




























































	
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
							
						
					














<li class="clearfix with-image">
	
		<a  class="play" href="/video/91587/google-home-hub-the-least-expensive-smart-display-is-one-of-the-best"><i class="ss-play"></i></a>
		<a  href="/video/91587/google-home-hub-the-least-expensive-smart-display-is-one-of-the-best"><img  class="small.3x2Image  imgId100777819 " src="https://images.idgesg.net/images/article/2018/10/trv18_039_googlehomehub-100777819-small.3x2.jpg" alt="trv18 039 googlehomehub" itemprop="image" /></a>
    
	<div class="item">
		<div class="item-eyebrow">Video</div>
		<div class="title"><a  href="/video/91587/google-home-hub-the-least-expensive-smart-display-is-one-of-the-best">Google Home Hub: The least-expensive smart display is one of the best</a></div>
	</div>
</li>
				
				
			
		
	




					
				
		    </ul>
		</div>
	</div>

   	


				<div class="ad top-ad">
	
		
		
			
				
					
						
					
					
				
				
				
			





















	

		
			
			
			
			
			
				<div id="gpt-showcase" class="adunit ad-container">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				if($(window).width() >= 930) {
					IDG.GPT.addDisplayedAd("gpt-showcase", "true");
					$('#gpt-showcase').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: gpt-showcase - [971 1115]");
				}
				});
				</script>
			
		
	
 	
 
 
		
	
</div>
		
	
</section>







	





















	
	
	






	
	
	
	
	
	
	
	<div class="at-a-glance multiple top" data-tracking-category="ecomm-aag-top">
		
		<div class="product-list-header">At a Glance</div>
		<ul class="aag-list">
			
			
				
						
							
						
						
				
				
				<li class="aag-item multiple " data-product-id="1441704" >
					
						<div class="product-left">
						
						<span>
					
					
						
						
					
					<h3 class="product-name">
						
							
							Amazon Fire TV Recast (75-hour model)
						
					</h3>
					</span>
					
						
						
						
							
							<div class="rating"><span class="rating-star four-star"></span></div>
							
							
							
							
						
					</div>
										
					
					<div class="product-right">
						
						
						<div class="price-msrp">
							
							<a href="http://buy.geni.us/Proxy.ashx?TSID=14157&GR_URL=https%3A%2F%2Fwww.amazon.com%2FFire-Recast-over-air-hours%2Fdp%2FB01J6A6H74%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB01J6A6H74%26ascsubtag%3DUS-003-3321002-001-1441704-web-20" target="_blank" rel="nofollow" class="product-list-price trackLink" data-product-id="1441704" data-po="amazon" data-bkc="ConsumerElectronics" data-bkmfr="Amazon" data-bkvndr="Amazon" data-product-name="Amazon Fire TV Recast (75-hour model)" data-vars-product-id="1441704" data-vars-bkmfr="Amazon" data-vars-bkvndr="Amazon" data-vars-product-name="Amazon Fire TV Recast (75-hour model)" data-vars-outbound-link="https://www.amazon.com/Fire-Recast-over-air-hours/dp/B01J6A6H74?psc=1&SubscriptionId=AKIAIVYSMSQJCH4VBFJA&tag=techhivecom-20&linkCode=xm2&camp=2025&creative=165953&creativeASIN=B01J6A6H74" data-vars-link-position-id="001" data-vars-link-position="AAG Top">$229.99</a>	
							
													</div>
						<a href="http://buy.geni.us/Proxy.ashx?TSID=14157&GR_URL=https%3A%2F%2Fwww.amazon.com%2FFire-Recast-over-air-hours%2Fdp%2FB01J6A6H74%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB01J6A6H74%26ascsubtag%3DUS-003-3321002-001-1441704-web-20" target="_blank" rel="nofollow" class="btn-amazon trackLink" data-product-id="1441704" data-po="amazon" data-bkc="ConsumerElectronics" data-bkmfr="Amazon" data-bkvndr="Amazon" data-product-name="Amazon Fire TV Recast (75-hour model)"  data-vars-product-id="1441704" data-vars-bkmfr="Amazon" data-vars-bkvndr="Amazon" data-vars-product-name="Amazon Fire TV Recast (75-hour model)" data-vars-outbound-link="https://www.amazon.com/Fire-Recast-over-air-hours/dp/B01J6A6H74?psc=1&SubscriptionId=AKIAIVYSMSQJCH4VBFJA&tag=techhivecom-20&linkCode=xm2&camp=2025&creative=165953&creativeASIN=B01J6A6H74" data-vars-link-position-id="001" data-vars-link-position="AAG Top">See it</a>
						<div class="vendor">
							<a href="http://buy.geni.us/Proxy.ashx?TSID=14157&GR_URL=https%3A%2F%2Fwww.amazon.com%2FFire-Recast-over-air-hours%2Fdp%2FB01J6A6H74%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB01J6A6H74%26ascsubtag%3DUS-003-3321002-001-1441704-web-20" target="_blank" rel="nofollow">on <span class="vendor-name">Amazon</span></a>
						</div>
					</div>
					
				
				
			</li>
			
			
				
						
							
						
						
				
				
				<li class="aag-item multiple " data-product-id="1441705" >
					
						<div class="product-left">
						
						<span>
					
					
						
						
					
					<h3 class="product-name">
						
							
							Amazon Fire TV Recast (150-hour model)
						
					</h3>
					</span>
					
						
						
						
							
							<div class="rating"><span class="rating-star four-star"></span></div>
							
							
							
							
						
					</div>
										
					
					<div class="product-right">
						
						
						<div class="price-msrp">
							
							<a href="http://buy.geni.us/Proxy.ashx?TSID=14157&GR_URL=https%3A%2F%2Fwww.amazon.com%2FFire-Recast-over-air-hours%2Fdp%2FB074J1GPB8%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB074J1GPB8%26ascsubtag%3DUS-003-3321002-001-1441705-web-20" target="_blank" rel="nofollow" class="product-list-price trackLink" data-product-id="1441705" data-po="amazon" data-bkc="ConsumerElectronics" data-bkmfr="Amazon" data-bkvndr="Amazon" data-product-name="Amazon Fire TV Recast (150-hour model)" data-vars-product-id="1441705" data-vars-bkmfr="Amazon" data-vars-bkvndr="Amazon" data-vars-product-name="Amazon Fire TV Recast (150-hour model)" data-vars-outbound-link="https://www.amazon.com/Fire-Recast-over-air-hours/dp/B074J1GPB8?psc=1&SubscriptionId=AKIAIVYSMSQJCH4VBFJA&tag=techhivecom-20&linkCode=xm2&camp=2025&creative=165953&creativeASIN=B074J1GPB8" data-vars-link-position-id="001" data-vars-link-position="AAG Top">$279.99</a>	
							
													</div>
						<a href="http://buy.geni.us/Proxy.ashx?TSID=14157&GR_URL=https%3A%2F%2Fwww.amazon.com%2FFire-Recast-over-air-hours%2Fdp%2FB074J1GPB8%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB074J1GPB8%26ascsubtag%3DUS-003-3321002-001-1441705-web-20" target="_blank" rel="nofollow" class="btn-amazon trackLink" data-product-id="1441705" data-po="amazon" data-bkc="ConsumerElectronics" data-bkmfr="Amazon" data-bkvndr="Amazon" data-product-name="Amazon Fire TV Recast (150-hour model)"  data-vars-product-id="1441705" data-vars-bkmfr="Amazon" data-vars-bkvndr="Amazon" data-vars-product-name="Amazon Fire TV Recast (150-hour model)" data-vars-outbound-link="https://www.amazon.com/Fire-Recast-over-air-hours/dp/B074J1GPB8?psc=1&SubscriptionId=AKIAIVYSMSQJCH4VBFJA&tag=techhivecom-20&linkCode=xm2&camp=2025&creative=165953&creativeASIN=B074J1GPB8" data-vars-link-position-id="001" data-vars-link-position="AAG Top">See it</a>
						<div class="vendor">
							<a href="http://buy.geni.us/Proxy.ashx?TSID=14157&GR_URL=https%3A%2F%2Fwww.amazon.com%2FFire-Recast-over-air-hours%2Fdp%2FB074J1GPB8%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB074J1GPB8%26ascsubtag%3DUS-003-3321002-001-1441705-web-20" target="_blank" rel="nofollow">on <span class="vendor-name">Amazon</span></a>
						</div>
					</div>
					
				
				
			</li>
			
		</ul>
	</div>









		<section class="bodee">

			
				
				
					


















<style>
	#drr-container figure.large.video {
		border-bottom: 0 none;
	}
	figure#page-lede.thm-gallery.rr-gallery-vid #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 300px !important;
		height: 169px !important;
		transition: all 0.5s ease;
	}
	figure#page-lede.thm-gallery #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 100%;
		height: 100%;
		transition: all 0.5s ease;
	}
</style>
<style>
.jwplayer.jw-state-paused .jw-display {
	display: table !important;
	padding: 0;
}
.jwplayer .jw-display-icon-container {
    float: none;
    padding: 0;
    margin: 0;
}
.jw-flag-small-player .jw-display {
	padding-top: 0px;
}
.jwplayer .jw-display-icon-container .jw-icon-rewind {
	visibility: hidden;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play path,
.jw-state-idle .jw-svg-icon-play path,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay path,
.jw-state-complete .jw-svg-icon-replay path {    
    display: none;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    background-size: contain;
    background-repeat: no-repeat;
    background-color: transparent;
    background-image: url(//idge.staticworld.net/idgtv/btn-play-default.svg);
    background-position: center center;
    bottom: 0;
    border-radius: 0;
    box-shadow: none;
    left: 0;
    margin: auto;
    right: 0;
    top: 0;
}
.jwplayer .jw-display-icon-container .jw-icon,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    height: 81px;
    width: 78px;
}
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container .jw-icon,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jw-state-idle .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.thm-gallery.rr-gallery-vid .jw-state-complete .jw-svg-icon-replay  {
	height: 65px;
    width: 62px;
}
</style>


	







	<div class="ad placement">
		
			
		





















	

		
			
			
				<!--  Begin gpt-skin/inread -->
				<div id="inread" class=" ad-container">					
				</div>
				<script type="text/javascript">
				consent.ads.queue.push(function(){
					IDG.GPT.addDisplayedAd("inread", "true");
					IDG.GPT.displayGoogleTagSlot('inread');
				});
				</script>
				<!--  End gpt-skin/inread -->	
			
			
			
			
		
	
 	
 
 
	</div>








	
	
		
		
		<script>
			var dataLayer = window.dataLayer = window.dataLayer || [];
			dataLayer.push({
				'event': 'loadTopCollectionModule'
				});
		</script>
		
	


















<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>
		


	
		<script>
			function gatherPerformanceMarks() {
				p = performance.getEntriesByType("mark");
				gtmEvent = {'event': 'gatherPerformanceMarks'};
			  	for (var i=0; i < p.length; i++) {
				    //console.log ("+++Mark only entry[" + i + "]: name = " + p[i].name + "; startTime = " + p[i].startTime);
				    gtmEvent[p[i].name] = p[i].startTime;
				  }
			  	var dataLayer = window.dataLayer = window.dataLayer || [];
				dataLayer.push(gtmEvent);
			}
		  </script>
		

		












	
	



<script type="text/javascript">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</script>






	
		
	
	





	
		
			
			
			
				
			
			
		
	
	


	
	
		<div id="drr-container" class='cat ' itemprop="reviewBody">
	
	
	
	

	<p>The mere existence of <a href="https://www.amazon.com/Fire-TV-Recast-over-the-air-DVR-500GB-75-hours/dp/B01J6A6H74" rel="nofollow">Amazon’s Fire TV Recast</a> is a testament to how popular <a href="https://www.techhive.com/column/cord-cutter-confidential/">cord-cutting</a> has become.</p><p>Over-the-air DVR was once the domain of geeks whose living rooms ran on Windows Media Center. But as more people have dropped cable TV, we’ve seen more user-friendly approaches from the likes of <a href="https://www.techhive.com/article/3316657/home-theater/tivo-bolt-ota-dvr-review.html">TiVo</a>, <a href="https://www.techhive.com/article/3268934/streaming-hardware/tablo-dual-lite-dvr-review.html">Tablo</a>, <a href="https://www.techhive.com/article/3264649/home-theater/plex-dvr-review.html">Plex</a>, <a href="https://www.techhive.com/article/3229007/streaming-hardware/channels-dvr-review.html">Channels</a>, and <a href="https://www.techhive.com/article/3307098/data-center-cloud/airtv-dvr-doesnt-pick-up-sling-tvs-slack.html">AirTV</a>. Those options presumably helped inspire the Fire TV Recast, a $230 box that records free broadcast TV channels from an antenna and streams the video to Amazon’s popular Fire TV devices.</p><p>The Fire TV Recast is the most mainstream attempt yet at over-the-air DVR, and it shows in Amazon’s simple and polished software. The Recast is also cheaper than most other options due to its lack of subscription fees. Still, Amazon’s DVR has several major limitations—most notably the need for a Fire TV device to watch on televisions—that will make it a non-starter for many cord-cutters. One thing hasn’t changed over the years: The perfect cord-cutting DVR still eludes us.</p><aside class="fakesidebar"><a href="http://www.techhive.com/article/3173175/streaming-hardware/best-dvr-for-cord-cutters.html">[ Further reading: The best DVRs for cord cutters ]</a></aside><h2>Low-hassle setup</h2><p>Unlike a traditional DVR, such as TiVo, the Recast does not plug directly into your television. Instead, you can place it anywhere in the house, and it’ll stream broadcast channels to your Fire TV, Fire tablets, iOS devices, and Android mobile devices over Wi-Fi. (The Recast also has an ethernet port for a wired connection to the router, but you’ll need to supply your own cable.) It’s compatible with any antenna through its coaxial input.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2018/11/firetvrecastrear-100780084-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2018/11/firetvrecastrear-100780084-large.jpg" border="0" alt="firetvrecastrear" width="700" height="467" data-imageid="100780084" data-license="IDG"/></a> <small class="credit">Jared Newman / IDG</small>
<figcaption>
<p>The Fire TV Recast works with any antenna, and it has an ethernet jack if you don’t want to rely on Wi-Fi. The USB port will support external hard drives in the future.</p>
</figcaption>
</figure><p>Amazon clearly gave some thought to the potential hassles of a networked DVR. Rather than making users connect an external hard drive, Amazon included a 500GB drive in the $230 dual-tuner model, which is good for 75 hours of HD video. There’s also a 1TB model—that’s enough storage to record 150 hours of HD video—with four tuners for $280. While the Recast does have a USB port that will eventually support external storage, it’s not necessary to record plenty of shows.</p><aside class="emo emo-sb">
<h6 class="nav-title">Mentioned in this article</h6>
<div class="product-details">
<figure class="productFigure"><a href="https://www.techhive.com/article/3316657/home-theater/tivo-bolt-ota-dvr-review.html" rel="noopener" target="_blank"><img src="https://images-na.ssl-images-amazon.com/images/I/31z33osqk7L.jpg" border="0" data-productid="1441707"/></a><a class="product-name" href="https://www.techhive.com/article/3316657/home-theater/tivo-bolt-ota-dvr-review.html" data-productid="1441707">TiVo Bolt OTA</a></figure>

 <div class="product-lines"><div class="product-line1"><div class="rating"> <a href="https://www.techhive.com/article/3316657/home-theater/tivo-bolt-ota-dvr-review.html"><span class="rating-star three-star"/></a></div><span class="product-brand"><a href="https://www.techhive.com/article/3316657/home-theater/tivo-bolt-ota-dvr-review.html">Read TechHive's review</a></span></div><div class="product-line2"><div class="price-msrp"><a class="product-list-price" href="http://buy.geni.us/Proxy.ashx?TSID=14157&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2FTiVo-Bolt-Antenna-All-One%2Fdp%2FB07GY54JPV%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB07GY54JPV%26ascsubtag%3DUS-003-3321002-005-1441707-web-20" rel="nofollow" target="_blank" data-product-name="Bolt OTA" data-vars-product-name="Bolt OTA" data-vars-link-position-id="005" data-vars-link-position="Product Sidebar" data-po="amazon" data-vars-outbound-link="https://www.amazon.com/TiVo-Bolt-Antenna-All-One/dp/B07GY54JPV?psc=1&amp;SubscriptionId=AKIAIVYSMSQJCH4VBFJA&amp;tag=techhivecom-20&amp;linkCode=xm2&amp;camp=2025&amp;creative=165953&amp;creativeASIN=B07GY54JPV" data-product-id="1441707" data-vars-product-id="1441707" data-bkc="ConsumerElectronics" data-bkmfr="TiVo" data-vars-bkmfr="TiVo" data-bkvndr="Amazon" data-vars-bkvndr="Amazon">$249.93</a><span class="msrp">MSRP $249.99</span></div><a class="btn-amazon" href="http://buy.geni.us/Proxy.ashx?TSID=14157&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2FTiVo-Bolt-Antenna-All-One%2Fdp%2FB07GY54JPV%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB07GY54JPV%26ascsubtag%3DUS-003-3321002-005-1441707-web-20" rel="nofollow" target="_blank" data-product-name="Bolt OTA" data-vars-product-name="Bolt OTA" data-vars-link-position-id="005" data-vars-link-position="Product Sidebar" data-po="amazon" data-vars-outbound-link="https://www.amazon.com/TiVo-Bolt-Antenna-All-One/dp/B07GY54JPV?psc=1&amp;SubscriptionId=AKIAIVYSMSQJCH4VBFJA&amp;tag=techhivecom-20&amp;linkCode=xm2&amp;camp=2025&amp;creative=165953&amp;creativeASIN=B07GY54JPV" data-product-id="1441707" data-vars-product-id="1441707" data-bkc="ConsumerElectronics" data-bkmfr="TiVo" data-vars-bkmfr="TiVo" data-bkvndr="Amazon" data-vars-bkvndr="Amazon">See it</a></div><div class="product-line3 vendor"><a href="http://buy.geni.us/Proxy.ashx?TSID=14157&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2FTiVo-Bolt-Antenna-All-One%2Fdp%2FB07GY54JPV%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB07GY54JPV%26ascsubtag%3DUS-003-3321002-005-1441707-web-20" rel="nofollow">on <span class="vendor-name">Amazon</span></a></div></div></div>
</aside><p>The Fire TV mobile app also does a good job with the setup process, offering plenty of guidance on where to place your antenna before connecting the Recast to Wi-Fi and scanning for channels. It even suggests a side of the house for installation, using your location and antenna range to figure out which direction is exposed to the most broadcast towers.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2018/11/firetvrecastsetup-100780085-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2018/11/firetvrecastsetup-100780085-large.jpg" border="0" alt="firetvrecastsetup" width="700" height="349" data-imageid="100780085" data-license="IDG"/></a> <small class="credit">Jared Newman / IDG</small>
<figcaption>
<p>Amazon’s Fire TV mobile app helps you figure out the best place to install the Recast.</p>
</figcaption>
</figure><p>You don’t even need to install any additional apps once the Recast is set up. Any Fire TV devices on the same network will discover the DVR automatically and add a new “DVR” section to the top menu bar. You’ll use the same Fire TV app for mobile streaming that you used for the installation.</p><h2>All about that interface</h2><p>The Fire TV Recast’s biggest drawback is that you need a Fire TV device to watch on televisions. Recast is incompatible with non-Amazon media-streaming devices such as Roku, Apple TV, Chromecast, game consoles, and most smart TVs. You can mirror an Android phone’s screen to Chromecast, or an iOS device’s screen to Apple TV via AirPlay, but the screen must stay focused on the Fire TV app the entire time. This is not a great workaround.</p><aside class="nativo-promo nativo-promo-1 smartphone tablet desktop" id=""> </aside><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2018/11/recastdvr-100780082-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2018/11/recastdvr-100780082-large.jpg" border="0" alt="recastdvr" width="700" height="394" data-imageid="100780082" data-license="IDG"/></a> <small class="credit">Jared Newman / IDG</small>
<figcaption>
<p>The Fire TV automatically adds a DVR menu when the Recast is on the same network.</p>
</figcaption>
</figure><p>If you’re all in on Fire TV, on the other hand, the Recast’s integration turns out to be its greatest strength. Instead of jumping into a separate app, you can access live channels, recordings, DVR settings, and a grid-based channel guide straight from the Fire TV’s DVR menu.</p><aside class="emo emo-sb">
<h6 class="nav-title">Mentioned in this article</h6>
<div class="product-details">
<figure class="productFigure"><span><img src="https://images.idgesg.net/images/article/2018/04/plex-logo-100754970-small.jpg" border="0" data-productid="1440552"/></span><span class="product-name" data-productid="1440552">Plex DVR</span></figure>

 <div class="product-lines"><div class="product-line1"><div class="rating"> <span class="rating-star three-half-star"/></div></div><div class="product-line2"><div class="price-msrp"><a class="product-list-price" href="https://go.redirectingat.com/?id=111346X1569484&amp;url=https%3A%2F%2Fwww.plex.tv%2F&amp;sref=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3321002%2Fstreaming-hardware%2Famazon-fire-tv-recast-review.html" target="_blank" data-product-name="Plex DVR" data-vars-product-name="Plex DVR" data-vars-link-position-id="005" data-vars-link-position="Product Sidebar" data-po="vendor" data-vars-outbound-link="https://www.plex.tv/" data-product-id="1440552" data-vars-product-id="1440552" data-bkc="Software" data-bkmfr="Plex" data-vars-bkmfr="Plex" data-bkvndr="Plex" data-vars-bkvndr="Plex">$120.00</a><span class="msrp">MSRP $120.00</span></div><a class="btn-amazon" href="https://go.redirectingat.com/?id=111346X1569484&amp;url=https%3A%2F%2Fwww.plex.tv%2F&amp;sref=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3321002%2Fstreaming-hardware%2Famazon-fire-tv-recast-review.html" target="_blank" data-product-name="Plex DVR" data-vars-product-name="Plex DVR" data-vars-link-position-id="005" data-vars-link-position="Product Sidebar" data-po="vendor" data-vars-outbound-link="https://www.plex.tv/" data-product-id="1440552" data-vars-product-id="1440552" data-bkc="Software" data-bkmfr="Plex" data-vars-bkmfr="Plex" data-bkvndr="Plex" data-vars-bkvndr="Plex">See it</a></div><div class="product-line3 vendor"><a href="https://go.redirectingat.com/?id=111346X1569484&amp;url=https%3A%2F%2Fwww.plex.tv%2F&amp;sref=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3321002%2Fstreaming-hardware%2Famazon-fire-tv-recast-review.html">on <span class="vendor-name">Plex</span></a></div></div></div>
</aside><p>Amazon also weaves over-the-air programming into other parts of the Fire TV interface. The “Recents” row on the home screen includes your most recently watched channel, for instance, while the “On Now” row lists all channels. You can even use the Fire TV’s search function to find over-the-air programming by name, actor, director, or genre. Amazon’s grid guide also supports streaming sources such as certain <a href="https://www.techhive.com/article/3161168/streaming-services/interview-how-amazon-channels-is-building-a-la-carte-tv.html">Amazon Channels</a> add-ons (including HBO and Showtime), Pluto TV, and PlayStation Vue. If more sources like Philo and Sling TV were to support that guide, it could become a powerful way to get all your live TV in one place.. </p><figure class="large "><img src="https://images.idgesg.net/images/article/2018/11/recasthome2-100780079-large.jpg" border="0" alt="recasthome2" width="700" height="394" data-imageid="100780079" data-license="IDG"/> <small class="credit">Jared Newman / IDG</small>
<figcaption>
<p>The Fire TV puts Recast’s over-the-air channels right on the home screen.</p>
</figcaption>
</figure><p>The Fire TV Recast also works with Alexa voice commands, so you can use the Fire TV voice remote or an Amazon Echo speaker to launch live channels, play your recordings, open the channel guide, delete recordings, and check on storage space. If you have an <a href="https://www.techhive.com/article/3311984/hubs-controllers/amazon-echo-show-2nd-generation-review.html">Amazon Echo Show</a> smart display, you can play over-the-air programming on that device as well.</p><p>Amazon hasn’t ruled out supporting other streaming devices in the future. (The company merely says it won’t comment on future plans.) But even if the Fire TV Recast does eventually work with devices like Roku and Apple TV, the experience will always be better on Fire TV thanks to its home-screen integration and voice controls.</p><aside class="nativo-promo nativo-promo-2 tablet desktop smartphone" id=""> </aside><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2018/11/recastguide-100780076-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2018/11/recastguide-100780076-large.jpg" border="0" alt="recastguide" width="700" height="394" data-imageid="100780076" data-license="IDG"/></a> <small class="credit">Jared Newman / IDG</small>
<figcaption>
<p>Yes, there’s a grid guide.</p>
</figcaption>
</figure><h2>DVR options galore</h2><p>When it comes to recording live TV, Amazon has a strong grasp of what cord-cutters might want.</p><aside class="emo emo-sb">
<h6 class="nav-title">Mentioned in this article</h6>
<div class="product-details">
<figure class="productFigure"><a href="https://www.techhive.com/article/3311984/hubs-controllers/amazon-echo-show-2nd-generation-review.html" rel="noopener" target="_blank"><img src="https://images-na.ssl-images-amazon.com/images/I/41Yi3DRr-zL.jpg" border="0" data-productid="1441686"/></a><a class="product-name" href="https://www.techhive.com/article/3311984/hubs-controllers/amazon-echo-show-2nd-generation-review.html" data-productid="1441686">Amazon Echo Show (2nd Generation)</a></figure>

 <span class="editors-choice">  </span><div class="product-lines"><div class="product-line1"><div class="rating"> <a href="https://www.techhive.com/article/3311984/hubs-controllers/amazon-echo-show-2nd-generation-review.html"><span class="rating-star four-half-star"/></a></div><span class="product-brand"><a href="https://www.techhive.com/article/3311984/hubs-controllers/amazon-echo-show-2nd-generation-review.html">Read TechHive's review</a></span></div><div class="product-line2"><div class="price-msrp"><a class="product-list-price" href="http://buy.geni.us/Proxy.ashx?TSID=14157&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2FAll-new-Echo-Show-2nd-Gen%2Fdp%2FB077THMYGN%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB077THMYGN%26ascsubtag%3DUS-003-3321002-005-1441686-web-20" rel="nofollow" target="_blank" data-product-name="Echo Show (2nd Generation)" data-vars-product-name="Echo Show (2nd Generation)" data-vars-link-position-id="005" data-vars-link-position="Product Sidebar" data-po="amazon" data-vars-outbound-link="https://www.amazon.com/All-new-Echo-Show-2nd-Gen/dp/B077THMYGN?psc=1&amp;SubscriptionId=AKIAIVYSMSQJCH4VBFJA&amp;tag=techhivecom-20&amp;linkCode=xm2&amp;camp=2025&amp;creative=165953&amp;creativeASIN=B077THMYGN" data-product-id="1441686" data-vars-product-id="1441686" data-bkc="HomeTech" data-bkmfr="Amazon" data-vars-bkmfr="Amazon" data-bkvndr="Amazon" data-vars-bkvndr="Amazon">$229.99</a><span class="msrp">MSRP $229.99</span></div><a class="btn-amazon" href="http://buy.geni.us/Proxy.ashx?TSID=14157&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2FAll-new-Echo-Show-2nd-Gen%2Fdp%2FB077THMYGN%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB077THMYGN%26ascsubtag%3DUS-003-3321002-005-1441686-web-20" rel="nofollow" target="_blank" data-product-name="Echo Show (2nd Generation)" data-vars-product-name="Echo Show (2nd Generation)" data-vars-link-position-id="005" data-vars-link-position="Product Sidebar" data-po="amazon" data-vars-outbound-link="https://www.amazon.com/All-new-Echo-Show-2nd-Gen/dp/B077THMYGN?psc=1&amp;SubscriptionId=AKIAIVYSMSQJCH4VBFJA&amp;tag=techhivecom-20&amp;linkCode=xm2&amp;camp=2025&amp;creative=165953&amp;creativeASIN=B077THMYGN" data-product-id="1441686" data-vars-product-id="1441686" data-bkc="HomeTech" data-bkmfr="Amazon" data-vars-bkmfr="Amazon" data-bkvndr="Amazon" data-vars-bkvndr="Amazon">See it</a></div><div class="product-line3 vendor"><a href="http://buy.geni.us/Proxy.ashx?TSID=14157&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2FAll-new-Echo-Show-2nd-Gen%2Fdp%2FB077THMYGN%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB077THMYGN%26ascsubtag%3DUS-003-3321002-005-1441686-web-20" rel="nofollow">on <span class="vendor-name">Amazon</span></a></div></div></div>
</aside><p>Like most other DVRs, the Fire TV Recast supports series recordings, and it offers lots of granular control over what gets saved. You can add start and stop buffer times, protect recordings from deletion, keep only a certain number of recent episodes, record in HD or SD only, and avoid recording reruns. You can also rearrange the priority of recordings, so when a conflict arises, the Recast will offer to cancel the lowest-priority program on your list.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2018/11/recastoptions-100780077-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2018/11/recastoptions-100780077-large.jpg" border="0" alt="recastoptions" width="700" height="394" data-imageid="100780077" data-license="IDG"/></a> <small class="credit">Jared Newman / IDG</small>
<figcaption>
<p>No shortage of recording options here.</p>
</figcaption>
</figure><p>The Fire TV Recast does a fine job with live TV as well. Whenever you tune to a live channel, the Recast automatically starts creating a buffer, so you can pause and rewind without needing to create a recording first. Pressing down on the Fire TV remote also brings up a mini-guide, so you can see what else is on without closing or minimizing the current program.</p><p>Still, Amazon’s recording options aren’t quite as rich as Plex, TiVo, or Tablo. You can’t schedule recordings manually, and the maximum buffer time of one hour for series recordings could be an issue for extra-innings baseball games. The Recast doesn’t support series passes for specific sports teams, either, so you’ll need to record every NFL broadcast instead of just your home team’s games.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2018/11/recastminiguide-100780081-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2018/11/recastminiguide-100780081-large.jpg" border="0" alt="recastminiguide" width="700" height="394" data-imageid="100780081" data-license="IDG"/></a> <small class="credit">Jared Newman / IDG</small>
<figcaption>
<p>Amazon’s mini-guide doesn’t get in the way of live TV.</p>
</figcaption>
</figure><p>The biggest omission, though, is an easy way to avoid ads, akin to TiVo’s SkipMode button and Plex’s automatic ad deletion. The best that the Fire TV Recast can do is fast forward in 30-second increments.</p><h2>Solving the frame rate problem</h2><p>With every other networked DVR I’ve tested, there’ve been problems delivering smooth frame rates across all channels.</p><p>Tablo, for instance, tops out at 30 frames per second for channels that broadcast in 480i or 1080i. Plex only supports 60-frames-per-second video on those channels for certain devices, such as the $180 Nvidia Shield TV. Channels DVR can manage 60 frames per second on <em>all</em> channels, but Fire TV devices struggle to handle this unless you disable transcoding, which uses less bandwidth. AirTV doesn’t do 60-frames-per-second video at all. In practical terms, not having 60-frames-per-second support means video will look choppier than cable for sports, news, and talk shows.</p><p>The Fire TV Recast solves this problem through its powerful built-in transcoder, which can convert interlaced channels to a maximum 720p resolution at 60 frames per second. Every channel therefore looks as smooth as it would directly from an antenna. The Recast also supports 5.1 surround sound, so using it doesn’t feel like much of a compromise compared to non-networked DVRs.</p><p>The only trade-off is that the Fire TV Recast supports only two video streams at a time, even with the four-tuner model (which can still record four channels at once) and with recordings that don’t occupy a tuner at all. Tablo, by comparison, can provide up to six concurrent streams, provided you have the network bandwidth to handle it. (Amazon says it considered offering raw 1080i video as an option, but decided against it due to bandwidth issues. Videophiles and users with speedy home Wi-Fi might wish the company would reconsider.)</p><h2>Quirks and limitations</h2><aside class="emo emo-sb">
<h6 class="nav-title">Mentioned in this article</h6>
<div class="product-details">
<figure class="productFigure"><a href="https://www.techhive.com/article/3268934/streaming-hardware/tablo-dual-lite-dvr-review.html" rel="noopener" target="_blank"><img src="https://images.idgesg.net/images/article/2018/04/tablo-dvr-100755650-small.jpg" border="0" data-productid="1440737"/></a><a class="product-name" href="https://www.techhive.com/article/3268934/streaming-hardware/tablo-dual-lite-dvr-review.html" data-productid="1440737">Nuvyyo Tablo Dual Lite DVR</a></figure>

 <span class="editors-choice">  </span><div class="product-lines"><div class="product-line1"><div class="rating"> <a href="https://www.techhive.com/article/3268934/streaming-hardware/tablo-dual-lite-dvr-review.html"><span class="rating-star four-star"/></a></div><span class="product-brand"><a href="https://www.techhive.com/article/3268934/streaming-hardware/tablo-dual-lite-dvr-review.html">Read TechHive's review</a></span></div><div class="product-line2"><div class="price-msrp"><a class="product-list-price" href="https://go.redirectingat.com/?id=111346X1569484&amp;url=https%3A%2F%2Fwww.tablotv.com%2Fproducts%2Ftablo-dual-lite-ota-dvr%2F&amp;sref=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3321002%2Fstreaming-hardware%2Famazon-fire-tv-recast-review.html" target="_blank" data-product-name="Tablo Dual Lite DVR" data-vars-product-name="Tablo Dual Lite DVR" data-vars-link-position-id="005" data-vars-link-position="Product Sidebar" data-po="vendor" data-vars-outbound-link="https://www.tablotv.com/products/tablo-dual-lite-ota-dvr/" data-product-id="1440737" data-vars-product-id="1440737" data-bkc="ConsumerElectronics" data-bkmfr="Nuvyyo" data-vars-bkmfr="Nuvyyo" data-bkvndr="Tablo" data-vars-bkvndr="Tablo">$140.00</a><span class="msrp">MSRP $140.00</span></div><a class="btn-amazon" href="https://go.redirectingat.com/?id=111346X1569484&amp;url=https%3A%2F%2Fwww.tablotv.com%2Fproducts%2Ftablo-dual-lite-ota-dvr%2F&amp;sref=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3321002%2Fstreaming-hardware%2Famazon-fire-tv-recast-review.html" target="_blank" data-product-name="Tablo Dual Lite DVR" data-vars-product-name="Tablo Dual Lite DVR" data-vars-link-position-id="005" data-vars-link-position="Product Sidebar" data-po="vendor" data-vars-outbound-link="https://www.tablotv.com/products/tablo-dual-lite-ota-dvr/" data-product-id="1440737" data-vars-product-id="1440737" data-bkc="ConsumerElectronics" data-bkmfr="Nuvyyo" data-vars-bkmfr="Nuvyyo" data-bkvndr="Tablo" data-vars-bkvndr="Tablo">See it</a></div><div class="product-line3 vendor"><a href="https://go.redirectingat.com/?id=111346X1569484&amp;url=https%3A%2F%2Fwww.tablotv.com%2Fproducts%2Ftablo-dual-lite-ota-dvr%2F&amp;sref=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3321002%2Fstreaming-hardware%2Famazon-fire-tv-recast-review.html">on <span class="vendor-name">Tablo</span></a></div></div></div>
</aside><p>My time with the Fire TV Recast wasn’t completely devoid of issues. At one point, it stopped delivering consistent 60-frames-per-second video until I restarted the tuner, and Amazon’s Fire TV Stick 4K once lost its ability to fast forward or rewind through recordings without getting stuck on a loading screen. (I solved the latter problem by factory resetting the Fire TV Stick 4K.)</p><p>Stranger still, the Fire TV Stick 4K had some image pixelation that didn’t occur on Amazon’s third-generation Fire TV. This is apparently a bug that Amazon believes it has identified, though there’s no official timing on a fix yet.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2018/11/recastvschannels-100780086-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2018/11/recastvschannels-100780086-large.jpg" border="0" alt="recastvschannels" width="700" height="466" data-imageid="100780086" data-license="IDG"/></a> <small class="credit">Jared Newman / IDG</small>
<figcaption>
<p>Pixelation on the Fire TV Stick 4K (left) vs. full broadcast quality from Channels DVR (right). Amazon says this is being fixed.</p>
</figcaption>
</figure><p>The other limitations I haven’t mentioned yet pertain to out-of-home streaming. Currently, the Recast only supports remote viewing on iOS devices, Android mobile devices, and Fire tablets, so you can’t watch local TV on a Fire TV Stick while out of town. You also can’t download recordings to a mobile device for offline viewing, like you can with Plex and Channels DVR, and there’s no way to pull recordings off the Fire TV Recast like you can with <a href="https://www.techhive.com/article/3273709/consumer-electronics/tablo-dvr-tips.html">Tablo Ripper</a>.</p><p>In light of everything the Fire TV Recast doesn’t do, I can’t recommend it as the <em>best</em> DVR for most people. That honor still goes to the <a href="https://www.techhive.com/article/3268934/streaming-hardware/tablo-dual-lite-dvr-review.html">Tablo Dual Lite DVR</a>, which is about $100 pricier when you factor in an external hard drive and lifetime guide data, but it supports far more TV devices, including Roku’s popular streamers.</p><p>If you don’t mind locking yourself into the Fire TV and Alexa ecosystems for the foreseeable future, the Fire TV Recast will give you a great interface for over-the-air DVR, smooth video, bountiful recording options, useful Alexa voice controls, and freedom from subscription fees. For its first shot at a DVR for cord-cutters, Amazon has done its homework—and has given the incumbents a lot to think about.</p>

	
	
		
	
	
	
	
		
		
		
		










<div class="end-note">
	
		
	











	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2010 blox4.html  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
				
				
			
		
















	
		
		
			<div id="" class="blx blxParticleendnote blxM2010  blox4_html  blxC24070">To comment on this article and other TechHive content, visit our <a href="https://www.facebook.com/techhivemedia/" target="_blank">Facebook</a> page or our <a href="https://twitter.com/techhive" target="_blank">Twitter</a> feed. </div>
		
	

	


</div>
	
	
</div>

	<script>
		try {
			performance.mark("mark_article_body_rendered");
		}
		catch(e) {
			console.log("Error saving performance mark -- this function may not be supported in this browser");
		}
	</script>



	
	  
	


























	
	
	
	
	
	
	
	<div class="at-a-glance multiple expanded" data-tracking-category="ecomm-aag-expanded">
		
		<div class="product-list-header">At a Glance</div>
		<ul class="aag-list">
			
			
				
						
							
						
						
				
				
					
					
					
					
					
						
						
							
						
					
					
				
				<li class="aag-item multiple " data-product-id="1441704" >
					
						<div class="product-left">
						<i class="aag-toggle ss-icon ss-directright" title="View more details"></i>
						<span>
					
					
						
						
					
					<h3 class="product-name expandable" title="View More Details">
						
							
							Amazon Fire TV Recast (75-hour model)
						
					</h3>
					</span>
					
						
						
						
							
							<div class="rating"><span class="rating-star four-star"></span></div>
							
							
							
							
						
					</div>
										
					
					<div class="product-right">
						
						
						<div class="price-msrp">
							
							<a href="http://buy.geni.us/Proxy.ashx?TSID=14157&GR_URL=https%3A%2F%2Fwww.amazon.com%2FFire-Recast-over-air-hours%2Fdp%2FB01J6A6H74%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB01J6A6H74%26ascsubtag%3DUS-003-3321002-002-1441704-web-20" target="_blank" rel="nofollow" class="product-list-price trackLink" data-product-id="1441704" data-po="amazon" data-bkc="ConsumerElectronics" data-bkmfr="Amazon" data-bkvndr="Amazon" data-product-name="Amazon Fire TV Recast (75-hour model)" data-vars-product-id="1441704" data-vars-bkmfr="Amazon" data-vars-bkvndr="Amazon" data-vars-product-name="Amazon Fire TV Recast (75-hour model)" data-vars-outbound-link="https://www.amazon.com/Fire-Recast-over-air-hours/dp/B01J6A6H74?psc=1&SubscriptionId=AKIAIVYSMSQJCH4VBFJA&tag=techhivecom-20&linkCode=xm2&camp=2025&creative=165953&creativeASIN=B01J6A6H74" data-vars-link-position-id="002" data-vars-link-position="AAG Bottom">$229.99</a>	
							
													</div>
						<a href="http://buy.geni.us/Proxy.ashx?TSID=14157&GR_URL=https%3A%2F%2Fwww.amazon.com%2FFire-Recast-over-air-hours%2Fdp%2FB01J6A6H74%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB01J6A6H74%26ascsubtag%3DUS-003-3321002-002-1441704-web-20" target="_blank" rel="nofollow" class="btn-amazon trackLink" data-product-id="1441704" data-po="amazon" data-bkc="ConsumerElectronics" data-bkmfr="Amazon" data-bkvndr="Amazon" data-product-name="Amazon Fire TV Recast (75-hour model)"  data-vars-product-id="1441704" data-vars-bkmfr="Amazon" data-vars-bkvndr="Amazon" data-vars-product-name="Amazon Fire TV Recast (75-hour model)" data-vars-outbound-link="https://www.amazon.com/Fire-Recast-over-air-hours/dp/B01J6A6H74?psc=1&SubscriptionId=AKIAIVYSMSQJCH4VBFJA&tag=techhivecom-20&linkCode=xm2&camp=2025&creative=165953&creativeASIN=B01J6A6H74" data-vars-link-position-id="002" data-vars-link-position="AAG Bottom">See it</a>
						<div class="vendor">
							<a href="http://buy.geni.us/Proxy.ashx?TSID=14157&GR_URL=https%3A%2F%2Fwww.amazon.com%2FFire-Recast-over-air-hours%2Fdp%2FB01J6A6H74%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB01J6A6H74%26ascsubtag%3DUS-003-3321002-002-1441704-web-20" target="_blank" rel="nofollow">on <span class="vendor-name">Amazon</span></a>
						</div>
					</div>
					
				
				<div class="expanded-content" style="display:none">
					<p  class="expanded-desc">Amazon's over-the-air DVR nails the little details, but it has some major limitations.</p>
					
						
							<div class="product-pros">
								<h4>Pros</h4>
								<ul>
								
									<li>Easy to set up and use with Fire TV devices and Alexa</li>
								
									<li>Smooth video playback across all channels</li>
								
									<li>Low price for built-in storage with no subscription fees</li>
								
								</ul>
							</div>
						
						
							<div class="product-cons">
							<h4>Cons</h4>
								<ul>
								
									<li>Fire TV required to watch on televisions</li>
								
									<li>No ad-skipping features</li>
								
									<li>Out-of-home streaming only works on mobile devices</li>
								
								</ul>
							</div>
						
					
				</div>
				
				
			</li>
			
			
				
						
							
						
						
				
				
					
					
					
					
					
						
						
							
						
					
					
				
				<li class="aag-item multiple " data-product-id="1441705" >
					
						<div class="product-left">
						<i class="aag-toggle ss-icon ss-directright" title="View more details"></i>
						<span>
					
					
						
						
					
					<h3 class="product-name expandable" title="View More Details">
						
							
							Amazon Fire TV Recast (150-hour model)
						
					</h3>
					</span>
					
						
						
						
							
							<div class="rating"><span class="rating-star four-star"></span></div>
							
							
							
							
						
					</div>
										
					
					<div class="product-right">
						
						
						<div class="price-msrp">
							
							<a href="http://buy.geni.us/Proxy.ashx?TSID=14157&GR_URL=https%3A%2F%2Fwww.amazon.com%2FFire-Recast-over-air-hours%2Fdp%2FB074J1GPB8%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB074J1GPB8%26ascsubtag%3DUS-003-3321002-002-1441705-web-20" target="_blank" rel="nofollow" class="product-list-price trackLink" data-product-id="1441705" data-po="amazon" data-bkc="ConsumerElectronics" data-bkmfr="Amazon" data-bkvndr="Amazon" data-product-name="Amazon Fire TV Recast (150-hour model)" data-vars-product-id="1441705" data-vars-bkmfr="Amazon" data-vars-bkvndr="Amazon" data-vars-product-name="Amazon Fire TV Recast (150-hour model)" data-vars-outbound-link="https://www.amazon.com/Fire-Recast-over-air-hours/dp/B074J1GPB8?psc=1&SubscriptionId=AKIAIVYSMSQJCH4VBFJA&tag=techhivecom-20&linkCode=xm2&camp=2025&creative=165953&creativeASIN=B074J1GPB8" data-vars-link-position-id="002" data-vars-link-position="AAG Bottom">$279.99</a>	
							
													</div>
						<a href="http://buy.geni.us/Proxy.ashx?TSID=14157&GR_URL=https%3A%2F%2Fwww.amazon.com%2FFire-Recast-over-air-hours%2Fdp%2FB074J1GPB8%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB074J1GPB8%26ascsubtag%3DUS-003-3321002-002-1441705-web-20" target="_blank" rel="nofollow" class="btn-amazon trackLink" data-product-id="1441705" data-po="amazon" data-bkc="ConsumerElectronics" data-bkmfr="Amazon" data-bkvndr="Amazon" data-product-name="Amazon Fire TV Recast (150-hour model)"  data-vars-product-id="1441705" data-vars-bkmfr="Amazon" data-vars-bkvndr="Amazon" data-vars-product-name="Amazon Fire TV Recast (150-hour model)" data-vars-outbound-link="https://www.amazon.com/Fire-Recast-over-air-hours/dp/B074J1GPB8?psc=1&SubscriptionId=AKIAIVYSMSQJCH4VBFJA&tag=techhivecom-20&linkCode=xm2&camp=2025&creative=165953&creativeASIN=B074J1GPB8" data-vars-link-position-id="002" data-vars-link-position="AAG Bottom">See it</a>
						<div class="vendor">
							<a href="http://buy.geni.us/Proxy.ashx?TSID=14157&GR_URL=https%3A%2F%2Fwww.amazon.com%2FFire-Recast-over-air-hours%2Fdp%2FB074J1GPB8%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dtechhivecom-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB074J1GPB8%26ascsubtag%3DUS-003-3321002-002-1441705-web-20" target="_blank" rel="nofollow">on <span class="vendor-name">Amazon</span></a>
						</div>
					</div>
					
				
				<div class="expanded-content" style="display:none">
					<p  class="expanded-desc">Amazon's over-the-air DVR nails the little details, but it has some major limitations.</p>
					
						
							<div class="product-pros">
								<h4>Pros</h4>
								<ul>
								
									<li>Easy to setup and use with Fire TV devices and Alexa</li>
								
									<li>Smooth video playback across all channels</li>
								
									<li>Low price with no subscription fees</li>
								
								</ul>
							</div>
						
						
							<div class="product-cons">
							<h4>Cons</h4>
								<ul>
								
									<li>Fire TV required to watch on televisions</li>
								
									<li>No ad-skipping features</li>
								
									<li>Out-of-home streaming only works on mobile devices</li>
								
								</ul>
							</div>
						
					
				</div>
				
				
			</li>
			
		</ul>
	</div>







<script>
$("a[data-product-id]").on('click',function(e){
	var e = e || window.event;
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var prodName = $(this).attr("data-product-name");
	prodName = prodName.replace("\\'","'"); // to counter the effects of over-escaping
	
	if ( $(this).parents('.slideshow').length > 0 ) {
		var productLinkPosition = "Slideshow";
	} else if ( $(this).parents('.emo-sb').length > 0 ) {
		var productLinkPosition = "Product Sidebar";
	} else if ( $(this).parents('.at-a-glance.top').length > 0 ) {
		var productLinkPosition = "AAG Top";
	} else if ( $(this).parents('.at-a-glance').length > 0 ) {
		var productLinkPosition = "AAG Bottom";
	} else if ( $(this).parents('.quick-hits.medium').length > 0 ) {
		var productLinkPosition = "Quick Hit Medium";
	} else if ( $(this).parents('.quick-hits').length > 0 ) {
		var productLinkPosition = "Quick Hit Full";
	} else if ( $(this).parents('.product-chart').length > 0 ) {
		var productLinkPosition = "Product Chart";
	} else if ( $(this).parents('.emo-list').length > 0 ) {
		var productLinkPosition = "Product List";
	} else {
		var productLinkPosition = "Body Text";
	}
	
	dataLayer.push({
		'event': 'affiliateLink', 
	  	'eventCategory': 'Affiliate Link', // Hardcoded, not dynamic
	  	'eventAction': 'Click', // Hardcoded, not dynamic
	  	'eventLabel': ''+e.target+'', // The URL the affiliate link leads to
	  	'productVendor': $(this).attr("data-bkvndr"), // The vendor of the product
	  	'productManufacturer': $(this).attr("data-bkmfr"), // The manufacturer of the product
	  	'productName': prodName, // The name of the product
	  	'productId': $(this).attr("data-product-id"), // The ID of the product
	  	'productLinkPosition': productLinkPosition // location of product link (Product Sidebar, Product Chart, etc.)
	});
});
</script>


	<script>
$("#drr-container a:not('[data-product-id]')").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickParentsUntilDrr = $clickEl.parentsUntil("#drr-container");
	var clickText = $clickEl.text().trim();
	var linkLocation;
	var linkType;
	var regex = new RegExp("cio.com|csoonline.com|computerworld.com|itnews.com|itworld.com|infoworld.com|networkworld.com|javaworld.com|techconnect.com|techhive.com|macworld.com|pcworld.com|greenbot.com|gamestar.com", "i");
	
	if (clickParentsUntilDrr.hasClass("fakesidebar")) {
		linkLocation = "FSB";
	}
	else if (clickParentsUntilDrr.hasClass("end-note")) {
     	 linkLocation = "End Note";
   }
	else {
		linkLocation = "Body";
	}
	
	if (regex.test(clickUrl)) {
	      linkType = "Internal";
	    }
	else {
		linkType = "External";
	}
		
	
	dataLayer.push({
		'event': 'editBodyLink', 
	  	'eventCategory': 'Editorial Body Links',
	  	'eventAction': linkType,
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>


<script>
$("#drr-top-ad .related-promo-wrapper .title > a").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickText = $clickEl.text().trim();
	var linkLocation = "Promo";		
	
	dataLayer.push({
		'event': 'promoModuleLink', 
	  	'eventCategory': 'Promotion module',
	  	'eventAction': 'Click',
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>






    <div class="apart-alt tags">
    <span class="related">Related: </span>
    <ul>
		
			<li><a href="/category/streaming-hardware">Streaming Hardware</a></li>
		
			<li><a href="/category/home-theater">Home Theater</a></li>
		
			<li><a href="/category/consumer-electronics">Consumer Electronics</a></li>
		
			<li><a href="/category/plex-systems">Plex Systems</a></li>
		 
		
			
			
				 
					 
			    	
			    		<li><a href="/tag/dvr/" rel="nofollow">DVR</a></li>
			    	
			    		<li><a href="/tag/movies/" rel="nofollow">Movies</a></li>
			    				
				
			
				
		
    </ul>
   
	</div>









		
   		
		












		
	
	
	
	<div class="byline vcard author end-byline">	
		<div class="author-info" id="jarednewman">		
			
			
				<p>Jared writes for PCWorld and TechHive from his remote outpost in Cincinnati.</p>
					
		</div><!-- end .author-info -->	
		
		<div class="brand-social">
				<div class="follow-text">Follow</div>
				<ul class="social-links">
					<li>
						<a href="/author/Jared-Newman/">
							<i class="ss-icon ss-user"></i>
						</a>
					</li>
					
					<li>
						<a href="https://twitter.com/onejarednewman" class="twitter-follow" target="_blank">
							<i class="ss-icon ss-social ss-twitter"></i>
						</a>
					</li>
					
					
					<li>
						<a href="http://www.facebook.com/OneJaredNewman" class="facebook-follow" target="_blank">
							<i class="ss-icon ss-social ss-facebook"></i>
						</a>
					</li>
					
					
					<li>
						<a href="https://plus.google.com/113546787634633367622/posts" class="googleplus-follow" target="_blank">
							<i class="ss-icon ss-social ss-googleplus"></i>
						</a>
					</li>
					
					
				</ul>
			</div>
			
	</div>
	
	
		
		
		







	
	


















 




	
	
	
	
	
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	





<script src="/www/js/video/embedder-jwp.js?v=20181113114309"></script>


					










				
			
		
		</section><!-- /.bodee -->

		















		
			
				













<div id="content-recommender">
	<div class="OUTBRAIN" data-widget-id="AR_1" data-ob-template="TechHive_1"></div>  
	<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
</div>
			
				
		
	
		<div id="amazon-bottom-widget">
			<div class="amzn-custom-header">Shop Tech Products at Amazon</div>
			<div id="amazon-links" class="rr sector" original="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&storeId=httpwwwidgcsm-20&adInstanceId=78b1d44a-51eb-41a3-8f7b-1c26d7650c44">
				<code type="text/javascript"><!--
				           console.log('lazyloaded amazon widget links in footer');
				           //-->
				</code>
			</div>
		</div>
		<script>
		$(window).load(function() {
			consent.adsel.queue.push(function(){
				try {
					$("div#amazon-links").lazyLoadAd({
				          threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
				          forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
				          onLoad       : false,       // Callback function on call ad loading
				          onComplete   : false,       // Callback function when load is loaded
				          timeout      : 2000,        // Timeout ad load
				          debug        : false,       // For debug use : draw colors border depends on load status
				          xray         : false      // For debug use : display a complete page view with ad placements
				    });
				} catch (exception){
					console.log("ERROR loading amazon widget links " + exception);
				}
			});
		});
		</script>
	


		</article>

	</section><!-- /role=main -->

</div><!-- /#page-wrapper -->
		
		













<div id="panel-loader"></div>
<!-- IDGMPM-11812, category.getCategoryType() returns an integer, and 9 stands for tentpole-->
 



	
		










<link rel="stylesheet" href="/www.idgcsmb/css/tso-links.css?v=20181113114309" />

	<div id="tso-wrapper"><div id="tso" style="display:none"></div></div>
	<script type="text/javascript">
	function renderTSO(ads, requireHttps) {
		$thm.debug("renderTSO:"+ads.length);
		if (ads && ads.length > 0) {
			var selectedAds = selectTSOAds(ads,6);
			if (null != selectedAds && selectedAds.length > 0) {
				var html = "<h3>Today's Special Offers</h3>";
				html += "<ul>";
				for (var i=0; i<selectedAds.length;i++) {
					html += "<li>";
					html += "<a href='"+selectedAds[i].url+"'> "+selectedAds[i].title+"</a>";
					html += "<span>"+selectedAds[i].body+"</span>";
					if (null != selectedAds[i].pixel && selectedAds[i].pixel.length > 0 && selectedAds[i].pixel.indexOf('http') == 0) {
						if(!requireHttps || selectedAds[i].pixel.indexOf('https://') == 0){
							html += "<img src='"+selectedAds[i].pixel+"' style='height:0;width:0;'/>";
						}
					}
					html += "</li>";
				}
				html += "</ul>";
				$("#tso").html(html).show();
			}
		}
	}
	function selectTSOAds(ads,max) {
		if (ads.length <= max) {
			return ads;
		} else {
			var uniq = {};
			var found = 0;
			var selectedAds = [];
			while (found < max) {
				var ad = ads[Math.floor(Math.random()*ads.length)];
				if (uniq[ad.id] != null) {
					continue;
				} else {
					uniq[ad.id] = true;
					found++;
					selectedAds.push(ad);
				}
			}
			return selectedAds;
		}
		return null;
	}
	</script>
	

	




		










<link rel="stylesheet" href="/www.idgcsmb/css/footer.css?v=20181113114309" />
<link rel="stylesheet" href="/www.idgcsmb.th/css/footer.css?v=20181113114309" />
<div id="network"></div>

	












<footer id="footer" class="clearfix">
    <div class="container clearfix">
    	<div class="footer-col">
    		<a href="#" id="footer-logo" class="ir">TechHive</a>
    		<p>TechHive helps you find your tech sweet spot. We steer you to products you'll love and show you how to get the most out of them.</p>
    		<ul>
    			<li><a href="/about/about.html">About Us</a></li>
				<li><a href="/about/contact.html">Contact Us</a></li>
				<li><a href="/newsletters/signup.html">Newsletters</a></li>
				<li><a href="/about/member-preferences.html">Member Preferences</a></li>
				<li><a href="/about/cookie-policy.html">Cookie Policy</a></li>
				<li><a href="/index.rss">RSS</a></li>
			</ul>
			<ul class="right">
				
				<li><a href="/about/privacy.html" rel="nofollow">Privacy Policy</a></li>
				<li><a href="https://www.idg.com/terms-of-service-agreement/" rel="nofollow">Terms of Service Agreement</a></li>
				<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a></li>
				<li><a href="https://www.idg.com/about-adchoices-techhive/" rel="nofollow">Ad Choices</a></li>
				
				
			</ul>
    	</div>
    	<div class="footer-col">
    		<h2>TechHive Categories</h2>
    		<ul>
    			
				<li><a href="/category/connected-home/">Connected Home</a></li>
				<li><a href="/tag/cordcutting/">Cord Cutting</a></li>
				<li><a href="/category/home-audio/">Home Audio</a></li>
				<li><a href="/category/home-networking/">Home Networking</a></li>
				<li><a href="/category/home-security/">Home Security</a></li>
				<li><a href="/category/hubs-controllers/">Hubs &amp; Controllers</a></li>
			</ul>
			<ul class="right">
				
				<li><a href="/category/internet-of-things/">Internet of Things</a></li>
				<li><a href="/category/lighting/">Lighting</a></li>
				<li><a href="/category/smart-appliance/">Smart Appliances</a></li>
				<li><a href="/category/streaming-media/">Streaming Media</a></li>
				<li><a href="/category/thermostats/">Thermostats</a></li>
			</ul>



			<h3>IDG Network Sites</h3>
			<ul>
				<li><a href="http://resources.idg.com/contact/contact-idg" rel="nofollow">Advertise</a></li>
				<li><a href="https://www.idg.com/technetwork/technetwork-permissions-guildelines/" rel="nofollow">Permissions</a></li>
				<li><a href="http://www.macworld.com/" rel="nofollow">Macworld</a></li>
				<li><a href="http://www.pcworld.com/" rel="nofollow">PCWorld</a></li>
				<li><a href="http://www.techadvisor.co.uk/">Tech Advisor</a></li>
			</ul>
			<ul class="right">
				<li><a href="https://www.idg.com/technetwork/" rel="nofollow">IDG TechNetwork</a></li>
				<li><a href="https://www.idg.com/" rel="nofollow">IDG</a></li>
				<li><a href="http://blog.idg.com/" rel="nofollow">IDG Blog</a></li>
				<li><a href="https://www.idg.com/work-here/" rel="nofollow">Careers at IDG</a></li>
			</ul>
    	</div>
    	<div class="footer-col">
    		<div id="footer-social">
    			<span>Follow us</span> 
    			<a href="http://www.facebook.com/techhivemedia" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
					&#xF610;
				</a>
				<a href="https://twitter.com/TechHive" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
					&#xF611;
				</a>
				<a href="https://plus.google.com/+TechHiveUS/posts" class="network-google ss-icon ss-social-circle banner-social banner-google" alt="Google+" itemprop="sameAs" rel="publisher">
					&#xF613;
				</a>
				
    		</div>
    		
    		
		    <p>Visit other IDG sites:</p>
    		
    		<div id="idgInfo" class="styled-select">		
		            <select onchange="location = this.options[this.selectedIndex].value;" id="jumpMenu" name="jumpMenu" d30tagged="1" style="visibility: visible;">
		                <option value="">Select One</option>
						
							
						













	
		<option value="https://www.cio.com">CIO</option>
	
		<option value="https://www.cio-asia.com">CIO Asia</option>
	
		<option value="https://www.computerworld.com">Computerworld</option>
	
		<option value="https://www.csoonline.com">CSO</option>
	
		<option value="https://www.gamestar.com">Gamestar</option>
	
		<option value="https://www.greenbot.com">Greenbot</option>
	
		<option value="https://www.idgconnect.com">IDG Connect</option>
	
		<option value="https://www.idg.tv">IDG.tv</option>
	
		<option value="https://www.infoworld.com">InfoWorld</option>
	
		<option value="https://www.itnews.com">IT News</option>
	
		<option value="https://www.itworld.com">ITworld</option>
	
		<option value="https://www.javaworld.com">JavaWorld</option>
	
		<option value="https://www.macworld.com">Macworld</option>
	
		<option value="https://www.networkworld.com">Network World</option>
	
		<option value="https://www.pcworld.com">PCWorld</option>
	
		<option value="https://www.techhive.com">TechHive</option>
	
		<option value="https://www.thefullnerd.com/">The Full Nerd</option>
	

		            </select>
		    </div>
		    
		        <p><small><a href="http://idgcsmb.com/terms-of-service-agreement/">Copyright</a> &copy; 2018 IDG Communications, Inc.</small></p>
    	</div>
    </div>
</footer>
 


		
				
		
			
				
			




















	
		
		
		
		
			<div id="gpt-infunnel" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-infunnel", "true");
	    			$('#gpt-infunnel').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-infunnel [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
		
		
			
		












<script src="/www/js/analytics/mouse_down.js"></script> 



<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script> 

<script src="/www.idgcsmb/js/jquery/jquery-ui-tools.js"></script>


<script src="/www.idgcsmb/js/thm_post.js?v=20181113114309"></script>

<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.md5.js"></script>

	<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.colorbox-min.js"></script>


<script src="/www.idgcsmb/js/autocomplete.js"></script>









<script src="/www/js/jquery/jquery.lazyload.min.js"></script>
<script>
$(function() {
    $("img.lazy").lazyload({ 
    	effect : "fadeIn", 
    	threshold: 200,
    	failure_limit:25
    });
});
</script>

<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>















<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>

<script type="text/javascript">
// -- Load Lazy Advertisement placement as deferred
try {
	$("div.lazyload_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
	}) ;
}
catch (exception) {
	console.log("Error with lazyLoadAd: "+exception);
}
</script>

<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
<script>
$(document).ready(function() {
	$("table.tablesorter").tablesorter({
		widgets: ['zebra']
	});
	
	$("table.tablesorter tbody tr").hover(function() {
		$(this).toggleClass("selected");
	});
	
	$("table.tablesorter thead tr th").each(function(){			
		if ($(this).find('.ss-icon').length < 1) {
			$(this).append('<i class="ss-icon"></i>');
		}
	});
	
});
</script>

<script>
	//click event for BrandPost "Learn More" buttons
	$(".learn-more").click(function(event) {
		 var brandpost_txt = "<div class=\"about-brandposts\"><p>BrandPosts are written and edited by members of our sponsor community. BrandPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of BrandPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 if ($(".blog-byline.sponsored-post").length > 0) { //for Nativo sponsoredPosts
			 brandpost_txt = "<div class=\"about-brandposts\"><p>SponsoredPosts are written and edited by members of our sponsor community. SponsoredPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of SponsoredPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 }
		 $("body").append(brandpost_txt);
		 $(".about-brandposts").css("top",event.pageY);
		 if ($("body").width() >= 955) { // need different behavior at desktop breakpoint and above
			 //find difference between X position clicked and body width and set as right attr 
			 //this is so tooltip doesn't overflow window
			 var xpos = $("body").width() - event.pageX;
			 $(".about-brandposts").css({"right":xpos,"margin-right":"0"});
		 }
		 $(".about-brandposts .close-bar").click(function() {
			 $(".about-brandposts").remove();
			 return false;
		 });
		 return false;
	});
</script>





	<!-- LiveRamp Sources -->
	<script type="text/javascript"src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
	<script src="/www/js/utils/liveRamp.js"></script>
	<!-- End of LiveRamp -->


<script type='text/javascript'>

$('.at-a-glance.multiple.expanded .aag-toggle,.at-a-glance.multiple.expanded .product-name').click(function() {
	var $thisLI = $(this).closest('li');
	$thisLI.find('.aag-toggle').toggleClass('ss-directright').toggleClass('ss-dropdown');
	$thisLI.find('.expanded-content').toggle();
	return false;
});


	g_bRequireHttps = true;
	 
		$.ajax('/ads/tso',{
			dataType: 'json',
			success: function(data){
				renderTSO(data.tsoLinks, g_bRequireHttps);
			},
			error: function(jqXHR,error,thrown){
				$thm.debug("TSO AJAX Status: "+error+": "+thrown,true);
			}
		});
	
</script>

		
		<script type="text/javascript">
			a=top;f=self;
			var acceptedDomains = ["lookbookhq.com"];
			var cleanedHost = a.location.hostname.split(".").slice(-2).join(".");
			if(a!=f && acceptedDomains.indexOf(cleanedHost) < 0) {
				a.location=f.location;
			}
		</script>	

 		














	
	
	    
	    
		   	
		   	
		   	
	    
    	
    	
	    
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	





<!-- Begin BlueKai Tag-->
<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
<script type="text/javascript" src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<!-- CryptoJS -->
<script src="/www/js/utils/md5.js"></script>
<script type="text/javascript" src="/www/js/analytics/idg_bk_coreapi.js"></script>

<script type="text/javascript">
bk_allow_multiple_calls=true;
var blueKaiId=13981;
var blueKaiPort=10;
var brandCode = "th";
var regUrl="https://regdev.idge.int/api/"
var daysToRefresh=30;
var bk_debug_log=false;


regUrl="https://reg.idgenterprise.com/api/";



daysToRefresh=30;


	




//CMS-Specific
bk_addPageCtx("cmscatids", "[3941,3059,3799,4723]");



	bk_addPageCtx("goldenIds", "[416,398,1025,833]");


bk_addPageCtx("cmpy", "[]");

bk_addPageCtx('tid', '3');

	










try{
	consent.adsel.queue.push(function(){
		console.log('*****GDPR: running queue for bluekai ad selection');
		IDG.bkCoreApi.start();
	});
}
catch(e){
	//alert("Triggering catch")
	consent.adsel.queue.push(function(){
		bk_doJSTag(blueKaiId ,blueKaiPort);
	});
	if (window.console && window.console.log){
		window.console.log("Error Occured While Processing Profile Siubmission")
	}
}



//bk_doJSTag(13981, 10);











$('article, #slideshowCarousel').on('click', '.product-list-price, .btn-amazon, .productLink', function(e) {
	var $linkEl = $(e.target);
	var po = $linkEl.data('po');
	if ($.inArray(po, ['amazon', 'vendor', 'other']) >= 0) {
		if (po == 'amazon') {
			var prCat = $linkEl.data('bkc');
			if (typeof prCat != 'undefined') {
				bk_addPageCtx('event', 'AmazonClick'+prCat);
			}
			
			bk_addPageCtx('event', 'AmazonClickStreamingHardware');
			
			bk_addPageCtx('event', 'AmazonClickHomeTheater');
			
			bk_addPageCtx('event', 'AmazonClickConsumerElectronics');
			
			bk_addPageCtx('event', 'AmazonClickPlexSystems');
			
		}
		var prMfr = $linkEl.data('bkmfr');
		if (typeof prMfr != 'undefined') {
			bk_addPageCtx('event', 'eCommerceMFR'+prMfr);
		}
		var prVndr = $linkEl.data('bkvndr');
		if (typeof prVndr != 'undefined') {
			bk_addPageCtx('event', 'eCommerceClickVendor'+prVndr);
		}
		consent.adsel.queue.push(function(){
			bk_doJSTag(34202, 1);
		});
	}
});
</script>
<!-- End BlueKai Tag -->

 		
		











<script type="text/javascript">
$thm.logPlEvent({"b":"th","e":"view","t":"article","id":"3321002"});
</script>


	
	
		<div id="loginModal"></div>
		<div id="logoffModal"></div>
		<div id="abuseModal"></div>

		
			<!-- rev: 20181113114309  -->
		
		
		
		
			
				
			




















	
		
			<div id="gpt-skin" class=" ad-container"></div>
    			<script type="text/javascript">
    			consent.ads.queue.push(function(){
    				try {
	    				IDG.GPT.addDisplayedAd("gpt-skin", "true");
	    				IDG.GPT.displayGoogleTagSlot('gpt-skin');
	    			}
	    			catch (exception) {
	    				console.log("Error with IDG.GPT: " + exception);
	    			}
    			});
    			</script>
		
		
		
		
	
 
 
			
			
	</body>
</html>
