
<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="utf-8"/>
<title>Harman Kardon Invoke smart speaker review: Cortana could be a strong smart home system—someday | TechHive</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0"/>
<link rel="canonical" href="https://www.techhive.com/article/3234466/hubs-controllers/harman-kardon-invoke-review.html"/>
<meta name="description" content="The Invoke is a good speaker, and Microsoft’s digital assistant has potential, but it’s too immature for us to give it a strong recommendation today. "/>
<meta name="news_keywords" content="Harman Kardon,Amazon Echo,Google Home,Google Assistant,Alexa"/>
<meta itemprop="image" content="https://images.idgesg.net/images/article/2017/10/invoke-primary-100739584-medium.jpg">
<meta name="DC.date.issued" content="2017-10-20"/>
<meta name="date" content="2017-10-20"/>
<link rel="amphtml" href="https://www.techhive.com/article/3234466/hubs-controllers/harman-kardon-invoke-review.amp.html"/>
<script type="text/javascript" src="//fonts.staticworld.net/azu1qsr.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>
<meta property="twitter:account_id" content="499275959"/>
<meta property="fb:app_id" content="1566936830273000"/>
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.techhive.com/article/3234466/hubs-controllers/harman-kardon-invoke-review.html">
<meta property="og:site_name" content="TechHive">
<meta property="og:image" content="https://images.idgesg.net/images/article/2017/10/invoke-primary-100739584-large.3x2.jpg">
<meta property="og:image:width" content="700">
<meta property="og:image:height" content="467">
<meta property="og:title" content="Harman Kardon Invoke smart speaker review: Cortana could be a strong smart home system—someday">
<meta property="og:description" content="The Invoke is a good speaker, and Microsoft’s digital assistant has potential, but it’s too immature for us to give it a strong recommendation today. ">
<!-- Sailthru -->
<meta name="sailthru.tags" content="hubs-controllers,home-control,speakers,home-tech,music,alexa,googlehome,michael-brown,reviews,long"/>
<meta name="sailthru.image.thumb" content="https://images.idgesg.net/images/article/2017/10/invoke-primary-100739584-small.jpg"/>
<meta name="sailthru.image.full" content="https://images.idgesg.net/images/article/2017/10/invoke-primary-100739584-large.3x2.jpg"/>
<meta name="sailthru.title" content="Harman Kardon Invoke smart speaker review: Cortana could be a strong smart home system—someday"/>
<meta name="sailthru.description" content="The Invoke is a good speaker, and Microsoft’s digital assistant has potential, but it’s too immature for us to give it a strong recommendation today. "/>
<meta name="displaytype" content="article"/>
<meta name="associatedproducts" content="sonos one,google home,invoke"/>
<meta name="source" content="techhive"/>
<meta name="category" content="hubs and controllers,home control,speakers,home tech"/>
<meta name="storytype" content="reviews"/>
<meta name="tags" content="music,alexa,google home"/>
<meta name="google-site-verification" content="GHmsZtoU3FlVFNZp6NaQob2y1ZBU9WoIhanodiETb2o"/>
<meta name="msvalidate.01" content="05F49F041AAA61528A0A3329A6C0C02D"/>
<link rel="stylesheet" href="/www.idgcsmb/css/inline-header.css?v=20171019025105"/>
<link rel="stylesheet" href="/www.idgcsmb.th/css/inline-header.css?v=20171019025105"/>
<!-- this must be first -->
<link href="/www.idgcsmb/css/colorbox.css" rel="stylesheet"/>
<!-- <link href="/www.idgcsmb/css/equalizer.css" rel="stylesheet" /> -->
<link href="/www.idgcsmb/css/global-layout.css?v=20171019025105" rel="stylesheet"/>
<link href="/www.idgcsmb.th/css/global-layout.css?v=20171019025105" rel="stylesheet"/>
<link href="/www.idgcsmb/css/global-colors.css?v=20171019025105" rel="stylesheet"/>
<link href="/www.idgcsmb.th/css/global-colors.css?v=20171019025105" rel="stylesheet"/>
<link href="/www.idgcsmb/css/global-typography.css?v=20171019025105" rel="stylesheet"/>
<link href="/www.idgcsmb.th/css/global-typography.css?v=20171019025105" rel="stylesheet"/>
<link href="/www/css/article.css?v=20171019025105" rel="stylesheet"/>
<link href="/www.idgcsmb.th/css/article.css?v=20171019025105" rel="stylesheet"/>
<link href="/www.idgcsmb/css/video.player.css?v=20171019025105" rel="stylesheet" media="all"/>
<!-- this must be last -->
<link href="/www.idgcsmb/css/helpers.css" rel="stylesheet"/>
<script>try{performance.mark("mark_head_css_done_blocking");}catch(e){console.log("Error saving performance mark -- this function may not be supported in this browser");}</script>
<!--  fav and touch icons -->
<link rel="shortcut icon" href="/www.idgcsmb.th/favicon.ico"/>
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://csmb.staticworld.net/images/furniture/techhive/th-apple-touch-icon-precomposed-144.png"/>
<link rel="apple-touch-icon-precomposed" sizes="129x129" href="https://csmb.staticworld.net/images/furniture/techhive/th-apple-touch-icon-precomposed-129.png"/>
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://csmb.staticworld.net/images/furniture/techhive/th-apple-touch-icon-precomposed-114.png"/>
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://csmb.staticworld.net/images/furniture/techhive/th-apple-touch-icon-precomposed-72.png"/>
<link rel="apple-touch-icon" href="https://csmb.staticworld.net/images/furniture/techhive/th-apple-touch-icon-precomposed.png"/>
<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
<script src="/www/js/init_device.js"></script>
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20171019025105"></script>
<script type="text/javascript">if(adLayer==null||adLayer=='undefined'){var adLayer=[];}adLayer["itemType"]="article";</script>
<script src="/www/js/ads/narf_prebid.js?v=20171019025105"></script>
<!-- LiveRamp Sources -->
<script type="text/javascript" src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
<script src="/www/js/utils/liveRamp.js"></script>
<!-- End of LiveRamp -->
<script type="text/javascript">try{IDG.GPT.unitName="/8456/IDG.US_CSMB_TechHive.com";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.unitName=IDG.GPT.unitName+"/"+"home-tech_section";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}var global_ShowSuper=true;var global_ShowHero=false;var url=window.location.href;if(url.indexOf("?")>1){url=url.split('?')[0];}try{IDG.GPT.addTarget("URL",encodeURIComponent(url));}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("zone",'article/hubs-controllers');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("productId",'1439482');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("productId",'1439493');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("productId",'1436575');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("productId",'1439493');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("articleId",'3234466');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("type",'reviews');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("typeId",'3');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("manufacturer",'microsoft');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("templateType",'article-review');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categoryIds",[3937,3934,3018,3067]);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categorySlugs",['hubs-controllers','home-control','speakers','home-tech']);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{if(null!=IDG.GPT.getQsVal("env")){IDG.GPT.addTarget("env",IDG.GPT.getQsVal("env").replace(/\W/g,""));}}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("author",'Michael Brown');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("page_type",'');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("tagNames",'Music,Alexa,Google Home');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("insiderContent",'false');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}</script>
<script type="text/javascript" src="/www/js/ads/proximic.js"></script>
<script type="text/javascript">console.log("PROXIMIC RESPONSE: SITE-LEVEL");var currentUrl='https://www.techhive.com/article/3234466/hubs-controllers/harman-kardon-invoke-review.html';(function(u){var f="scr";var e=(u?("url="+u):"");document.write("<"+f+"ipt type='text/javascript' src='//t.zqtk.net/c.js?m=1&s=idg_js&"+e.replace(/\'/g,"")+"'></"+f+"ipt>");})((typeof(currentUrl)==="undefined")?"":currentUrl);</script>
<script type="text/javascript"></script>
<script src="/www.idgcsmb/js/thm_pre.js?v=20171019025105"></script>
<script type="text/javascript">$thm.useBusinessData=true;</script>
<script>var isMobile=(typeof IDG.DEVICE!=='undefined')?IDG.DEVICE.isMobile():false;try{IDG.GPT.addBiddingParams("yieldbotPsn",(isMobile?"ddcb":"c8f6"));IDG.GPT.addBiddingParams("appnexusPlacementId",(isMobile?"6451237":"6352813"));IDG.GPT.addBiddingParams("TriLiftPrefix","techhive_ros_");}catch(e){console.log("Error in adding bidding params: "+e);}</script>
<script type="text/javascript" src="/www/js/ads/prebid_gpt_launcher.js?v=20171019025105"></script>
<script type="text/javascript">g_arrModules=new Array();g_arrAds=new Array();</script>
<script type="text/javascript">var _sf_async_config={};_sf_async_config.uid=29363;_sf_async_config.useCanonical=true;_sf_async_config.authors="Michael Brown";_sf_async_config.sections="hubs-controllers";_sf_async_config.domain="techhive.com";</script>
<!-- <link href="/www.idgcsmb/webfonts/ss-social.css" rel="stylesheet" />
	<link href="/www.idgcsmb/webfonts/ss-standard.css" rel="stylesheet" />  -->
<!--[if lte IE 8]>  
		<link href="/www.idgcsmb/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->
<!-- Use Twitter Summary Card with Large Image for articles and videos; summary otherwise -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@TechHive">
<meta name="twitter:image" content="https://images.idgesg.net/images/article/2017/10/invoke-primary-100739584-orig.jpg"/>
<meta name="twitter:description" content="The Invoke is a good speaker, and Microsoft’s digital assistant has potential, but it’s too immature for us to give it a strong recommendation today. ">
<meta name="twitter:title" content="Harman Kardon Invoke smart speaker review: Cortana could be a strong smart home system—someday">
<meta name="twitter:url" content="www.techhive.com">
<meta name="parsely-title" content="Harman Kardon Invoke smart speaker review: Cortana could be a strong smart home system—someday"/>
<meta name="parsely-link" content="https://www.techhive.com/article/3234466/hubs-controllers/harman-kardon-invoke-review.html"/>
<meta name="parsely-type" content="NewsArticle"/>
<meta name="parsely-image-url" content="https://images.idgesg.net/images/article/2017/10/invoke-primary-100739584-large.jpg"/>
<meta name="parsely-pub-date" content="2017-10-20T13:00:00Z"/>
<meta name="parsely-section" content="Hubs and Controllers"/>
<meta name="parsely-author" content="Michael Brown"/>
<meta name="parsely-tags" content="Music,Alexa,Google Home,type: reviews,source: techhive,original"/>
<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "WebSite",
		"url": "https://www.techhive.com/ ",
		"potentialAction": {
		"@type": "SearchAction",
		"target": "https://www.techhive.com/search?query={search_term}",
		"query-input": "required name=search_term"
		}
	}
</script>
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
<script>dataLayer=[{'primaryCategory':'Hubs and Controllers','ga_enabled':'true','gaTrackingId':'UA-30870572-1','articleType':'Reviews','articleId':'3234466','articleDisplayId':'1','articleTitle':'Harman Kardon Invoke smart speaker review: Cortana could be a strong smart home system—someday','articleAuthor':'Michael Brown','datePublished':'Fri Oct 20 06:00:00 PDT 2017','isInsider':'false','blogName':'','parselyEnabled':'true','parselyDomain':'techhive.com','skimlinksId':'111346X1569484','sailthruCustomerId':'14e51635b425ee81f25f84e57f95fbff','geolocEnabled':'true'}];</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-NZGV5J" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-NZGV5J');</script>
<!-- End Google Tag Manager -->
<script>try{performance.mark("mark_head_js_done_blocking");}catch(e){console.log("Error saving performance mark -- this function may not be supported in this browser");}</script>
</head>
<body id="article3234466" class="article review techhive">
<div id="skinAdTarget"></div>
<div id="superadunit" class="hidden">
<div class="ad">
<div class="ad-header">
<div class="brand-logo"></div>
<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
</div>
<div id="gpt-superstitial" class=" ad-container"></div>
<script type="text/javascript">try{IDG.GPT.addDisplayedAd("gpt-superstitial","true");$('#gpt-superstitial').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: gpt-superstitial [971 1115]");}catch(exception){console.log("Error with IDG.GPT: "+exception);}</script>
</div><!-- / ad -->
</div><!-- / super -->
<div id="page-top">
<div class="page-top-inner" itemscope itemtype="http://schema.org/Organization">
<link itemprop="url" href="http://www.techhive.com">
<header id="banner">
<a id="mobile-offscreen-toggle" class="ss-standard ss-rows" href="javascript://"></a>
<div id="logo">
<a href="/" class="ir banner-logo" id="logoImage">Home</a>
</div>
<div id="mobile-search-toggle" class="ss-standard ss-search"></div>
</header>
<ul id="th-nav">
<li class="newsNav"><a href="/news/" id="newsNav">News</a></li>
<li class="reviewsNav"><a href="/reviews/" id="reviewsNav">Reviews</a></li>
<li class="videoNav"><a href="/video/" id="videoNav">Video</a></li>
<li class="th-category-nav"><a href="/category/connected-home/">Connected Home<span class="ss-navigatedown right"></span></a>
<ul class="th-sub-nav">
<li><a href="/category/smart-appliance/">Appliances</a></li>
<li><a href="/tag/gardengarage/">Garden &amp; Garage</a></li>
<li><a href="/category/health-fitness/">Health</a></li>
<li><a href="/category/home-control/">Home Control</a></li>
<li><a href="/category/home-networking/">Home Networking</a></li>
<li><a href="/category/home-security/">Home Security</a></li>
<li><a href="/category/hubs-controllers/">Hubs &amp; Controllers</a></li>
<li><a href="/category/internet-of-things/">Internet of Things</a></li>
<li><a href="/tag/kitchen/">Kitchen</a></li>
<li><a href="/category/lighting/">Lighting</a></li>
<li><a href="/category/security-cameras/">Security Cameras</a></li>
<li><a href="/category/thermostats/">Thermostats</a></li>
</ul><!-- /.th-sub-nav -->
</li><!-- /.th-category-nav -->
<li class="th-category-nav"><a href="/category/entertainment/">Entertainment<span class="ss-navigatedown right"></span></a>
<ul class="th-sub-nav">
<li><a href="/tag/cordcutting/">Cord Cutting</a></li>
<li><a href="/category/home-audio/">Home audio</a></li>
<li><a href="/category/smart-tv/">Smart TVs</a></li>
<li><a href="/category/streaming-hardware/">Streaming Hardware</a></li>
<li><a href="/category/streaming-media/">Streaming Media</a></li>
<li><a href="/category/streaming-services/">Streaming services</a></li>
</ul><!-- /.th-sub-nav -->
</li><!-- /.th-category-nav -->
<li class="th-category-nav"><a href="/resources/" id="resourcesNav">Resources</a>
</ul><!-- /.th-nav -->
<div id="th-social">
<a href="http://www.facebook.com/techhivemedia" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
&#xF610;
</a>
<a href="https://twitter.com/TechHive" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
&#xF611;
</a>
<a href="https://plus.google.com/+TechHiveUS/posts" class="network-google ss-icon ss-social-circle banner-social banner-google" alt="Google+" itemprop="sameAs" rel="publisher">
&#xF613;
</a>
</div><!-- /#th-social -->
<div id="th-search">
<form id="search-form" action="/search">
<input type="search" name="query" id="banner-search-term" class="inactive searchbox-input-class" value="">
<input type="submit" name="submit" id="banner-search-submit" value="search"/>
<a id="magGlassClick" class="ss-icon ss-standard" type="submit">&#x1F50E;</a>
</form>
</div>
<div id="saved-comparisons"></div>
</div>
</div>
<div id="section-nav">
<div class="container clearfix">
<ul class="fmenu">
<li>
<a href="/category/lighting/">Lighting</a>
</li>
<li>
<a href="/category/thermostats/">Thermostats</a>
</li>
<li>
<a href="/category/home-networking/">Home Networking</a>
</li>
<li>
<a href="/category/internet-of-things/">Internet of Things</a>
</li>
<li>
<a href="/category/health-fitness/">Health and Fitness</a>
</li>
<li>
<a href="/category/security/">Security</a>
</li>
<li>
<a href="/category/hubs-controllers/" class="active">Hubs and Controllers</a>
</li>
<li style="display:none">
<a href="/category/security-cameras/">Security Cameras</a>
</li>
</ul>
</div>
</div><!--/#section-nav-->
<!-- Events Header -->
<script>$(document).ready(function(){$('.searchbox-input-class').each(function(){$(this).change(function(){var qStr=$(this).val();if($(this).val().indexOf('@')!=-1){qStr=qStr.replace(/@/g,' ');$(this).val(qStr);}});});});</script>
<div id="page-wrapper" class="page-wrapper">
<section role="main">
<article itemscope itemtype="http://schema.org/Review">
<header class='cat'>
<nav class="breadcrumbs horiz">
<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
<li><a href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
<li><a href="/category/hubs-controllers/" itemprop="url"><span itemprop="title">Hubs and Controllers</span></a></li>
</ul>
</nav>
<div class="category"><a href="/reviews" itemprop="genre">Review</a></div>
<h1 itemprop="headline">Harman Kardon Invoke smart speaker review: Cortana could be a strong smart home system—someday</h1>
<script>try{performance.mark("mark_headline_rendered");}catch(e){console.log("Error saving performance mark -- this function may not be supported in this browser");}</script>
<section class="deck viewability">
<h3 itemprop="description">The Invoke is a good speaker, and Microsoft’s digital assistant has potential, but it’s too immature for us to give it a strong recommendation today. </h3>
</section>
<div class="cat-social">
<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">
<li class="sosh">
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3234466%2Fhubs-controllers%2Fharman-kardon-invoke-review.html" target="_blank" onclick="sharingTrack('Facebook-vert', 'fblike')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3234466%2Fhubs-controllers%2Fharman-kardon-invoke-review.html&via=TechHive&text=Harman+Kardon+Invoke+smart+speaker+review%3A+Cortana+could+be+a+strong+smart" target="_blank" onclick="sharingTrack('Twitter-vert', 'twshare')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3234466%2Fhubs-controllers%2Fharman-kardon-invoke-review.html" target="_blank" onclick="sharingTrack('GooglePlus-vert', 'googplus')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/gplus.svg"/>
</a>
</li>
<li class="sosh">
<a class="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?url=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3234466%2Fhubs-controllers%2Fharman-kardon-invoke-review.html&description=Harman+Kardon+Invoke+smart+speaker+review%3A+Cortana+could+be+a+strong+smart" target="_blank" onclick="sharingTrack('Pinterest-vert')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/pinterest.svg"/>
</a>
</li>
<li class="sosh">
<a href="http://reddit.com/submit?url=https%3A%2F%2Fwww.techhive.com%2Farticle%2F3234466%2Fhubs-controllers%2Fharman-kardon-invoke-review.html&title=Harman+Kardon+Invoke+smart+speaker+review%3A+Cortana+could+be+a+strong+smart" target="_blank" onclick="sharingTrack('Reddit-vert')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg"/>
</a>
</li>
<li class="sosh cat">
<a href="#email" id="email-icon">
<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg"/>
</a>
</li>
<li class="sosh hide cat print">
<a href="javascript:window.print();">
<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg"/>
</a>
</li>
</ul>
</div>
<script type="text/javascript">var isValidEmailAddress=isValidEmailAddress||function(emailAddress){var pattern=new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);return pattern.test(emailAddress);};function encodeQueryData(params){var ret=[];for(var paramKey in params){ret.push(encodeURIComponent(paramKey)+"="+encodeURIComponent(params[paramKey]));}return ret.join("&");}function bindEmailModal(){$('#emailModal').on("click",".close-btn",function(event){event.preventDefault();$('#emailModal').hide();$("#emailModal .eml-friend").show();$(".eml-friend-success").hide();$(".eml-friend-error").hide();$('#emailModal').fadeOut(200);$('#email-to').val('');$('#email-from').val('');$('#name').val('');$('#personalization').val('');$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");});$('#emailModal').on("submit","form",function(event){event.preventDefault();var $form=$(this);var action=$form.attr('action');var formData=$form.serialize();var emailFrom=$('#email-from').val();var emailTo=$('#email-to').val();var uresponse=$('#g-recaptcha-response').val();$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");if(isValidEmailAddress(emailFrom)&&isValidEmailAddress(emailTo)&&uresponse!=""){$.ajax(action,{type:'POST',data:formData,success:function(data,textStatus,xhr){$("#emailModal .eml-friend").hide();$(".eml-friend-success").fadeIn(800);},error:function(xhr,textStatus,errorThrown){$("#emailModal .eml-friend").hide();$(".eml-friend-error").fadeIn(800);}});}else{if(uresponse==""){$('#eml-friend-captcha-message').html("Please verify you're not a robot!");}if(!isValidEmailAddress(emailTo)){$('#eml-to-address-message').html("Please enter a valid email address.");}if(!isValidEmailAddress(emailFrom)){$('#eml-from-address-message').html("Please enter a valid email address.");}}});}$(document).ready(function(){$(document).on("click","#email-icon",function(event){event.preventDefault();bindEmailModal();sharingTrack('Email-vert');$('#emailModal').fadeIn(800);});});</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">
<form class="eml-friend" action="/eloquaemail/article?eloqua=false&id=3234466">
<input type="hidden" name="title" value="Harman Kardon Invoke smart speaker review: Cortana could be a strong smart home system—someday"/>
<input type="hidden" name="url" value="https://www.techhive.com/article/3234466/hubs-controllers/harman-kardon-invoke-review.html"/>
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Email a friend</h3>
<div class="input-row">
<div id="eml-to-address-message" class="error-msg"></div>
<h4 class="input-label">To</h4>
<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
<p class="addl-text">Use commas to separate multiple email addresses</p>
</div>
<hr/>
<div class="input-row">
<div id="eml-from-address-message" class="error-msg"></div>
<h4 class="input-label">From</h4>
<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
</div>
<div class="input-row">
<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
</div>
<div class="input-row">
<textarea name="message" placeholder="Check out this article I found on TechHive." id="personalization" tabindex="4"></textarea>
</div>
<hr/>
<div class="input-row">
<div id="eml-friend-captcha-message" class="error-msg"></div>
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
<div class="g-recaptcha" data-sitekey="6Lew1fwSAAAAANp38ScDcwtgHsGa7fj9ofV6OiAF"></div>
</div>
<hr/>
<div class="submit">
<input type="submit" value="Send" class="input-submit" tabindex="5">
<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
</div>
</form>
<div class="eml-ty eml-friend-success" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Thank you</h3>
<p class="msg-sent">Your message has been sent.</p>
</div>
<div class="eml-friend-error" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Sorry</h3>
<p class="msg-sent">There was an error emailing this page.</p>
</div>
</div>
</div>
<div class="cat byline vcard author with-image">
<div class="byline-wrapper">
<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
<a href="/author/Michael-Brown/" rel="author" title="Michael Brown"><img class="bylineImage  imgId100619069 " src="https://images.techhive.com/images/article/2015/10/mike_brown-2-100619069-byline.jpg" width="34" width="34" alt="Michael Brown" itemprop="image"/></a>
<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Michael-Brown/"><span itemprop="name">Michael Brown</span></a></span>
</p>
<p class="dateline">
Executive Editor,
<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">TechHive</span><meta itemprop="logo" content=""/></span> <span class="divider break">|</span>
<span class="pub-date" class='break-date' itemprop="datePublished" content="2017-10-20T06:00-0700">Oct 20, 2017 6:00 AM
PT
</span>
</p>
</div>
</div>
<div id="articleLeaderboardWrapper">
<div id="articleLeaderboardInner">
<div id="gpt-leaderboard" class=" ad-container"></div>
<script type="text/javascript">try{IDG.GPT.addDisplayedAd("gpt-leaderboard","true");$('#gpt-leaderboard').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: gpt-leaderboard [971 1115]");}catch(exception){console.log("Error with IDG.GPT: "+exception);}</script>
</div>
</div>
<div id="gpt-leaderboardmobile" class=" ad-container"></div>
<script type="text/javascript">try{IDG.GPT.addDisplayedAd("gpt-leaderboardmobile","true");$('#gpt-leaderboardmobile').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: gpt-leaderboardmobile [971 1115]");}catch(exception){console.log("Error with IDG.GPT: "+exception);}</script>
</header>
<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
<meta itemprop="representativeOfPage" content="1"/>
<meta itemprop="height" content="467"/>
<meta itemprop="width" content="700"/>
<img src="https://images.idgesg.net/images/article/2017/10/invoke-primary-100739584-large.jpg" alt="invoke primary" itemprop="contentUrl" itemprop="url" onload="try {performance.clearMarks('mark_primary_img_rendered'); performance.mark('mark_primary_img_rendered');}catch(e) {console.log('Error saving performance mark -- this function may not be supported in this browser');}"/>
<script>try{performance.clearMarks("mark_primary_img_rendered");performance.mark("mark_primary_img_rendered");}catch(e){console.log("Error saving performance mark -- this function may not be supported in this browser");}</script>
<figcaption>
<span class="credit" itemprop="copyrightHolder">
Harman Kardon
</span>
</figcaption>
</figure>
<section class="epo cat-narrow" id="drr-top-ad">
<!-- Related -->
<div class="related-promo-wrapper">
<div class="promo apart">
<div class="hed">More like this</div>
<ul class="">
<li class="clearfix with-image">
<a href="/article/3220987/consumer-electronics/microsofts-cortana-and-amazons-alexa-are-going-to-work-together.html"><img class="small.3x2Image  imgId100734070 " src="https://images.idgesg.net/images/article/2017/08/cortana-alexa-100734070-small.3x2.jpg" alt="cortana alexa" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3220987/consumer-electronics/microsofts-cortana-and-amazons-alexa-are-going-to-work-together.html">Microsoft&#039;s Cortana and Amazon&#039;s Alexa are going to work together</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3229105/hubs-controllers/amazon-echo-which-alexa-smart-speaker-is-right-for-you.html"><img class="small.3x2Image  imgId100737285 " src="https://images.idgesg.net/images/article/2017/09/echo-family-100737285-small.3x2.jpg" alt="echo family" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3229105/hubs-controllers/amazon-echo-which-alexa-smart-speaker-is-right-for-you.html">Amazon Echo, Echo Plus or Echo Spot: Which Alexa smart speaker is right for...</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3232398/hubs-controllers/google-home-mini-review.html"><img class="small.3x2Image  imgId100738683 " src="https://images.idgesg.net/images/article/2017/10/google-home-mini-primary-100738683-small.3x2.jpg" alt="google home mini primary" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3232398/hubs-controllers/google-home-mini-review.html">Google Home Mini review: It doesn’t outdo the Dot</a></div>
</div>
</li>
<li class="clearfix with-image">
<a class="play" href="/video/82315/google-home-mini-first-look"><i class="ss-play"></i></a>
<a href="/video/82315/google-home-mini-first-look"><img class="small.3x2Image  imgId100738049 " src="https://images.idgesg.net/images/article/2017/10/tms_004_settingup-100738049-small.3x2.jpg" alt="tms 004 settingup" itemprop="image"/></a>
<div class="item">
<div class="item-eyebrow">Video</div>
<div class="title"><a href="/video/82315/google-home-mini-first-look">Google Home Mini: First Look</a></div>
</div>
</li>
</ul>
</div>
</div>
<div class="ad top-ad">
<div id="gpt-showcase" class="adunit ad-container">
</div>
<script type="text/javascript">if($(window).width()>=930){IDG.GPT.addDisplayedAd("gpt-showcase","true");$('#gpt-showcase').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: gpt-showcase - [971 1115]");}</script>
</div>
</section>
<div class="at-a-glance single top" data-tracking-category="ecomm-aag-top">
<div class="product-list-header">At a Glance</div>
<ul class="aag-list">
<li class="aag-item single " data-product-id="1439493">
<div class="product-left">
<span itemscope itemtype="http://schema.org/Product" itemprop="itemReviewed">
<h3 class="product-name" itemprop="name">
Harman Kardon Invoke
</h3>
</span>
<div class="rating" itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"><span class="rating-star three-star"></span><meta itemprop="ratingValue" content="3.0"></div>
</div>
<div class="product-right">
<div class="price-msrp">
<a href="http://www.harmankardon.com/invoke.html" rel="nofollow" class="product-list-price trackLink" data-product-id="1439493" data-po="vendor" data-bkc="HomeTech" data-bkmfr="HarmanKardon" data-bkvndr="HarmanKardon">$199.00</a>
<span class="msrp">MSRP $199.00</span>
</div>
<a href="http://www.harmankardon.com/invoke.html" rel="nofollow" class="btn-amazon trackLink" data-product-id="1439493" data-po="vendor" data-bkc="HomeTech" data-bkmfr="HarmanKardon" data-bkvndr="HarmanKardon">View</a>
<div class="vendor">
<a href="http://www.harmankardon.com/invoke.html" rel="nofollow">on <span class="vendor-name">Harman Kardon</span></a>
</div>
</div>
</li>
</ul>
</div>
<section class="bodee">
<div class="ad placement">
<!--  Begin gpt-skin/inread -->
<div id="inread" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("inread","true");IDG.GPT.displayGoogleTagSlot('inread');</script>
<!--  End gpt-skin/inread -->
</div>
<div class="tocWrapper scaleArticleToc some-toc" data-tracking-category="In-article TOC">
<legend>Table of Contents <i class="ss-navigatedown"></i></legend>
<ul class="articleToc">
<li data-pagenum="1" data-tocnum="1"><a href="#toc-1" class="trackLink">How does smart home control work on the Invoke?</a></li>
<li data-pagenum="1" data-tocnum="2"><a href="#toc-2" class="trackLink">What’s it like using Skype on the Invoke?</a></li>
<li data-pagenum="1" data-tocnum="3"><a href="#toc-3" class="trackLink">How does the Invoke sound?</a></li>
<li data-pagenum="1" data-tocnum="4"><a href="#toc-4" class="trackLink">Are the Invoke—and Cortana—ready for their closeups?</a></li>
</ul>
<div class="toc-show-more">Show More <i class="ss-navigatedown"></i></div>
</div>
<script>var dataLayer=window.dataLayer=window.dataLayer||[];dataLayer.push({'event':'loadInArticleToc'});</script>
<script type="text/javascript">$(document).ready(function(){$('.articleBloxAd').filter(":visible").each(function(index,item){var id=$(item).attr('id');var divClass=$(item).attr('class');var adString=IDG.GPT.getLazyAdCode();$(item).replaceWith("<div id=\""+id+"\" class=\"lazyload_blox_ad "+divClass+"\">"+adString+"</div>");});try{$("div.lazyload_blox_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});}catch(exception){console.log("error loading lazyload_ad "+exception);}});</script>
<script>function gatherPerformanceMarks(){p=performance.getEntriesByType("mark");gtmEvent={'event':'gatherPerformanceMarks'};for(var i=0;i<p.length;i++){gtmEvent[p[i].name]=p[i].startTime;}var dataLayer=window.dataLayer=window.dataLayer||[];dataLayer.push(gtmEvent);}</script>
<script type="text/javascript">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</script>
<div id="drr-container" class='cat ' itemprop="reviewBody">
<p>Harman Kardon’s Invoke is a pretty good speaker, and Microsoft’s Cortana is a pretty good digital assistant. Put them together and you have a smart speaker that costs as much, but doesn’t sound as good—and isn’t as smart—as the brand-new Sonos One, powered by Amazon’s Alexa.</p><p>The Invoke’s cylindrical form factor looks slightly less like a peppermill than the original Echo, and its flared bottom make it less susceptible to falling over. You’ll find all kinds of Echo accessories designed to keep the Echo upright, or to protect it from damage if it gets toppled. Like Amazon’s Echo, the Invoke has a volume-control ring circling its top. But where the Echo has buttons, the Invoke has a touch-sensitive top surface.</p><aside class="product product-sb">
<h6 class="nav-title">Mentioned in this article</h6>
<div class="product-details">
<figure class="productFigure"><a href="https://www.techhive.com/article/3233141/speakers/sonos-one-review.html"><img src="https://images-na.ssl-images-amazon.com/images/I/518raulrjYL.jpg" border="0" data-productid="1439482"/></a><a class="product-name" href="https://www.techhive.com/article/3233141/speakers/sonos-one-review.html" data-productid="1439482">Sonos One</a></figure>
<div class="product-lines"><div class="product-line1"><div class="rating"> <a href="https://www.techhive.com/article/3233141/speakers/sonos-one-review.html"><span class="rating-star four-half-star"/></a></div><span class="product-brand"><a href="https://www.techhive.com/article/3233141/speakers/sonos-one-review.html">Read TechHive's review</a></span></div><div class="product-line2"><div class="price-msrp"><a class="product-list-price" href="https://www.amazon.com/Sonos-One-Controlled-Speaker-Amazon/dp/B074XN1LH3?psc=1&amp;SubscriptionId=AKIAIRZJHSP2SKQIWVZA&amp;tag=techhivecom-20&amp;linkCode=xm2&amp;camp=2025&amp;creative=165953&amp;creativeASIN=B074XN1LH3" rel="nofollow" data-po="amazon" data-product-id="1439482" data-bkc="HomeTech" data-bkmfr="Sonos" data-bkvndr="Amazon">$199.00</a><span class="msrp">MSRP $199.00</span></div><a class="btn-amazon" href="https://www.amazon.com/Sonos-One-Controlled-Speaker-Amazon/dp/B074XN1LH3?psc=1&amp;SubscriptionId=AKIAIRZJHSP2SKQIWVZA&amp;tag=techhivecom-20&amp;linkCode=xm2&amp;camp=2025&amp;creative=165953&amp;creativeASIN=B074XN1LH3" rel="nofollow" data-po="amazon" data-product-id="1439482" data-bkc="HomeTech" data-bkmfr="Sonos" data-bkvndr="Amazon">View</a></div><div class="product-line3 vendor"><a href="https://www.amazon.com/Sonos-One-Controlled-Speaker-Amazon/dp/B074XN1LH3?psc=1&amp;SubscriptionId=AKIAIRZJHSP2SKQIWVZA&amp;tag=techhivecom-20&amp;linkCode=xm2&amp;camp=2025&amp;creative=165953&amp;creativeASIN=B074XN1LH3" rel="nofollow">on <span class="vendor-name">Amazon</span></a></div></div></div>
</aside><p>With a quick tap, you can answer an incoming call or hang up on one (the Invoke supports Microsoft’s fee-based Skype VoIP service), cancel a timer or an alarm, or stop any music that’s playing. Touch the top when the Invoke isn’t doing anything else, and Cortana will spout random trivia. I heard the tale of how Mary Shelley came to write <em>Frankenstein</em> when I tried it. If you want to mute the Invoke’s microphone, you’ll need to push a button on the rear of its base.</p><aside id="fsb-2409" class="fakesidebar fakesidebar-auto"><a href="https://www.techhive.com/article/3206310/connected-home/best-smart-home-system.html">[ Further reading: The best smart home systems ]</a></aside><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2017/10/invoke-top-100739583-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2017/10/invoke-top-100739583-large.jpg" border="0" alt="invoke top" width="700" height="467" data-imageid="100739583"/></a> <small class="credit">Harman Kardon</small>
<figcaption>
<p>The very top of the Invoke is a touch-sensitive surface.</p>
</figcaption>
</figure><p>Cortana’s voice sounds much more natural than Alexa or Google Assistant, at least when she’s reading a script. She can sound just as robotic as those other digital assistants when she’s responding to more routine requests, such as, “hey Cortana, turn on the kitchen lights.” But where Alexa will respond with a simple “OK” when you assign her a task, Cortana will helpfully confirm your request: “Turning on the kitchen lights.” Google Assistant does something similar, and it’s very helpful when you’re activating something that’s not in your line of sight, such as the porch light. An abstract pattern of LEDs light up when Cortana hears the wake word, and you have the option of having the speaker make a sound, too.</p><h2 class="toc" id="toc-1">How does smart home control work on the Invoke?</h2><p>This story considers the Invoke’s place in the digital home. Our sister site <a href="http://www.techhive.com/cms/article/Our%20sister%20site%20PCWorld%20takes%20an%20in-depth%20look%20at%20the%20Invoke%20from%20a%20home-office%20perspective.">PCWorld examines it as a home-office tool</a>. The Invoke is a smart speaker, not a smart home controller. It connects to Wi-Fi and depends on connections to other devices to control subsystems such as lighting. I used the Invoke and Cortana to control a set of Philips Hue smart bulbs, which depend on a hub that’s hardwired to your router. That’s the way all smart speakers work today (Amazon’s new Echo Plus, $150, is an exception: It will have a bona-fide smart home controller inside it when it ships).</p><figure class="medium right"><a class="zoom" href="https://images.idgesg.net/images/article/2017/10/invoke-app-100739585-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2017/10/invoke-app-100739585-medium.jpg" border="0" alt="invoke app" width="300" height="533" data-imageid="100739585"/></a> <small class="credit">Microsoft</small>
<figcaption>
<p>This is the extent of Cortana’s smart-home connectivity for now.</p>
</figcaption>
</figure><p>I experienced mostly good results with the Invoke and the Philips Hue bulbs. Response times were slightly slower than with an Echo, and you currently can’t change the colors of color-changing lights (you can with both the Echo and the Google Home series). But you can assign each bulb a different name and control them individually by saying something like “Hey Cortana, turn on Kitchen One,” and then saying “Hey Cortana, turn on Kitchen Two” to control a second light in the same room. You can also assign multiple lights to a single room and control all of them at once with a command like, “hey Cortana, turn on the Kitchen.” Or if you want to control all your smart lights at once, you can say, “hey Cortana, turn on the lights.” What you <em>can’t</em> say is, “hey Cortana, turn on Kitchen and Bedroom” to control the lights in a two or rooms at once. If you don’t want to turn on every light, you’ll need to utter a separate command for each room. You can also dim lights to a defined percentage.</p><p>So as far as working with Philips Hue bulbs, the Invoke and Cortana are not <em>quite</em> as good as the competition; but if you don’t have color smart lights, you won’t care. The Invoke and Cortana are equally as good when it comes to using voice commands to make shopping and to-do lists, setting timers and alarms, and creating helpful reminders, like, “hey Cortana, remind me to take out the garbage at 7:00.”</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2017/10/invoke-volume-control-100739582-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2017/10/invoke-volume-control-100739582-large.jpg" border="0" alt="invoke volume control" width="700" height="466" data-imageid="100739582"/></a> <small class="credit">Harman Kardon</small>
<figcaption>
<p>A ring around the top of the Invoke serves as a volume control.</p>
</figcaption>
</figure><p>On the other hand, the list of compatible smart home systems and individual products this combo supports is pretty short: Samsung’s SmartThings, Nest, Wink, and Insteon. Those are big names to be sure, but if your smart home is based on products from Ecobee, LIFX, iDevices, Iris by Lowe’s, TP-Link, C by GE, Chamberlain, Vivint Smart Home, Wemo, Dish Network, or any of a long list of other products or service providers, then you’ll have to wait for Cortana to catch up. Heck, Cortana isn’t even compatible with IFTTT, the supremely popular tool for stitching together disparate smart products and services.</p><aside class="nativo-promo smartphone tablet desktop" id=""> </aside><h2 class="toc" id="toc-2">What’s it like using Skype on the Invoke?</h2><p>The Invoke supports Bluetooth, but it won’t operate as a Bluetooth speakerphone when paired with your mobile handset. It is unique among smart speakers, however, in its support for Skype, Microsoft’s VOiP telephone service. Skype calls aren’t free, but they’re not expensive. You’ll find the <a href="https://www.skype.com/en/features/call-phones-and-mobiles/" rel="nofollow">details on Microsoft’s website</a>.</p><p>Using the Invoke as a Skype speakerphone is easy enough, and the sound quality of the calls I made was good. The people at the other end of the call said the same—at least when I was within a couple of feet of the speaker. They complained it was bit echoey when I was six to eight feet away. You can even summon Cortana on a Skype call. She’ll respond, but the other person won’t hear her.</p><aside class="product product-sb">
<h6 class="nav-title">Mentioned in this article</h6>
<div class="product-details">
<figure class="productFigure"><a href="https://www.techhive.com/article/3137718/smart-appliance/google-home-review-google-puts-its-awesome-ai-on-a-nightstand-and-wins.html"><img src="https://images.techhive.com/images/article/2016/11/google_home_beauty-100693944-small.jpg" border="0" data-productid="1436575"/></a><a class="product-name" href="https://www.techhive.com/article/3137718/smart-appliance/google-home-review-google-puts-its-awesome-ai-on-a-nightstand-and-wins.html" data-productid="1436575">Google Home</a></figure>
<div class="product-lines"><div class="product-line1"><div class="rating"> <a href="https://www.techhive.com/article/3137718/smart-appliance/google-home-review-google-puts-its-awesome-ai-on-a-nightstand-and-wins.html"><span class="rating-star four-half-star"/></a></div><span class="product-brand"><a href="https://www.techhive.com/article/3137718/smart-appliance/google-home-review-google-puts-its-awesome-ai-on-a-nightstand-and-wins.html">Read TechHive's review</a></span></div><div class="product-line2"><div class="price-msrp"><span class="msrp">MSRP $129.00</span></div><a class="btn-amazon" href="https://store.google.com/product/google_home" rel="nofollow" data-po="other" data-product-id="1436575" data-bkc="HomeTech" data-bkmfr="Google" data-bkvndr="Google">Learn more</a></div><div class="product-line3 vendor">on <span class="vendor-name">Google</span></div></div></div>
</aside><p>Once you’ve given Cortana access to your contact list, you just need to say, “hey Cortana, call so-and-so.” Cortana will respond, “sure,” and repeat the contact name. If the contact has more than one number, Cortana will ask, “which number: mobile, other, or work?” Tell her which one to use and she’ll make the call. When all is said and done, I’m not sure how attractive this feature is in an era of cell-phone plans with unlimited minutes.</p><p>Google Home has the best phone-call support, although it’s good for outgoing calls only. Amazon Echo users can call people who have the Alexa app installed on their smartphone, and they can call other Echos with the Drop In feature. When such calls are made between Echo Shows, video is supported.</p><h2 class="toc" id="toc-3">How does the Invoke sound?</h2><p>The Invoke is outfitted with three woofers, three tweeters, and two passive radiators, so I was surprised when I did an A/B comparison to the two-way Sonos One—playing Natalie Merchant’s “Carnival,” from her <em>Tiger Lily </em>album, which I’d ripped from CD and encoded in FLAC—and heard much better bass response from the Sonos.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2017/10/invoke-cutaway-100739581-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2017/10/invoke-cutaway-100739581-large.jpg" border="0" alt="invoke cutaway" width="700" height="467" data-imageid="100739581"/></a> <small class="credit">Harman Kardon</small>
<figcaption>
<p>With two passive radiators and three woofers, you’d think the Invoke would deliver better bass response.</p>
</figcaption>
</figure><p>I did prefer the Invoke’s handling of higher frequencies: The guitar solo on that track crackled with much more energy on Harman’s speaker. But to my ears, music needs the solid foundation that bass lines provide, and I found the Invoke lacking on that score. The Invoke isn’t a bad speaker by any stretch of the imagination, it’s just that I’ve heard many that are better lately.</p><p>I complained in my Sonos One review that Amazon doesn’t provide any means of summoning tracks stored on a local network—it’s all about streaming from online services. It’s the same with Cortana and the Invoke, although you <em>can </em>make a direct connection to your Spotify Premium account from the Invoke.</p><aside class="product product-sb">
<h6 class="nav-title">Mentioned in this article</h6>
<div class="product-details">
<figure class="productFigure"><span><img src="https://images.idgesg.net/images/article/2017/10/invoke-primary-100739584-small.jpg" border="0" data-productid="1439493"/></span><span class="product-name" data-productid="1439493">Harman Kardon Invoke</span></figure>
<div class="product-lines"><div class="product-line1"><div class="rating"> <span class="rating-star three-star"/></div></div><div class="product-line2"><div class="price-msrp"><a class="product-list-price" href="http://www.harmankardon.com/invoke.html" rel="nofollow" data-po="vendor" data-product-id="1439493" data-bkc="HomeTech" data-bkmfr="HarmanKardon" data-bkvndr="HarmanKardon">$199.00</a><span class="msrp">MSRP $199.00</span></div><a class="btn-amazon" href="http://www.harmankardon.com/invoke.html" rel="nofollow" data-po="vendor" data-product-id="1439493" data-bkc="HomeTech" data-bkmfr="HarmanKardon" data-bkvndr="HarmanKardon">View</a></div><div class="product-line3 vendor"><a href="http://www.harmankardon.com/invoke.html" rel="nofollow">on <span class="vendor-name">Harman Kardon</span></a></div></div></div>
</aside><p>That’s a task Cortana will perform with a bit of flair. Ask her, “Hey Cortana, play Natalie Merchant on Spotify,” and she’ll reply, “I’m on it” or “you got it.” A second or two later, she’ll add, “and now, Natalie Merchant on Spotify.” You can also make more specific requests, although Cortana won’t always deliver what you expect. When I asked, “hey Cortana, play the new Robert Plant album on Spotify,” she responded by streaming Plant’s 2014 release <em>Lullaby and the Ceaseless Roar </em>instead of <em>Carry Fire</em>, which came out on October 13.</p><p>The documentation provided with the Invoke, however, makes no mention of multi-room audio configurations. And if the list of smart home devices and services it supports is short, the collection of music services it supports is even smaller: Direct Spotify support is a big plus, but the only other services available at launch are TuneIn and iHeartRadio. Microsoft says it’s working with Pandora and hopes to make it available soon.</p><h2 class="toc" id="toc-4">Are the Invoke—and Cortana—ready for their closeups?</h2><p>Based on Harman Kardon’s implementation in the Invoke, I’d say Cortana has the potential to be a great smart home platform. But it’s not even a contest today. Amazon’s Alexa is a juggernaut, racking up partnership after partnership with both established smart home brands and up-and-comers. Google, meanwhile, is working hard to bring its Google Assistant to parity with Alexa.</p><p>The world’s not going to end if you buy a $199 Invoke and it ends up an orphan in a year or two. It’s a pretty good speaker that will play music via Bluetooth, if nothing else. Building your smart home foundation around Cortana today, on the other hand, means placing a bet on that technology’s future—that it will be a long-term winner for Microsoft: Something closer to the Xbox, say, than a dead end like <a href="https://www.pcworld.com/article/3231965/windows-phone-os/windows-10-mobile-phones-are-dead.html">Windows Phone</a>, the <a href="https://www.pcworld.com/article/241065/microsoft_says_no_more_zunes_its_all_about_the_phone_now.html">Zune media player</a>, or—most recently—<a href="https://www.pcworld.com/article/3229973/internet/what-groove-users-need-to-do-now-that-microsoft-is-killing-groove-music-pass.html">Groove Music</a>. That’s not a bet I’d make just yet.</p>
<div class="end-note">
<!-- blx4 #2010 blox4.html  -->
<div id="" class="blx blxParticleendnote blxM2010  blox4_html  blxC24070">To comment on this article and other TechHive content, visit our <a href="https://www.facebook.com/techhivemedia/" target="_blank">Facebook</a> page or our <a href="https://twitter.com/techhive" target="_blank">Twitter</a> feed. </div>
</div>
</div>
<script>try{performance.mark("mark_article_body_rendered");}catch(e){console.log("Error saving performance mark -- this function may not be supported in this browser");}</script>
<div class="at-a-glance single expanded" data-tracking-category="ecomm-aag-expanded">
<div class="product-list-header">At a Glance</div>
<ul class="aag-list">
<li class="aag-item single " data-product-id="1439493">
<div class="product-left">
<span itemscope itemtype="http://schema.org/Product" itemprop="itemReviewed">
<h3 class="product-name expandable" itemprop="name" title="View More Details">
Harman Kardon Invoke
</h3>
</span>
<div class="rating" itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"><span class="rating-star three-star"></span><meta itemprop="ratingValue" content="3.0"></div>
</div>
<div class="product-right">
<div class="price-msrp">
<a href="http://www.harmankardon.com/invoke.html" rel="nofollow" class="product-list-price trackLink" data-product-id="1439493" data-po="vendor" data-bkc="HomeTech" data-bkmfr="HarmanKardon" data-bkvndr="HarmanKardon">$199.00</a>
<span class="msrp">MSRP $199.00</span>
</div>
<a href="http://www.harmankardon.com/invoke.html" rel="nofollow" class="btn-amazon trackLink" data-product-id="1439493" data-po="vendor" data-bkc="HomeTech" data-bkmfr="HarmanKardon" data-bkvndr="HarmanKardon">View</a>
<div class="vendor">
<a href="http://www.harmankardon.com/invoke.html" rel="nofollow">on <span class="vendor-name">Harman Kardon</span></a>
</div>
</div>
<div class="expanded-content">
<p itemprop="description" class="expanded-desc">The Invoke is a pretty good speaker, but it’s too early to bet that Cortana will come out on top against the digital assistants Amazon and Google are offering.</p>
<div class="product-pros">
<h4>Pros</h4>
<ul>
<li>Good sound </li>
<li>Cortana has real potential as a smart home platform</li>
<li>Strong hooks into Microsoft's productivity apps</li>
</ul>
</div>
<div class="product-cons">
<h4>Cons</h4>
<ul>
<li>Very limited third-party product support</li>
<li>No multi-room audio support</li>
<li>It’s too early to bet on Cortana as a smart home platform</li>
</ul>
</div>
</div>
</li>
</ul>
</div>
<div class="apart-alt tags">
<span class="related">Related: </span>
<ul>
<li><a href="/category/hubs-controllers">Hubs and Controllers</a></li>
<li><a href="/category/home-control">Home Control</a></li>
<li><a href="/category/speakers">Speakers</a></li>
<li><a href="/category/home-tech">Home Tech</a></li>
<li><a href="/tag/music/" rel="nofollow">Music</a></li>
<li><a href="/tag/alexa/" rel="nofollow">Alexa</a></li>
<li><a href="/tag/googlehome/" rel="nofollow">Google Home</a></li>
</ul>
</div>
<div class="byline vcard author end-byline">
<div class="author-info" id="michaelbrown">
<p>Michael covers the smart-home, home-entertainment, and home-networking beats, working in the smart home he built in 2007.</p>
</div><!-- end .author-info -->
<div class="brand-social">
<div class="follow-text">Follow</div>
<ul class="social-links">
<li>
<a href="/author/Michael-Brown/">
<i class="ss-icon ss-user"></i>
</a>
</li>
<li>
<a href="https://twitter.com/brownieshq" class="twitter-follow" target="_blank">
<i class="ss-icon ss-social ss-twitter"></i>
</a>
</li>
<li>
<a href="http://www.facebook.com/MichaelDJBrown" class="facebook-follow" target="_blank">
<i class="ss-icon ss-social ss-facebook"></i>
</a>
</li>
<li>
<a href="https://plus.google.com/u/1/100434458907553275649/posts/p/pub" class="googleplus-follow" target="_blank">
<i class="ss-icon ss-social ss-googleplus"></i>
</a>
</li>
</ul>
</div>
</div>
<script src="/www/js/video/embedder.js"></script>
</section><!-- /.bodee -->
<div id="content-recommender" class="nolinks norewrite">
<div class="head">You Might Like</div>
<div id="rcjsload_3c8242"></div>
</div>
<script type="text/javascript">(function(){function ad_block_test(e,o){if("undefined"!=typeof document.body){var t="0.1.2-dev",o=o?o:"sponsorText",n=document.createElement("DIV");n.id=o,n.style.position="absolute",n.style.left="-999px",n.appendChild(document.createTextNode("&nbsp;")),document.body.appendChild(n),setTimeout(function(){if(n){var o=0==n.clientHeight;try{}catch(d){console&&console.log&&console.log("ad-block-test error",d)}e(o,t),document.body.removeChild(n)}},175)}}ad_block_test(function(is_blocked){var widget_id=30199;if(is_blocked===true){widget_id=30274;}var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);var rcel=document.createElement("script");rcel.id='rc_'+Math.floor(Math.random()*1000);rcel.type='text/javascript';rcel.src="//trends.revcontent.com/serve.js.php?w="+widget_id+"&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth||document.documentElement.clientWidth)+"&referer="+referer+'&is_blocked='+is_blocked;rcel.async=true;var rcds=document.getElementById("rcjsload_3c8242");rcds.appendChild(rcel);});})();</script>
<div id="amazon-bottom-widget">
<div class="amzn-custom-header">Shop Tech Products at Amazon</div>
<script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&storeId=httpwwwidgcsm-20&adInstanceId=78b1d44a-51eb-41a3-8f7b-1c26d7650c44"></script>
</div>
</article>
</section><!-- /role=main -->
</div><!-- /#page-wrapper -->
<div id="panel-loader"></div>
<!-- IDGMPM-11812, category.getCategoryType() returns an integer, and 9 stands for tentpole-->
<div id="tso-wrapper"><div id="tso" style="display:none"></div></div>
<script type="text/javascript">function renderTSO(ads,requireHttps){$thm.debug("renderTSO:"+ads.length);if(ads&&ads.length>0){var selectedAds=selectTSOAds(ads,6);if(null!=selectedAds&&selectedAds.length>0){var html="<h3>Today's Special Offers</h3>";html+="<ul>";for(var i=0;i<selectedAds.length;i++){html+="<li>";html+="<a href='"+selectedAds[i].url+"' onclick='oClickTrack(\"Article Detail:Funnel:TSO\")'>"+selectedAds[i].title+"</a>";html+="<span>"+selectedAds[i].body+"</span>";if(null!=selectedAds[i].pixel&&selectedAds[i].pixel.length>0&&selectedAds[i].pixel.indexOf('http')==0){if(!requireHttps||selectedAds[i].pixel.indexOf('https://')==0){html+="<img src='"+selectedAds[i].pixel+"' style='height:0;width:0;'/>";}}html+="</li>";}html+="</ul>";$("#tso").html(html).show();}}}function selectTSOAds(ads,max){if(ads.length<=max){return ads;}else{var uniq={};var found=0;var selectedAds=[];while(found<max){var ad=ads[Math.floor(Math.random()*ads.length)];if(uniq[ad.id]!=null){continue;}else{uniq[ad.id]=true;found++;selectedAds.push(ad);}}return selectedAds;}return null;}</script>
<div id="network"></div>
<footer id="footer" class="clearfix">
<div class="container clearfix">
<div class="footer-col">
<a href="#" id="footer-logo" class="ir">TechHive</a>
<p>TechHive helps you find your tech sweet spot. We steer you to products you'll love and show you how to get the most out of them.</p>
<ul>
<li><a href="https://www.idg.com/technetwork/" rel="nofollow">About Us</a></li>
<li><a href="http://resources.idg.com/contact/contact-idg" rel="nofollow">Contact Us</a></li>
<li><a href="/premiumcontent/">Magazines, eBooks &amp; Apps</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
</ul>
<ul class="right">
<li><a href="/about/RSS.html">RSS</a></li>
<li><a href="https://www.idg.com/techhive-online-privacy-policy/" rel="nofollow">Privacy Policy</a></li>
<li><a href="https://www.idg.com/terms-of-service-agreement/" rel="nofollow">Terms of Service Agreement</a></li>
<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a></li>
<li><a href="https://www.idg.com/about-adchoices-techhive/" rel="nofollow">Ad Choices</a></li>
</ul>
</div>
<div class="footer-col">
<h2>TechHive Categories</h2>
<ul>
<li><a href="/category/connected-home/">Connected Home</a></li>
<li><a href="/tag/cordcutting/">Cord Cutting</a></li>
<li><a href="/category/home-audio/">Home Audio</a></li>
<li><a href="/category/home-networking/">Home Networking</a></li>
<li><a href="/category/home-security/">Home Security</a></li>
<li><a href="/category/hubs-controllers/">Hubs &amp; Controllers</a></li>
</ul>
<ul class="right">
<li><a href="/category/internet-of-things/">Internet of Things</a></li>
<li><a href="/category/lighting/">Lighting</a></li>
<li><a href="/category/smart-appliance/">Smart Appliances</a></li>
<li><a href="/category/streaming-media/">Streaming Media</a></li>
<li><a href="/category/thermostats/">Thermostats</a></li>
</ul>
<h3>IDG Network Sites</h3>
<ul>
<li><a href="http://resources.idg.com/contact/contact-idg" rel="nofollow">Advertise</a></li>
<li><a href="https://www.idg.com/technetwork/technetwork-permissions-guildelines/" rel="nofollow">Permissions</a></li>
<li><a href="http://www.macworld.com/" rel="nofollow">Macworld</a></li>
<li><a href="http://www.pcworld.com/" rel="nofollow">PCWorld</a></li>
<li><a href="http://www.techadvisor.co.uk/">Tech Advisor</a></li>
</ul>
<ul class="right">
<li><a href="https://www.idg.com/technetwork/" rel="nofollow">IDG TechNetwork</a></li>
<li><a href="https://www.idg.com/" rel="nofollow">IDG</a></li>
<li><a href="http://blog.idg.com/" rel="nofollow">IDG Blog</a></li>
<li><a href="https://www.idg.com/work-here/" rel="nofollow">Careers at IDG</a></li>
</ul>
</div>
<div class="footer-col">
<div id="footer-social">
<span>Follow us</span>
<a href="http://www.facebook.com/techhivemedia" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
&#xF610;
</a>
<a href="https://twitter.com/TechHive" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
&#xF611;
</a>
<a href="https://plus.google.com/+TechHiveUS/posts" class="network-google ss-icon ss-social-circle banner-social banner-google" alt="Google+" itemprop="sameAs" rel="publisher">
&#xF613;
</a>
</div>
<p>Visit other IDG sites:</p>
<div id="idgInfo" class="styled-select">
<select onchange="location = this.options[this.selectedIndex].value;" id="jumpMenu" name="jumpMenu" d30tagged="1" style="visibility: visible;">
<option value="">Select One</option>
<option value="https://www.cio.com">CIO</option>
<option value="https://www.computerworld.com">Computerworld</option>
<option value="https://www.csoonline.com">CSO</option>
<option value="https://www.gamestar.com">Gamestar</option>
<option value="https://www.greenbot.com">Greenbot</option>
<option value="https://www.idgconnect.com">IDG Connect</option>
<option value="https://www.idg.tv">IDG.tv</option>
<option value="https://www.infoworld.com">InfoWorld</option>
<option value="https://www.itnews.com">IT News</option>
<option value="https://www.itworld.com">ITworld</option>
<option value="https://www.javaworld.com">JavaWorld</option>
<option value="https://www.macworld.com">Macworld</option>
<option value="https://www.networkworld.com">Network World</option>
<option value="https://www.pcworld.com">PCWorld</option>
<option value="https://www.techhive.com">TechHive</option>
<option value="https://www.thestandard.com">The Industry Standard</option>
</select>
</div>
<p><small><a href="http://idgcsmb.com/terms-of-service-agreement/">Copyright</a> &copy; 2017 IDG Communications, Inc.</small></p>
</div>
</div>
</footer>
<div id="gpt-infunnel" class=" ad-container"></div>
<script type="text/javascript">try{IDG.GPT.addDisplayedAd("gpt-infunnel","true");$('#gpt-infunnel').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: gpt-infunnel [971 1115]");}catch(exception){console.log("Error with IDG.GPT: "+exception);}</script>
<script src="/www/js/analytics/mouse_down.js"></script>
<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
<script src="/www.idgcsmb/js/jquery/jquery-ui-tools.js"></script>
<script src="/www.idgcsmb/js/thm_post.js?v=20171019025105"></script>
<script src="/www/js/product-toc.js?v=20171019025105"></script>
<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.md5.js"></script>
<script src="/www/js/carousel-extend.js"></script>
<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.colorbox-min.js"></script>
<script src="/www.idgcsmb/js/autocomplete.js"></script>
<script src="/www/js/jquery/jquery.lazyload.min.js"></script>
<script>$(function(){$("img.lazy").lazyload({effect:"fadeIn",threshold:200,failure_limit:25});});</script>
<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>
<script type="text/javascript">$(document).ready(function(){$('.articleBloxAd').filter(":visible").each(function(index,item){var id=$(item).attr('id');var divClass=$(item).attr('class');var adString=IDG.GPT.getLazyAdCode();$(item).replaceWith("<div id=\""+id+"\" class=\"lazyload_blox_ad "+divClass+"\">"+adString+"</div>");});try{$("div.lazyload_blox_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});}catch(exception){console.log("error loading lazyload_ad "+exception);}});</script>
<script type="text/javascript">try{$("div.lazyload_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});}catch(exception){console.log("Error with lazyLoadAd: "+exception);}</script>
<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
<script>$(document).ready(function(){$("table.tablesorter").tablesorter({widgets:['zebra']});$("table.tablesorter tbody tr").hover(function(){$(this).toggleClass("selected");});$("table.tablesorter thead tr th").each(function(){if($(this).find('.ss-icon').length<1){$(this).append('<i class="ss-icon"></i>');}});});</script>
<script>$(".learn-more").click(function(event){var brandpost_txt="<div class=\"about-brandposts\"><p>BrandPosts are written and edited by members of our sponsor community. BrandPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of BrandPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";if($(".blog-byline.sponsored-post").length>0){brandpost_txt="<div class=\"about-brandposts\"><p>SponsoredPosts are written and edited by members of our sponsor community. SponsoredPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of SponsoredPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";}$("body").append(brandpost_txt);$(".about-brandposts").css("top",event.pageY);if($("body").width()>=955){var xpos=$("body").width()-event.pageX;$(".about-brandposts").css({"right":xpos,"margin-right":"0"});}$(".about-brandposts .close-bar").click(function(){$(".about-brandposts").remove();return false;});return false;});</script>
<script type='text/javascript'>g_arrModules['Article Detail:Top:Breadcrumb']=true;g_arrModules['Article Detail:Social Sharing Vertical']=true;$(document).ready(function(){var tocTopper=10;if($('body').hasClass('macworld')||$('body').hasClass('pcworld')||$('body').hasClass('techhive')){tocTopper=0;}$(window).resize(function(){var scaleTocFixBegin=$("#drr-container.cat").offset().top-tocTopper;var scaleTocFixEnd=$(".bodee").offset().top+$(".bodee").height();var scaleTocStartOffsetTop=5;doProductToc(true,false,scaleTocFixBegin,scaleTocFixEnd,scaleTocStartOffsetTop);}).resize();});g_arrModules['']=true;g_arrModules['Article Detail:Funnel:TSO']=true;g_bRequireHttps=true;$.ajax('/ads/tso',{dataType:'json',success:function(data){renderTSO(data.tsoLinks,g_bRequireHttps);},error:function(jqXHR,error,thrown){$thm.debug("TSO AJAX Status: "+error+": "+thrown,true);}});</script>
<script type="text/javascript">a=top;f=self;if(a!=f){a.location=f.location;}</script>
<!-- Begin BlueKai Tag-->
<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
<script type="text/javascript" src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<!-- CryptoJS -->
<script src="/www/js/utils/md5.js"></script>
<script type="text/javascript" src="/www/js/analytics/idg_bk_coreapi.js"></script>
<script type="text/javascript">bk_allow_multiple_calls=true;var blueKaiId=13981;var blueKaiPort=10;var brandCode="th";var regUrl="https://regdev.idge.int/api/"
var daysToRefresh=30;var bk_debug_log=false;regUrl="https://reg.idgenterprise.com/api/";daysToRefresh=30;if(typeof(s)!=='undefined'){bk_addPageCtx("p2",(typeof(s.prop2)!='undefined')?s.prop2:'');bk_addPageCtx("p9",(typeof(s.prop9)!='undefined')?s.prop9:'');bk_addPageCtx("p18",(typeof(s.prop18)!='undefined')?s.prop18:'');bk_addPageCtx("p54",(typeof(s.prop54)!='undefined')?s.prop54:'');bk_addPageCtx("p56",(typeof(s.prop56)!='undefined')?s.prop56:'');bk_addPageCtx("p59",(typeof(s.prop59)!='undefined')?s.prop59:'');bk_addPageCtx("p60",(typeof(s.prop60)!='undefined')?s.prop60:'');}bk_addPageCtx("cmscatids","[3937,3934,3018,3067]");bk_addPageCtx("cmpy","[]");bk_addPageCtx('tid','3');try{IDG.bkCoreApi.start();}catch(e){bk_doJSTag(blueKaiId,blueKaiPort);if(window.console&&window.console.log){window.console.log("Error Occured While Processing Profile Siubmission")}}$('article, #slideshowCarousel').on('click','.product-list-price, .btn-amazon, .productLink',function(e){var $linkEl=$(e.target);var po=$linkEl.data('po');if($.inArray(po,['amazon','vendor','other'])>=0){if(po=='amazon'){var prCat=$linkEl.data('bkc');if(typeof prCat!='undefined'){bk_addPageCtx('event','AmazonClick'+prCat);}bk_addPageCtx('event','AmazonClickHubsandControllers');bk_addPageCtx('event','AmazonClickHomeControl');bk_addPageCtx('event','AmazonClickSpeakers');bk_addPageCtx('event','AmazonClickHomeTech');}var prMfr=$linkEl.data('bkmfr');if(typeof prMfr!='undefined'){bk_addPageCtx('event','eCommerceMFR'+prMfr);}var prVndr=$linkEl.data('bkvndr');if(typeof prVndr!='undefined'){bk_addPageCtx('event','eCommerceClickVendor'+prVndr);}bk_doJSTag(34202,1);}});</script>
<!-- End BlueKai Tag -->
<script type="text/javascript">$thm.logPlEvent({"b":"th","e":"view","t":"article","id":"3234466"});</script>
<script type="text/javascript">$(document).ready(function(){$('a.pinterest-pinit').click(function(e){socialTrack('Article','Pinterest','share');});$('li.redditShare').click(function(e){socialTrack('Article','Reddit','share');});$('a.shoppingExit').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event4";s.prop26='Merchant Exit';s.linkTrackVars="eVar30,prop26,prop54,events";s.tl(true,'o','Merchant Exit Link');});$('a.bingexit').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event6";s.prop35="text ad exit";s.linkTrackVars="eVar35,prop35,events";s.tl(true,'o','Text Ad Exit');});$('a.itclick').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event5";s.prop36="itunes exit";s.linkTrackVars="eVar36,prop36,events";s.tl(true,'o','iTunes Exit');});$('a.signinclick').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event32";s.prop19="Internal Login";s.linkTrackVars="prop19,events";s.tl(true,'o','Login');});$('a.regclick').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event7,event18,prop20,prop22";s.prop20="new registered user";s.prop22="Internal Reg";s.linkTrackVars="events";s.tl(true,'o','Register');});$('.banner-tw').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event37";s.prop49="twitter follow";s.linkTrackVars="prop49,events";s.tl(true,'o','Social Media Follow');});$('.banner-fb').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event37";s.prop49="facebook follow";s.linkTrackVars="prop49,events";s.tl(true,'o','Social Media Follow');});$('a.item-link-container').click(function(e){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event45";s.prop16=$(this).attr("href");s.evar45=s.prop16;s.linkTrackVars="eVar32,prop16,events";s.tl(true,'o','Outbrain Click');});if(typeof(FB)!='undefined'){FB.Event.subscribe('edge.create',function(response){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event36";s.prop48="facebook share";s.linkTrackVars="prop48,events";s.tl(true,'o','Social Media share');});}if(typeof(digMag)!='undefined'){if(typeof(digLogin)!='undefined'){DigAnalytics.logSignIn(digLogin);}}});var Analytics=new Object();Analytics.logArticleComment=function(){s=s_gi(g_sOmnitureReportSuite);s.linkTrackVars="prop25,eVar25,events";s.linkTrackEvents="event19";s.events="event19";s.prop25='Article Comment';s.tl(this,'o','Article Comments');};Analytics.logSocialSignin=function(provider){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event32";s.prop19=provider;s.linkTrackVars="prop19,events";s.tl(true,'o',provider);};Analytics.logInternalSignin=function(){s=s_gi(g_sOmnitureReportSuite);s.linkTrackEvents=s.events="event32";s.prop19="Internal Login";s.linkTrackVars="prop19,events";s.tl(true,'o','Login');};function sharingTrack(type,pixelLogString){s=s_gi(g_sOmnitureReportSuite);s.eVar16="Sharing on: "+type;s.linkTrackEvents=s.events="event37";s.prop49="social media sharing";s.linkTrackVars="prop49,eVar16,events";s.tl(true,'o','Social Media Sharing');if(typeof IDG.Eloqua!="undefined"){IDG.Eloqua.invoke_flash("social-"+type);}if(pixelLogString!==undefined){$thm.logPlEvent({"b":"th","e":pixelLogString,"t":"article","id":"3234466"});}}function oClickTrack(key){if(typeof(key)!='undefined'&&key.length>0){s=s_gi(g_sOmnitureReportSuite);s.linkTrackVars="eVar42,events";s.events="event49";s.linkTrackEvents="event49";s.eVar42=key;s.tl(true,'o','module click');}};</script>
<!-- SiteCatalyst code version: H.25.
Copyright 1996-2012 Adobe, Inc. All Rights Reserved
More info available at http://www.omniture.com -->
<script language="JavaScript" type="text/javascript" src="/www.idgcsmb.th/js/analytics/omniture/pcwmw-techhive/s_code.js"></script>
<script language="JavaScript" type="text/javascript" id="omniVars">g_sOmnitureReportSuite="pcwmw-techhive";s.pageName="TechHive:article:reviews:Hubs and Controllers:3234466:Harman Kardon Invoke smart speaker review: Cortana could be a strong smart home system—someday";s.pageType="";if(typeof omnitureChannel!='undefined'){s.channel=omnitureChannel;}s.prop1="source:techhive";s.eVar1="D=c1";s.prop2="content type:reviews";s.eVar2="D=c2";s.prop3="display type:article:reviews";s.eVar3="D=c3";s.prop4="0 days";s.eVar4="D=c4";s.prop6="";s.prop7="";s.eVar7="D=c7";s.prop9="category:hubs and controllers";s.eVar9="D=c9";s.prop11="published:20-Oct-17";s.eVar11="D=c11";s.prop12="aid:3234466";s.eVar12="D=c12";s.prop13="";s.eVar13="D=c13";s.prop14="author:michael brown";s.eVar14="D=c14";s.prop15="page number:1";s.eVar15="D=c15";s.prop17="uri:/article/3234466/hubs-controllers/harman-kardon-invoke-review.html";s.eVar17="D=c17";s.prop18="brand:harman kardon";s.eVar18="D=c18";s.prop24=getLoginStatusForOmniture();s.eVar24="D=c24";s.prop28=getTrackingToken('tk')?"tokens:"+getTrackingToken('tk'):"";s.eVar28="D=c28";s.prop61="";s.eVar10="D=c61";s.prop37="rpn:th:reviews:techhive:article:reviews:hubs and controllers:3234466:harman kardon invoke smart speaker review: cortana could be a strong smart home system—someday";s.eVar37="D=c37";s.prop53="3937";s.eVar53="D=c53";s.prop54="hubs and controllers,home control,speakers,home tech";s.eVar30="D=c54";s.eVar33=s.prop55="3937,3934,3018,3067";s.eVar33="D=c55";s.prop39="";s.eVar39="D=c39";s.prop56="music,alexa,google home";s.eVar40="D=c56";try{s.prop41=IDG.GPT.getDisplayedAds(',')+','+IDG.GPT.getOtherAds(',');}catch(exception){console.log("Error with IDG.GPT "+exception);}sModules='';for(var i in g_arrModules){if(g_arrModules[i]&&i!=''){sModules+=i+',';}}sModules=sModules.replace(/,$/,'');s.prop42=sModules;s.eVar42="D=c42";s.list3=s.prop42+","+s.eVar42;s.events="";for(var p in s){if(s[p]&&p.match(/^(prop|ceVar)\d+$/)){s[p]=s[p].toLowerCase();}}s.campaign=s.getQueryParam('cid');s.useForcedLinkTracking=false;var s_code=s.t();if(s_code)document.write(s_code)</script>
<script language="JavaScript" type="text/javascript">if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')</script><noscript><img src="http://pcworldcommunication.d2.sc.omtrdc.net/b/ss/pcwmw-techhive/1/H.25--NS/0" height="1" width="1" border="0" alt=""/></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.25. -->
<!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
<span id="parsely-cfg" data-parsely-site="techhive.com"></span>
</div>
<script>(function(s,p,d){var h=d.location.protocol,i=p+"-"+s,e=d.getElementById(i),r=d.getElementById(p+"-root"),u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net":"static."+p+".com";if(e)return;e=d.createElement(s);e.id=i;e.async=true;e.src=h+"//"+u+"/p.js";r.appendChild(e);})("script","parsely",document);</script>
<!-- END Parse.ly Include: Standard -->
<div id="loginModal"></div>
<div id="logoffModal"></div>
<div id="abuseModal"></div>
<!-- rev: 20171019025105  -->
<div id="gpt-skin" class=" ad-container"></div>
<script type="text/javascript">try{IDG.GPT.addDisplayedAd("gpt-skin","true");IDG.GPT.displayGoogleTagSlot('gpt-skin');}catch(exception){console.log("Error with IDG.GPT: "+exception);}</script>
</body>
</html>
