Diving Headfirst into Windows Beta 7

Well, I did it. I made the move. Got off the fence. Took the plunge. Or, as my English language-challenged friend at State Bank of Mauritius would put it, I "did the necessary."

After thoroughly backing up my Vista x64 production laptop -- including redundant, manual copies of my data files, plus a full system image via Complete PC Backup -- I paved over the disk and installed the official Windows 7 Beta (64-bit edition).

[ For more help sorting through the early Win 7 benchmarks, check out InfoWorld's special report. ]

I've actually been sitting on the beta bits since before the Christmas break. However, I didn't want to commit totally until I could snag a working Product ID code or two from the Microsoft servers. Now, with my fully configured and activated Windows 7 environment in place, it's time to survey the landscape...and start complaining.

For starters, when will Microsoft get its act together and deliver ISO image-mounting support in Windows? It seems like anytime the OS is updated (we early Vista users were in this same boat three years ago), all of the best third-party mounting tools get broken.

Daemon Tools? Won't even install.

Virtual Clone Drive? Buggy and unstable (check their forums).

Fortunately, I was able to use VCD just long enough to get my major work titles (SQL Server 2008, Visual Studio 2008, Office 2007, and their respective service packs) installed from my MSDN ISO images. However, after the umpteenth random lock-up, I finally pulled Slysoft's normally well-behaved mounting utility from the system. I may give Alcohol 52% a try, but at this point I'm not optimistic.

And, frankly, I shouldn't have to be. This is the kind of base-level functionality that's supposed to be baked into the OS. Microsoft did it with VHD images. It can do it with ISO images as well. Heaven knows these folks distribute enough software in this format. MSDN and TechNet users pay good money for this stuff. The least Microsoft can do is provide a simple mechanism for mounting the images at runtime.

Note to Microsoft: Put a couple of those supersmart engineers on this, pronto! And while you're at it, have them back-port the solution to Vista and XP. Think of it as a kind of penance for putting us all through this same ISO-mounting hell again.

Also, what's the deal with Skype? Version 3.8 is still completely hosed under Windows 7. It won't connect to the peer-to-peer network and crashes mere seconds after loading. I'm now forced to use the butt-ugly Skype 4 beta. Truly a painful experience!

Finally, who screwed up Internet Explorer's networking? If I have more than one NIC enabled on the system (for example, one of the VMware Workstation virtual adapters or even Microsoft's own Loopback driver), IE takes forever to load. And once it is loaded, opening new tabs is painfully slow. If I then disable the extra adapters (so only my one primary wireless connection remains), the problem disappears. So, it's clearly related to those multiple NIC drivers.

Other nits:

  • Chrome (both 1.x and the newer 2.x pre-beta) didn't work at first under the x64-bit edition. I had to add the "—in-process-plugins" parameter to get it to load properly. Given my issues with IE, mentioned above, the inability to run Chrome properly was nearly a deal-breaker for me. Bullet dodged.
  • The Intel 5300-series Wi-Fi connection on my Dell Precision M6400 test bed refused to wake up after a suspend/resume cycle. I had to disable power management for the device in order to regain my sanity. Of course, this means the system's battery life takes a hit, but it's better than having my laptop go "deaf" every time I put it to sleep.
  • My tray icons keep disappearing! No matter how many times I tell Windows to leave them visible, it inevitably starts hiding one or more of them for no apparent reason. I've had to resort to disabling the notification icon hide function altogether and leaving them all visible, all the time. Very annoying.
  • Those snazzy new Task Bar thumbnails don't always show the updated window contents. For example, when I check to see the status of a download in Free Download Manager, I often find that what the thumbnail shows and what's really in the status window (time remaining, bytes downloaded, etc.) are entirely different.
  • What's with the hide-and-seek game for legacy features? The Add Hardware Wizard, which I use to install the aforementioned Loopback adapter, is now missing from Device Manager. You have to launch it from the Start Menu search box (filename is hdwwiz.exe). Also, the graphic equalizer in Windows Media Player is now buried in an unmarked, drop-down menu button thingy in the Now Playing view. Had to hit up Google to figure that one out.

On the plus side, Windows 7 definitely feels crisper than Vista. The UI is highly responsive, though I wonder how much of this is just smoke and mirrors (e.g., the Windows animation speed for minimizing/maximizing seems to be set higher under Windows 7) since benchmarks show that the system is actually performing about the same. Regardless, it's a fresh departure from my uneven Vista experience. And I'm really digging the new task bar, especially the various Aero "peek" functions. Definitely one of the more poorly understood features of the new Windows.

Bottom Line: Bugs or no, I think I'll stick around for a while -- if for no other reason than I really like that new task bar. Once you fully embrace it -- and this means using the default configuration with the big, grouped icons and no text labels -- you'll find that it's quite a bit more efficient to use than the old task bar.

I'll talk more about this next week. In the meantime, good luck downloading those beta bits!

Subscribe to the Best of TechHive Newsletter

Comments